Feature #28166

Increase camp capture radious ( so AI can capture )

Added by Rubber over 3 years ago. Updated over 3 years ago.

Status:Closed Start date:01/27/2012
Priority:Normal Due date:
Assignee:Benny % Done:


Target version:Warfare BE 2.072
Affected Version: I am using some Mods:No
Affected ArmA II version: Reproducible for you:No


atm, the camp radious works only if you're really close or inside the camp, we play with all camp needed to capture a town and we appreciate if controlled AI can capture the camp, with current settings AI really capture is really rare because the AI doesn't enter in the camp and can't capture it unless for some reason (rare) the ai will stand closer and capture the camp

I think that +5 meter radious will be ok for this purpose



Updated by Qazdar over 3 years ago

Only for AI if possible,but not for humans.

Updated by Rubber over 3 years ago

Qazdar wrote:

Only for AI if possible,but not for humans.

I think that 5m radious (10m around the center of the camp 3d model I suppose ) doesn't affect gameplay for humans, safe spot is inside the camp not 3/4m on it's side, instead of if we raise to 15m radious we can improve the gameplay also for humans.

City depot can be captured in a radious of 40m mean 80m around (diameter) sorry if my english is not perfect
why for capture a camp you're forced to be inside? Enemy just trow HE grenades or shot and kill you, a radious of 15m allow you to find a cover in alternate place and make camp capture little bit different and force defender to search around, not just shot inside it.

By the way, I've read here that MrNice Guy is changing the way of city capture works so maybe this will be outdated in next release,

If the camp still there, please make the capture radious area bigger for better gameplay and better use of AI

Please note that, we play with all camp needed to capture a town, this mean fight, because if you use camp just as respawn you don't need to capture all, with Officer Mash or Ambulance, you can capture or not, you can just fight in the town central area to capture town. We esperienced very better PvP action if you're forced to take all camp, and with this param, increased capture area for camp will improve gameplay.

You give me a big idea :) play without camps ! we will test tonight ;)!!

O.T. nice tutorial on mando stuff, hope that you will like that I've upgraded the included 096 with last 102 I'm tweaking last thing and I will send to Benny in order to include on 2072

Updated by Qazdar over 3 years ago

We made some games on XR server without camps a few months ago,but we suffered a lot of problems due to lack of re-supply possibilities ... so maybe in next versions (wf3 especially) we will have some kind of outposts.

Updated by Benny over 3 years ago

  • Status changed from New to Closed
  • Assignee set to Benny
  • % Done changed from 0 to 100

AI Capture radius has been increased while player capture radius remain the same, the setting can be modified with those variables:

missionNamespace setVariable ["WFBE_C_CAMPS_RANGE", 10];
missionNamespace setVariable ["WFBE_C_CAMPS_RANGE_PLAYERS", 5];

Also available in: Atom PDF