Bug #28097

programm doesnt start at windows 7 64bit with java 6 update 30

Added by K707 over 3 years ago. Updated about 3 years ago.

Status:Closed Start date:01/24/2012
Priority:Normal Due date:
Assignee:Major_Shepard % Done:

100%

Category:-
Target version:-

Description

programm doesnt start at windows 7 64bit with java 6 update 30
i cant run the LEA on my PC
I think it is problem with Java, so it will be great if you port this programm on microsoft Netframework for example

mac7.rar (3.8 MB) K707, 01/27/2012 18:14

History

Updated by Major_Shepard over 3 years ago

K707 wrote:

programm doesnt start at windows 7 64bit with java 6 update 30
i cant run the LEA on my PC
I think it is problem with Java, so it will be great if you port this programm on microsoft Netframework for example

You MUST run LEA with Administractor priviledges. There is nothing to see with Java. This is Windows Seven restriction.

I will see for auto elevate privilege of LEA when running lea.exe, see #28091

Updated by K707 over 3 years ago

Major_Shepard wrote:

K707 wrote:

programm doesnt start at windows 7 64bit with java 6 update 30
i cant run the LEA on my PC
I think it is problem with Java, so it will be great if you port this programm on microsoft Netframework for example

You MUST run LEA with Administractor priviledges. There is nothing to see with Java. This is Windows Seven restriction.

I will see for auto elevate privilege of LEA when running lea.exe, see #28091

it doesnt help me. On my PC this programm doesnt start even from admin rights

Updated by Major_Shepard over 3 years ago

  • Status changed from New to Closed

Updated by Major_Shepard over 3 years ago

it doesnt help me. On my PC this programm doesnt start even from admin rights

Re-install your Java with last version 7. http://www.oracle.com/technetwork/java/javase/downloads/jre-7u2-download-1377135.html

Updated by K707 about 3 years ago

Major_Shepard wrote:

it doesnt help me. On my PC this programm doesnt start even from admin rights

Re-install your Java with last version 7. http://www.oracle.com/technetwork/java/javase/downloads/jre-7u2-download-1377135.html

i did so, but it is still no progress

Updated by Major_Shepard about 3 years ago

In LEA installation folder run "lea.bat" file. Copy paste here the text displayed in console.

Updated by K707 about 3 years ago

Major_Shepard wrote:

In LEA installation folder run "lea.bat" file. Copy paste here the text displayed in console.

Exception in thread "main" java.lang.NullPointerException
at com.sun.java.swing.plaf.windows.XPStyle.getTypeEnumName(Unknown Sourc
e)
at com.sun.java.swing.plaf.windows.XPStyle.getBorder(Unknown Source)
at com.sun.java.swing.plaf.windows.WindowsLookAndFeel$XPBorderValue.getX
PValue(Unknown Source)
at com.sun.java.swing.plaf.windows.WindowsLookAndFeel$XPValue.createValu
e(Unknown Source)
at javax.swing.UIDefaults.getFromHashtable(Unknown Source)
at javax.swing.UIDefaults.get(Unknown Source)
at javax.swing.MultiUIDefaults.get(Unknown Source)
at javax.swing.UIDefaults.getBorder(Unknown Source)
at javax.swing.UIManager.getBorder(Unknown Source)
at javax.swing.plaf.basic.BasicTextUI.installDefaults(Unknown Source)
at javax.swing.plaf.basic.BasicTextUI.installUI(Unknown Source)
at javax.swing.JComponent.setUI(Unknown Source)
at javax.swing.text.JTextComponent.setUI(Unknown Source)
at javax.swing.text.JTextComponent.updateUI(Unknown Source)
at javax.swing.text.JTextComponent.<init>(Unknown Source)
at javax.swing.JTextField.<init>(Unknown Source)
at javax.swing.JTextField.<init>(Unknown Source)
at com.lea.ui.mission.AmmoPanel.<init>(AmmoPanel.java:402)
at com.lea.main.Lea.main(Lea.java:61)

Updated by Major_Shepard about 3 years ago

Do you use a theme modification for Windows 7? If not do you use Aero? Classic theme ?

Updated by Major_Shepard about 3 years ago

  • Status changed from Closed to New
  • Assignee set to Major_Shepard
  • Target version set to LEA v1.2

Updated by K707 about 3 years ago

Major_Shepard wrote:

Do you use a theme modification for Windows 7? If not do you use Aero? Classic theme ?

I use mac7 theme

Updated by Major_Shepard about 3 years ago

K707 wrote:

Major_Shepard wrote:

Do you use a theme modification for Windows 7? If not do you use Aero? Classic theme ?

I use mac7 theme

The problem come from the use of this theme. Try desabling it. Could you give me a link to get it?

Updated by K707 about 3 years ago

Major_Shepard wrote:

K707 wrote:

Major_Shepard wrote:

Do you use a theme modification for Windows 7? If not do you use Aero? Classic theme ?

I use mac7 theme

The problem come from the use of this theme. Try desabling it. Could you give me a link to get it?

here it is --->

Updated by K707 about 3 years ago

K707 wrote:

Major_Shepard wrote:

K707 wrote:

Major_Shepard wrote:

Do you use a theme modification for Windows 7? If not do you use Aero? Classic theme ?

I use mac7 theme

The problem come from the use of this theme. Try desabling it. Could you give me a link to get it?

here it is --->

Oh, great it launched when I set the default Windows7 theme. So there is problem with fonts, may be.

Updated by Major_Shepard about 3 years ago

Oh, great it launched when I set the default Windows7 theme. So there is problem with fonts, may be.

The problem is that the theme you use is bugged. You may expect crashes with other software.

Updated by K707 about 3 years ago

Major_Shepard wrote:

Oh, great it launched when I set the default Windows7 theme. So there is problem with fonts, may be.

The problem is that the theme you use is bugged. You may expect crashes with other software.

thank you very much for your help, you have done a great job

Updated by Major_Shepard about 3 years ago

  • Status changed from New to Closed
  • Target version deleted (LEA v1.2)
  • % Done changed from 0 to 100

Also available in: Atom PDF