Bug #28033

Default gear for rucks not being added from config when playing on dedicated server

Added by Tweet over 3 years ago. Updated over 3 years ago.

Status:Closed Start date:01/21/2012
Priority:Normal Due date:
Assignee:Sickboy % Done:

100%

Category:Script
Target version:1.14
Component:sys_ruck Affected Version:
Close Reason:

Description

After I initially reported that https://dev-heaven.net/issues/27103#change-120677 was indeed solved, it turns out there are still issues in MP.
I must have only tested in SP, my apologies for this.

In SP everything works fine but in MP on a dedicated server the default ruck gear isnt loaded from the config.

I took a look at the scripts from ace_sys_ruck and since in both fnc_AddMagToRuck.sqf and fnc_AddWepToRuck.sqf a local event was raised to update the ruck gear I suspect that needs to be a global event.

So I am suspecting that is where the issue lies, not sure since I am not that familiar with how ACE works internally.

Sorry for the inconvenience by reporting the issue as solved when I only tested it in SP.

Nothing shows up in the RPT files so I didn't add one, if needed I can provide one.

ace_sys_ruck-#28033-fixed.7z (15.6 MB) Sickboy, 01/23/2012 20:19


Related issues

related to A.C.E. for OA - Feature #27103: Default gear for rucks isn't added when a secondary weapo... Closed 12/16/2011 04/29/2012

Associated revisions

Revision 926ac0b9
Added by Sickboy over 3 years ago

Workaround for RuckFromConfig not working in MP deddy. fixes #28033

History

Updated by tcp over 3 years ago

Those local events are for external scripts to hook into. They don't do anything in ACE.

Updated by Tweet over 3 years ago

tcp wrote:

Those local events are for external scripts to hook into. They don't do anything in ACE.

ah ok, I just assumed they were used since the script putting gear into backpacks on init is fnc_initRuckFromConfig.sqf, which calls for fnc_PackWeapon.sqf which then calls FUNC, so I assumed that FUNC referred to fnc_AddWepToRuck.sqf

Updated by rocko over 3 years ago

  • Target version changed from TBD to 1.14

Updated by Sickboy over 3 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Updated by Sickboy over 3 years ago

The attached file should workaround the issue, please confirm.

Hopefully can do better analysis soon and implement a real fix, as currently the adding is delayed until after the briefing at least.

Updated by Sickboy over 3 years ago

  • Status changed from Resolved to Closed

Updated by Sickboy over 3 years ago

Available as hotfix on the Six Updater network. Please run Verify and Repair on the ACE preset.

Updated by Tweet over 3 years ago

Confirmed working on dedicated server, thx :)

Also available in: Atom PDF