Bug #27689

OPFOR aircraft AI gunners shoot automatically even when manual fire is selected.

Added by Qazdar over 3 years ago. Updated about 3 years ago.

Status:Closed Start date:01/11/2012
Priority:Normal Due date:01/24/2012
Assignee:- % Done:

0%

Category:AI Control
Target version:1.62.95248
Affected ArmA II version:1.61 Beta First affected build:Please Specify...
Reproduced by another DH user:No First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

Tried with many OPFOR planes, but it can be tested with SU34 and also MI-24:

Repro
  1. In editor add a SU34 and add to it a "Helibomblauncher" and "2rnd_fab_250"
  2. Place some enemy vehicles on the map
  3. Start the mission
  4. Switch to manual fire.
  5. Target enemies using different weapons starting by S8 rockets, then FAB bombs. (you to aim the target to get the result)

Obs
AI gunner will shoot Rockets and Bombs even when "manual fire" is set.

Exp
AI shouldn't shoot on its own when "manual fire" is active.

This confuses the player pilot seeing their ammo spent twice as fast.

27689.utes.7z (1.1 kB) kju, 01/11/2012 11:22

Ka-52.utes.7z - Moved to Utes (1.2 kB) kju, 01/14/2012 07:46

History

Updated by kju over 3 years ago

  • Assignee deleted (kju)

Updated by Fireball over 3 years ago

  • Due date set to 04/11/2012
  • Status changed from New to Assigned
  • Affected ArmA II version set to 1.60.87580
  • Reproducible for you changed from No to Yes

Updated by kju over 3 years ago

  • Description updated (diff)
  • Affected ArmA II version changed from 1.60.87580 to 1.61 Beta

Updated by kju over 3 years ago

  • Due date changed from 04/11/2012 to 01/24/2012
  • Status changed from Assigned to Feedback
While I can confirm that the Su34 ignores the "manual fire" command, aka he continues to fire the S8 rockets regardless,
your ticket is a mess:
  1. What other OFPFOR planes have this issue? Only the Su34 as far as I can tell.
  2. No other plane nor chopper seems affected from my tests.
  3. What is the point of adding bombs?

Updated by kju over 3 years ago

Repro
  1. Load mission in editor
  2. Play as pilot of the Su34
  3. Select "manual fire"
  4. Aim the plane's noes at hostile targets
  5. Notice how the AI gunner fire the S8 rockets despite "manual fire" active

Updated by kju over 3 years ago

  • Description updated (diff)

Updated by Qazdar over 3 years ago

Most of tickets i make are from my Job's comp,that's why i can't provide repro missions.

Adding bombs to su34,because in some missions you can change plane's armament and place bombs instead of ch29 or r73.

And also because MI24P has 2 FABs and same problem is happening with it.

Updated by Qazdar over 3 years ago

  • Description updated (diff)

Updated by Fireball over 3 years ago

  • Subject changed from OPFOR planes' AI gunners shoot automatically even when manual fire is selected. to OPFOR aircraft AI gunners shoot automatically even when manual fire is selected.
  • Description updated (diff)

So you're saying, if you do not add the bombs, it works as expected with S8 rockets?

Updated by Suma over 3 years ago

Is this a new problem, or something which has been this way for a long time?

Updated by kju over 3 years ago

Also in 1.60. No idea about before.

Updated by Qazdar over 3 years ago

No, the problem is old and occurs with or without FABs

I added FABs to make one test for two vehicles (su34 and mi24P),so you can try with both separately (su34 and mi24P)

Updated by Suma over 3 years ago

  • Status changed from Feedback to Resolved

I have reproduced it with Su34 (the only two seater airplane I know in A2OA, if there are some other, they would be affected as well), but not with Mi24V or other helicopters (and this makes sense, as manual fire was already handled for them properly in the code).

Fixed for airplanes in 88015

Updated by kju over 3 years ago

  • Target version changed from 1198 to Upcoming version

Updated by kju over 3 years ago

  • Status changed from Resolved to Closed
  • Target version changed from Upcoming version to 1.61 BETA

works

Updated by Vipera over 3 years ago

I would like to disable weapon automatic switch by AI gunner in Ka-52 for Auto fire too. I cannot enforce AI gunner to shoot cannon to infantry until he finished all missiles. And he fires too many missiles to infantry.

Updated by Vipera over 3 years ago

  • File Ka-52.Chernarus.rar added

I'm not sure this is the same issue as a topic but here is mission attached with Ka-52. In this mission you fly Ka-52 as a pilot and you want to engage enemy infantry using only cannon. But AI pilot constantly switches from canon to missiles.

Updated by kju over 3 years ago

  • File deleted (Ka-52.Chernarus.rar)

Updated by kju over 3 years ago

  1. Your wish has no relation to this, now fixed, bug
  2. You need to switch to manual fire if you want to tell the gunner what to do / to have full control

Updated by kju about 3 years ago

  • Target version changed from 1.61 BETA to 1.62.95248

Also available in: Atom PDF