Bug #27635

Can't lock on laser target

Added by messiah about 3 years ago. Updated about 2 years ago.

Status:Rejected Start date:01/08/2012
Priority:Normal Due date:
Assignee:Nou % Done:

0%

Category:Review
Target version:-
Component: Affected Version:1.13
Close Reason:

Description

OBS
It is currently not possible to lock on laser target using Harrier GBU bombs.

EXP
You should be able to use "Lock" key to lock on any laser target.

REPRO
I've attached demo mission. Try with ACE and without ACE.

COMMENT
I didn't test other units/ammo, which can lock, but I guess they are also affected.

lasertargettest.utes.rar (689 Bytes) messiah, 01/08/2012 20:18

History

Updated by messiah about 3 years ago

  • Affected Version changed from 522 to 1.13

wrote build number instead of version (build 522)

Updated by rocko about 3 years ago

  • Status changed from New to Rejected
  • Target version deleted (TBD)
  • Close Reason set to By design/Not a Bug

AFAIK they track the lasertarget (given valid laser code is used) on their own. No need to lock.

Updated by messiah about 3 years ago

Roger. I'll do more extensive tests. Currently personally I did only this one test, but other people, who fly frequently in our community, claim that something is wrong. There is a suspicion, that issue is not related to lasers or vehicles, but bombs (missiles lock on and hit target).

Updated by rocko about 3 years ago

  • Assignee set to Nou

Updated by rocko about 3 years ago

Nou is responsible for the laser guidance stuff. Maybe he knows better than me.

Updated by Huggy about 3 years ago

Laser guided bombs still hit the intended target, didnĀ“t had any problems yet.
No lock is required as long as the laser code us correct as Rocko pointed out.

The seeker only as a limited field of view which requires more planning by the pilot

Updated by messiah about 3 years ago

Just tested A10 and Harrier in multiplayer and indeed everything works, but it is very hard to determine when to drop bomb for it to lock on laser. There are no indicators for pilot. How should one know when to drop?

Updated by Huggy about 3 years ago

messiah wrote:

but it is very hard to determine when to drop bomb for it to lock on laser. There are no indicators for pilot. How should one know when to drop?

Expierience + good co-ordination with the ground forces makes a good, effective pilot.

Predict the rough impact point by altitude, speed and orientation of your plane, then you will hit since the window of the seeker is not that small.

Updated by Sickboy about 3 years ago

Any info available on if there should be indicators when to launch, or how pilots otherwise do this?

Updated by rocko about 3 years ago

In the real thing, the point where you (in case of self-designating) point your laser from the TGP, is marked as SPI which is displayed on the HUD and is used by the computer to calculate the correct solution for CCIP or CCRP release modes.

Basically you're not actually locking THE lasertarget but inputting the coordinates of the lasertarget for the computer and visualize the coordinates on the HUD.
The bomb actually does seek the laser on it's own (the target is not transferred from the aircraft to the bomb)

I guess the way it was in Arma, that you do "lock" the target is some sort of simplification to that process - have a visual indicator on the HUD. Though the bomb employment in Arma is very simple. Plus being a "lockable" target, it makes the LGB kind of "fire and forget" from everywhere, whereas in reality it is not (hence the calculation for the correct "release" point).

But because in ARMA and in ACE, there is only one way of using a LGB, which is the use of JTAC (in short: Using the SOFLAM from ground), the JTAC has to transmit the coordinates of the target to the pilot. The pilot then should mark the coordinates on the map for himself (Maybe setting up an individual Waypoint works [SHIFT + Mouseclick on the map] - and hope it shows up on the HUD).
This comes close to how it is in reality. Though the Pipper for CCRP and CCIP is missing ...

Updated by messiah about 3 years ago

Can you please advice which config value is responsible for this feature?

Updated by messiah about 3 years ago

Please? :)
Our pilots are struggling hitting targets...

Updated by Sickboy about 3 years ago

Hey messiah - perhaps best create a new support ticket, assigned to Nou, instead of using this rejected and 'hidden' ticket :P

Updated by BlackjackD about 2 years ago

  • Category set to Review
  • Close Reason deleted (By design/Not a Bug)

As suggested by Sickboy in the last post in this topic, this matter really has never been actually resolved with certainty, and has generated numerous independant bug reports, having been signed off for various reasons to include: lack of input, AI solved the problem, and by-design.

I do not believe that it was "by-design" that we would remove a primary means to deliver laser guided bombs (by a human (Forward Air Controller) designating the target with a SOFLAM ).
This issue is being re-submitted in [[https://dev-heaven.net/issues/67889]] in an attempt to regain functionality that has been lost from the vanilla version - the ability for two human players to coordinate an attack by GBU's with a ground GLTD SOFLAM desinator. This is not a problem with AI...it only represents itself when two humans are involved in the targeting process.

Also available in: Atom PDF