Bug #2755

My team refuse to join me in formation

Added by zombiemod almost 8 years ago. Updated over 7 years ago.

Status:Closed Start date:07/11/2009
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:AI Issues
Target version:1.05.62017
Affected ArmA II version:1.04.59026 First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods: Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you: NGUrl:
Related to content of DLC: WIKIurl:

Description

In the map editor, I placed Razor Team on the map in Chernovorsk, made Sykes the leader (player) and put the AI through its paces.

As you can see, the AI doesn't do very well when in DANGER mode. When ordered to STAY ALERT they rejoin me fine.

Video of bug here:
http://www.youtube.com/watch?v=R7Z4jiFyLHc

And continuation -
http://www.youtube.com/watch?v=B5l7v2FHDj0

This is an extremely serious bug - I could lose my team because they don't move when I tell them to.

formationpriority.utes.zip - Alternative Showcase-Mission (Not by original reporter) (1.1 kB) lwlooz, 11/05/2009 20:18

formationpriorityM.utes.zip - Mission with MarkerScript (4.9 kB) lwlooz, 11/13/2009 18:05


Related issues

related to ARMA2 Community Issue Tracker - Bug #2551: Suicidal Group leader Closed 07/04/2009

History

Updated by fabrizioT almost 8 years ago

In this case leader = player, but to me this issue sounds somewhat related to:
http://dev-heaven.net/issues/show/2551

Updated by zGuba almost 8 years ago

  • Status changed from New to Duplicate

Please post Your reports in #2551

Updated by zombiemod almost 8 years ago

zGuba - how can it be a duplicate?

I was standing still, telling them to get back into formation - it is little to do with team leader getting too far ahead of troops!

Updated by zGuba almost 8 years ago

It is duplicate. Same thing applies to AI and player controlled teams.

Updated by zombiemod almost 8 years ago

OK, if you are absolutely sure it's the same issue - I think it's more an AI pathfinding issue myself.

Updated by zGuba almost 8 years ago

I guess that pathfinding is similar for every mode, the formation FSMs care about unit's choices. It looks like an condition error, so the team members do not proceed the same way they would as single units.

Updated by Suma over 7 years ago

  • Status changed from Duplicate to New
  • Difficulty set to Not set
  • Reproduced by another DH user set to No
  • CPU set to Please specify!

Does not sound like a duplicate to me. Leader is not moving anywhere in this case.

Updated by zGuba over 7 years ago

  • Due date set to 12/11/2009
  • Status changed from New to Assigned
  • Affected ArmA II version changed from 1.02.58134 to 1.04.59026
  • Reproduced by another DH user changed from No to Yes

Updated by Suma over 7 years ago

  • Status changed from Assigned to Feedback

Repro mission on Utes would come very handy.

Updated by lwlooz over 7 years ago

I too believe this to be related to Issue #2551
It unfortunately is not a clear bug that either breaks or doesn't , but more of an design/AI tweakage problem.

From studying the video linked in the original post , it seems AI is slow in adapting to what its leader wants , rather than not following the orders at all for an infinite time.
In the attached mission "formationpriority.utes" I tried to create reproduction-routines that try to highlight the problems on Utes:

1. Run/Jog along the road towards the "Wait"-Marker(Next to the T-Intersection and the big ole tree) ,
switch to 3D-"Command Mode" [Default: Del on the Numpad] and watch your AI teammates.
2. Same Procedure as in "1." , but this time issue "Fall Back in Formation"(1-1) to your team everytime you come past a telephone/electricity/lamp pole.
Keep Issuing the command in the same intervals once you stopped at the "Wait"-Marker.
3. Same Procedure as "2." , but once arrived at the "Wait-Marker" , additionally order your Nr.2 AI to move to the tree next to you.

What one observes in "1." is the AI in combat mode gives little priority to the position of the leader. Keeping Formation has little priority to them.
What one can observe in "2." and "3." is that those commands slightly give the AI more priority of following you orders ,
but very quickly they get stuck in their "scripted"-routine of providing cover and running to next again.

In all three routines the AI can get stuck on a spot for prolonged times or choose cover that is not in the path towards their next waypoint.
It is also obvious that this is more in a problem in towns than in the open.
This "scripted"-routine can also lead to the AI being spread extremely without them able to cover each other.

I assume the underlying problem for this are following FormationFSM-Functions used by all soldier-classes derived from CAManBase as defined in the characters.pbo:
A) searchPath with the Parameters {10,5}
B) formationProvideCover
Knockout-Formation-FSMs without those 2 states effectively removed the "scripted"-routine, hence why it is assumed they are responsible for it.

Therefore it doesn't seem to be a problem that is based on the fact the leader is a player , but due to the leader AI performing the same "Cover&Search Cover"-Routine
most of the time , it is probably less visible in Issue #2551.
As one can see in the video or in the attached showcase mission , the problem of the implemented design arrives when the human leader of an AI squad wants to move quickly.

I come to the conclusion that this is an unfortunate design issue that needs fixing nevertheless.
The main problem here is that the AI does not value their human leaders orders enough(Fall Back,Move) and that the position of the leader is completly ignored.
A possible solution to this could be to increase the cost of providing cover and searching for cover everytime a player issue the mentioned commands.
This cost decreases over time , meaning the longer the player does not issue command , the more autonomous the AI becomes.
The cost is also increased the further away the leader unit is , and this should be tweaked to make sure the AI does not get seperated from its leader ,
but can search good cover without always having to stick to the formation-place they are supposed to have according to the offset.
(Again,they will move to their formation place if you increase the cost of them acting on their initiative by issuing a "Fall Back" order).

A secondary problem is that the interface does not provide any tool to let the leader determine if he wants "scripted"-routines to work or not.
You can not decide if you want your AI to use buddy teams or if you want them to just move as cohesive fireteams(once that will work in the future).

Updated by Suma over 7 years ago

  • Status changed from Feedback to Resolved

Should be a lot improved in 60129 - please, verify.

Updated by kju over 7 years ago

  • Due date changed from 12/11/2009 to 11/27/2009
  • Target version set to 1.05 BETA

Updated by kju over 7 years ago

  • [60129] Fixed: AI subordinates now move faster (use less cover) to catch up when leader is way ahead of them.

Updated by Suma over 7 years ago

From http://forums.bistudio.com/showpost.php?p=1488134&postcount=1688:

While seeing slightly better behaviour, it is unfortunately still not fixed.

Times to Form-Up:

"Procedure #1":

3:30 in 1.04
2:40 in the 60129

"Procedure #2":

2:30 in 1.04
1.35 in the 60129

Effect needs to be at least doubled, especially as far as them caring about the distance to the leader is concerned. Too often they go to cover or wait for their buddy partner even so you are miles away still.

Updated by lwlooz over 7 years ago

Quote - "even so you are miles away still". Sorry for the Hyperbole.
It is actual a point worth discussing tho when the effect you coded in would fall off again. "Miles away" AI probably should use the full "Go to Cover&Provide Cover"-routine again.

But I have come to the conclusion that it is probably best to solve this problem that the the AI:
  • From 250m to 100m they probably should use the "Aware"-Behaviour-Movement just to help them catch up (unless temporarily fired on)
  • Does Not Provide Cover/Stay in Cover (Be Stationary) between 100m and 50m from their Formation Offset point.
    They may run from cover to cover , but they should not stay there for any prolonged time.
  • Has a "Cover"-Maximum Timeout time (The time they stay at one place) on which they move to the next Cover. This should be minimal for 50m and increase towards 0m.
  • Issuing the "Fall Back" Order should decrease the distance limits described above. So repeated useage would result in the AI subordinates going to the Formation Offset Point ever so more urgently , the extremest form them moving like in "Aware" (unless temporarily fired on).

Additionally I linked the same mission with a simple "Unit Tracking Script" for better visualization of what your subordinates do.
I would also like to highlight an additional problem that plays a role here.Reproduction as follows:

1. Start the mission "formationpriorityM.utes" and jog to the "1"-Marker.
2. Without stopping along the road go to the "Wait"-Marker
-> The AI remains mostly immobile until you have stopped

One can highlight the problem in a more extreme way by going between the "1"-Marker and the StartPoint while going past the immobile AI.
Because this happens every time the player moves , the AI accumulates a distance to the player everytime he/she moves , which aggravates the problem of them catching up.

Updated by Suma over 7 years ago

Effect should be a now lot stronger in 60180.

Updated by kju over 7 years ago

  • Due date deleted (11/27/2009)

Please try again with the new beta patch and report back:
http://www.arma2.com/beta-patch.php

Updated by lwlooz over 7 years ago

Observation:
1. No significant different unit cohesion for player-led AI compared to 60141 in used Test-Setups
Comment:
1. If better results unattainable , current behaviour may suffice

Observation:
1. AI remains mostly immobile while player is moving.
Repro:
1. Load FormationPriorityM.utes
2. Run towards the Marker with a "1" as Text
3. Run back to the Start-Point
4. Run towards "Wait"-Marker
Comment:
1. If AI moved while player moved , unit cohesion might be improved further.

Suggestion:
1. Possible Fix for "My team refuses to join me in formation" -> "Fall Back" command orders AI to go to their formation place without pause (unless interupted).

Updated by kju over 7 years ago

How about a demo mission / sample video and repro steps.
Or not possible to replicate somewhat properly?

Updated by Suma over 7 years ago

2. Without stopping along the road go to the "Wait"-Marker
-> The AI remains mostly immobile until you have stopped

Good observation. I have reproduced it. There was a bug in the formation keeping logic not reflecting paths leading into a cover in one function.

This is fixed in 61057

Together with one more measure which should keep AI subordinates moving more when leader is far, this reduced time to Procedure #1 to 1:30-1:50

Updated by kju over 7 years ago

Please confirm with new beta:
http://www.arma2.com/beta-patch.php

Updated by lwlooz over 7 years ago

Updates appreciated. Re-tested with 61062

AI following Human Leader (Automatic):
  • AI in Combat not moving while player is moving : FIXED
  • Distance checks: AI still picks spots for bounding overwatch too far from leader. No spot above 75m from formation position should be picked.
AI following Human Leader (On Order):
  • AI should really "Fall Back in Formation" on giving that order. No staying in spot, even in in firefight. System needed for fast regrouping in all situations.

Thanks for all the fixes and optimizations since 1.04 so far. The automatic formation keeping during COMBAT-Mode has been really improved.
I leave it at your discretion to close this if you are happy with it so far.
As pointed out unfortunately "My team refuses to join me in formation" still exists , but as this appears to be a much bigger task , I leave it to you if you are happy with the current situation for arma2 and want to work on it again at some later point.

Updated by kju over 7 years ago

  • Status changed from Resolved to Closed
  • Target version changed from 1.05 BETA to 1.05.62017

Lets close this. Feel free to reopen or file a new report,
if you (anyone) think it is not good (enough).

Also available in: Atom PDF