Bug #27409

Limited Gear Weapons wont be saved

Added by B1n4ry about 3 years ago. Updated about 3 years ago.

Status:Closed Start date:12/30/2011
Priority:Trivial Due date:
Assignee:- % Done:

0%

Category:Loadout
Target version:-
Affected Version:

Description

After taking a limited weapon
(which is written in common/client/gear/loadout.sqf -> limitedSquadGear (l.17) limitedGearList (l.18)
the Weapons list gonna updated 2 times, but then the taken weapons disapears and the old one gets saved.

Version 0.81a

No Mods activatet.

wf.wmv - Shows my problem (17.2 MB) B1n4ry, 12/30/2011 12:55


Related issues

related to Insurgency - Bug #27453: Change loadout system?! Closed 01/02/2012

History

Updated by Kol9yN about 3 years ago

  • Status changed from New to Assigned
  • Assignee set to Fireball

Thanks for report...

Updated by B1n4ry about 3 years ago

Kol9yN wrote:

Thanks for report...

No problem ;D

We noticed it, after i've added some Weapons (to be exact, all Arma 2 and OA Weapons xS)
Also i think, the limitedGearlist does not work properly. Because the only weapons which are limited are the FMG 148 Javelin (1) and the M24 Desert(2), even after adding all MGs and Sniperrifle from Vanilla+OA.

Whatever, i hope, that i could help you guys :D ;)

edit: I noticed that you added 2 types of SCAR H mags in common/defines.sqf -> 20Rnd_762x51_B_SCAR & 20rnd_762x51_B_SCAR.
What was strange, because after some testing i found out, that only 20rnd version works (also the SB [SD] version). But why?

Updated by Fireball about 3 years ago

  • Status changed from Assigned to Feedback

Until now it's by design:

Originally written by pogoman, I've seen that behavior for a long time and was asked about it too. Then I thought about it and understood why limited weapons should not persist, specially on public servers, so that one squad member could keep the precious sniper/AT weapon the whole time and nobody else could ever take on them, unless you join another squad and I thought, ok, fair enough.

But maybe for private servers (or well-admin'ed public servers) this could be made optional to persist/remember weapon selection also for limited gear. Would this be a deal?

Updated by B1n4ry about 3 years ago

The problem is, that these weapons are needed, so e.g. if your MG gunner take a hit, he cant give firesupport because he has a Mk16 after revive.

But when you can add it as a Parm, when i understood you right, it would be very cool :D

Updated by B1n4ry about 3 years ago

Allright, new problem.

We're testing Insurgency 1.50 right now, and i had a bug. I choosed a unit, which has a MG as first layout. Problem, i cant take an other weapon, because the Weaponlist is updating the whole time, nonstop! (like in the video)
Should i create a new tracker? I made a new vid, but cant uploaded right now.

Updated by Fireball about 3 years ago

B1n4ry wrote:

Should i create a new tracker? I made a new vid, but cant uploaded right now.

Yes, please create a new ticket!

Updated by B1n4ry about 3 years ago

Fireball wrote:

B1n4ry wrote:

Should i create a new tracker? I made a new vid, but cant uploaded right now.

Yes, please create a new ticket!

Done ;D

Updated by Kol9yN about 3 years ago

  • Status changed from Feedback to Closed
  • Assignee deleted (Fireball)
  • Priority changed from Normal to Trivial

- When loadout sys changed, no this problems again :)

Also available in: Atom PDF