Bug #27358

CWR2 Rescuepilot: Wrong debriefing text and no mission completion marker

Added by OMAC about 3 years ago. Updated almost 3 years ago.

Status:Closed Start date:12/25/2011
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:Missions
Target version:-
Close Reason: I am using some Mods:No
Affected Version: Reproducible for you:Yes
Affected ArmA II version:1.60.87580 Language:English

Description

Version Demo 3 (1.00.6800).

1) In Nogova SP scenario Rescuepilot, debriefing text is wrong in that references are made to A2 Razor Team (screenshot). However, correct text ("End of shift. Many lives were saved.") is also shown. A2 debriefing text should be removed.

2) After mission completion, no green completion marker is shown on scenario list. doneKeys and activeateKey statements are needed.

arma2oa_2011_12_25_14_16_56_290.jpg (182.6 kB) OMAC, 12/25/2011 21:37

History

Updated by Sander about 3 years ago

Debriefing error is reproducible

Completing the mission successfully adds the debriefing text for a default Arma2 campaign mission.

Problem Solution

Completing the mission gave exactly the same result as on the screen shot. Briefing.html was apparently adapted from the file in the folder C1_IntoTheStorm.Chernarus. Remove the line '<localized id="briefing.html_1_0"/>'.


The description.ext file requires the addition of a doneKeys statement, for example:

doneKeys[] = {"cwr2_sp_rescuepilot_key"};

In the mission folder add a line to returnToBase2.sqf before the line 'endmission "end1";' to activate the key:

activateKey "cwr2_sp_rescuepilot_key";

Updated by OMAC about 3 years ago

Possibly the Ground Strike mission also needs code for the completion marker (I have not tested that mission).

http://forums.bistudio.com/showpost.php?p=2083431&postcount=89

Updated by W0lle about 3 years ago

  • Status changed from New to Assigned
  • Assignee set to Mondkalb

Updated by OMAC about 3 years ago

Just a reminder that the Cobra Assault SP scenario also needs a completed marker (doneKeys/activeatekey).

http://forums.bistudio.com/showpost.php?p=2070929&postcount=152

http://forums.bistudio.com/showpost.php?p=2086489&postcount=99

Updated by OMAC about 3 years ago

Updated by W0lle almost 3 years ago

  • Status changed from Assigned to Closed
  • Assignee deleted (Mondkalb)

I'm closing this since "Rescue Pilot" was made by Mondkalb who obviously has no interest in fixing his work he did for us.

With my limited time these days I can't be bothered to analyze his mission and trying to fix it. Shame but blame Mondkalb for that. :-)

The mission won't be included in the final release. Please feel free to remove it from your Missions folder.

Updated by OMAC almost 3 years ago

W0lle wrote:

The mission won't be included in the final release.

Sorry to hear this.

Please feel free to remove it from your Missions folder.

Will do.

Updated by OMAC almost 3 years ago

It is a shame to throw away this nice mission just because of some silly minor issues with the debriefing.html and the donekeys. I think I could fix this mission in about 15 minutes, assuming that no other issues are present other than the ones I uncovered. Let me know if you'd like me to attempt a fix.

Also available in: Atom PDF