Feature #27107

weapon mode

Added by swed about 3 years ago. Updated about 3 years ago.

Status:Rejected Start date:12/17/2011
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:Gameplay
Target version:-
Affected ArmA II version:Please select... First affected ArmA II version:Please select...
Reproduced by another DH user:No Single / Multi Player?:
I am using some Mods:No BIForumURL:
I am using: NGUrl:
Reproducible for you:No WIKIurl:
Related to content of DLC:

Description

West Weapon mode starts on semi, East starts on full auto or burst

History

Updated by swed about 3 years ago

  • Category set to Gameplay
  • Assignee set to swed
  • Target version set to 1.60 BETA
  • Operating system set to Win7 64 bit

West fire mode starts on semi. East starts on full auto or burst

Updated by swed about 3 years ago

  • Assignee deleted (swed)

West fire mode starts on semi.East fire mode starts on full auto or burst

Updated by Qazdar about 3 years ago

swed wrote:

West fire mode starts on semi.East fire mode starts on full auto or burst

My tickets are not the best out there,but this one is very incomplete ...

You need to specify what you observed and what you expect ... it sounds idiot but this is the way to keep things clear.

Updated by swed about 3 years ago

i think East should start on semi fire mode like west

Updated by Colossus about 3 years ago

swed wrote:

i think East should start on semi fire mode like west

I tried to see if there was a bug with it but concluded it was as it should be. I used Utes' airfield as a testing ground. Placed some USMC units (equipped with M16A4s) on one side of the field, while I place Russian units (equipped with AK-74Ms) on the other side. Both sides used single shot (semi) as the distance between them were quite wast. I also tried it at close range and found out that the Russian used full and burst as much as the USMC units used burst. Keep in mind they don't go all spray & pray with the full and burst mode. The use the modes methodically. I get the same result by equipping USMC units with AK-74M and Russians with M16A4.

Fire mode depends on the weapon and range to the target, not the side it's being used in.
AK-series usually goes something like this SAFE-FULL-(BURST)-SEMI
And most M16s like the M16A4 goes SAFE-SEMI-BURST

It's quite simply a feature, not a bug.
Build used: 87411 & 1.59

Updated by Dwarden about 3 years ago

  • Target version deleted (1.60 BETA)

Updated by swed about 3 years ago

what i meant is this if you place a soldier in 2d editor as a player.then the weapons (automatic weapon)first fire mode on West is set to semi fire mode and East is set to full auto(this have nothing to do with AI) do you understand?

Updated by Colossus about 3 years ago

swed wrote:

what i meant is this if you place a soldier in 2d editor as a player.then the weapons (automatic weapon)first fire mode on West is set to semi fire mode and East is set to full auto(this have nothing to do with AI) do you understand?

I do understand, but I'm not sure if I can explain it to you. Like I said - It's the weapons; they are designed like this. M16A2, M16A4, FN SCAR and FN FAL starts in Semi because that's the first fire mode you get when you flip the "fire mode switch" on the weapons in real life. Russian AKM, AK-74, AK-107, etc. is designed to start on Full.

That's how they work in real life and that is why Bohemia Interactive have chosen to make them like this in-game.
I don't know what else to tell you, other then: Create some ammo crates in the 2D Editor from various factions (RU Basic Weapons, US Army Basic Weapons, US Basic Weapons, etc) and see how the different weapons work.

Updated by swed about 3 years ago

ok then im sorry.im so bf2 arcade´ísh

Updated by Fireball about 3 years ago

  • Status changed from New to Rejected

Also available in: Atom PDF