Bug #26814

Vehicles with a "doMove" command move very slowly

Added by GuessWho about 3 years ago. Updated about 3 years ago.

Status:Closed Start date:12/04/2011
Priority:Normal Due date:03/01/2012
Assignee:Dwarden % Done:

0%

Category:AI Issues
Target version:1.60.87580
Affected ArmA II version:1.60 RC First affected build:1.60 RC
Reproduced by another DH user:Yes First affected ArmA II version:Please select...
I am using some Mods:No Single / Multi Player?:
I am using:CO (OA+A2) BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

After 1.60 RC all vehicles with a "doMove" command only move at a very slow pace. Helos fly at an infantry jogging speed, wheeled vehicles are a little faster. Vehicles with a normal waypoint act normally.

Starting beta build 86873 over the installed 1.60 RC sets everything to normal.

NORRN_aerialTaxi061.utes.rar - Norrin' Aerial Taxi v0.61 (33.8 kB) GuessWho, 12/04/2011 09:11

History

Updated by kju about 3 years ago

  • Category set to AI Issues
  • Status changed from New to Feedback

Please provide a simple demo mission or repro steps with a BI one.

Updated by GuessWho about 3 years ago

I attached Norrin' Aerial Taxi v0.61. Maybe it's too complex, but it shows the issue very well.

Repro:
Start the mission in editor, you'll find yourself at the Utes runway with two helos, MH60 and AH-64D
Wait for the hint message "extraction action added"
Use the action menu "Call chopper extraction"
Go to map mode and click at the other end of the runway, extraction marker appears on the map
Close the map and watch the two helos on their way to the assigned destination

Observation:
The helos start and head to their destination with "jogging speed". You can easily follow on foot.

Expected:
The helos should take up normal speed.

Counter indication:
Run the same scenario with build 86873. You shall see the difference

Updated by thhamm about 3 years ago

Got the same here, it looks like the units try to keep formation now, regardless of "doMove" or "setSpeedMode".

Updated by kju about 3 years ago

  • Due date set to 03/01/2012
  • Assignee set to Dwarden
  • Operating system deleted (Win7 64 bit)
  • Graphics card deleted (5870)
  • Graphics card driver version deleted (10.4)
  • Reproduced by another DH user changed from No to Yes
  • CPU changed from i7 to i
  • Mainboard chipset deleted (X58)
  • System RAM size deleted (6)
  • GPU VRAM size deleted (1)
  • Reproducible for you changed from No to Yes

ty

Updated by Suma about 3 years ago

  • Status changed from Feedback to Resolved

Caused by fix

[86880] Fixed: Helicopter slow after GET OUT waypoint when CYCLE was used as well.

The movement was slow for helicopters with no waypoints at all.

After 1.60 RC all vehicles with a "doMove" command only move at a very slow pace. Helos fly at an infantry jogging speed, wheeled vehicles are a little faster.

I cannot see any issues with wheeled vehicles (and the bug fixed above was related strictly to helicopters).

Updated by Dwarden about 3 years ago

  • Target version set to 1.60.87580

Updated by GuessWho about 3 years ago

confirm fixed in build 86978

Updated by Dwarden about 3 years ago

  • Status changed from Resolved to Closed

closing then

Also available in: Atom PDF