Bug #2671

Object rendering distance != view distance

Added by Vortrog almost 6 years ago. Updated about 3 years ago.

Status:Closed Start date:07/08/2009
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:Config
Target version:1.05.62017
Affected ArmA II version:1.04.59026 First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:No NGUrl:
Related to content of DLC: WIKIurl:

Description

This issue has been identified on the BIS forums by others, but it is irritating.

Currently, the game will show a s visible terrain and static objects at the setviewdistance by the user (ie default 1600m) however will not render vehicles or units until you reach approximately 70% of that distance (approx 1000m of the default).
If flying a AH for instance, you can target a UAZ for instance within the viewdistance range, yet will not be able to view it UNTIL it is within the 70% of the setviewdistance.
This seriously impacts the effectiveness of Airborne support, and moreso air to ground support in aircraft in not being able to sight your target UNTIL you have nearly flown over it. (especially those with weaker video cards that cannot run the game at 4000m setviewdistance)

http://www.youtube.com/watch?v=ecYhUveecdg

aa2-10km.jpg - A2 10km VD (346 kB) zGuba, 10/12/2009 20:55

aa1-5km.jpg - A1 5km VD (329 kB) zGuba, 10/12/2009 20:55


Related issues

related to ARMA2 Community Issue Tracker - Feature #25092: Object View Distance Slider Assigned 10/02/2011
related to ARMA2 Community Issue Tracker - Bug #15293: The AI tank gunner should automatically switch to and use... Assigned 11/20/2010 10/28/2011
related to ARMA2 Community Issue Tracker - Bug #2650: Using the 2 Button (target acquisition) gives targets you... Expired 07/07/2009
related to ARMA2 Community Issue Tracker - Feature #5274: Make draw distance of ANY item configurable Assigned 10/18/2009
related to ARMA2 Community Issue Tracker - Bug #3807: clairvoyant AI Expired 08/19/2009 07/14/2010
duplicated by ARMA2 Community Issue Tracker - Bug #3884: Viewdistance and objects Duplicate 08/21/2009
duplicated by ARMA2 Community Issue Tracker - Feature #4504: Increase draw distance for all vehicles Duplicate 09/13/2009 10/13/2009

History

Updated by kju almost 6 years ago

  • Status changed from New to Assigned
  • Target version deleted (1.02.58134)

This is engine behavior since OFP.

Viewable distance is 66% of viewdistance (technical value). //object draw distance
Radar and locking works up to 100% of viewdistance.

In a2 there is also a max drawing distance of ~2000-3000 meter.

Very very unlikely to see this change - personal opinion!

Updated by zGuba almost 6 years ago

However I'd like to see it changed, since vehicles are of high importance to be drawn.

Updated by Whisper almost 6 years ago

Why would the 2km limit for vehicle drawing be unchanged? It kind of make the whole high view distance useless if you don't see the important things, ie vehicles.
Aiming at the base of some dust cloud because the actual object itself is not drawn is a bit odd

Updated by zGuba almost 6 years ago

IMO at least aircrafts and helicopters should be drawn from far distances, even exceeding the VD.

Updated by monark almost 6 years ago

I suggest this is made a user customizable variable set in percentage. I.e "Object drawing distance". At those distances LOD doesn't have to be very detailed, and by making it a percentage you avoid cheating. Example of wall-hack like cheat would be viewdistance=20 meters, objectviewdistance=2000 meters. Assuming you make the mistake of doing objectviewdistance independent of viewdistance.

Updated by alef over 5 years ago

  • Due date set to 10/08/2009

Updated by Chaos over 5 years ago

The problem can be very good seen with the command setting ´TT setFog X´. If the setting is ´10 setfog 0.5´, we can see trees/objects disappearing more hundret meters before the fog border.

Updated by Chaos over 5 years ago

Here is a good screen to demonstrate it. You can see in upper part of the screen the hills, with roads, but no trees, no objects. If we cannot see the trees, so we cannot see the roads - in real life.

http://www.armaholic.com/pfs.php?m=view&v=2661-arma22009-08-0702-55-39-00.jpg

BIS plz fix it !!!

Updated by zGuba over 5 years ago

  • Affected ArmA II version changed from 1.02.58134 to 1.04 BETA

Updated by zGuba over 5 years ago

  • Category changed from Visual to Config

Updated by zGuba over 5 years ago

  • Subject changed from Object Rendering distance /= setviewdistance to Object rendering distance != view distance
  • Affected ArmA II version changed from 1.04 BETA to 1.04.59026

Updated by Dwarden over 5 years ago

  • Assignee set to Dwarden
  • Reproduced by another DH user set to No

Updated by zGuba over 5 years ago

  • File aa2-10km.jpg added
  • File aa1-5km.jpg added
  • Due date changed from 10/08/2009 to 11/08/2009
  • Reproduced by another DH user changed from No to Yes

Got screenshots made with 3rd party island clearly explaining this issue.

Problem is both with config and world data.

Updated by zGuba over 5 years ago

  • File deleted (aa1-5km.jpg)

Updated by zGuba over 5 years ago

  • File deleted (aa2-10km.jpg)

Updated by Fireball over 5 years ago

  • Due date changed from 11/08/2009 to 12/08/2009

Updated by mr.g-c over 5 years ago

After Reading Sumas Developer-Blog Entry today, and especially how he says that the Multicore-Optimizations of Arma2 can actually draw more objects at the same time, without much performance breakdown, i wonder why we see exactly the opposite in Arma2?

Like others said, this is a must have fixed thing - even if its "only" modable by the communtiy (like Kju's approach did, but FULLY please @Bis)

Updated by kju over 5 years ago

You must be having difference finds than almost anyone else.

A1 worlds run way better than in a2. Everyone confirmed that for CAA1 so far.

You just seem to neglect that a2 has way more objects, that are
more complex, has way more detailed clutter, which is drawn further.

It is all down to your settings. Look into object details and terrain details.

Updated by Suma over 5 years ago

  • Status changed from Assigned to Resolved

The object rendering distance relative to view distance was significantly increased in 60522. Please, test how you like it now.

Updated by mr.g-c over 5 years ago

Suma wrote:

The object rendering distance relative to view distance was significantly increased in 60522. Please, test how you like it now.

I personally like it very much! ;-) Thanks!

Updated by zGuba over 5 years ago

Now it's OK, hence I still don't like fog occluding objects that still should be visible.

Updated by kju over 5 years ago

In short I am happy.

Yet to have objects drawing from within fog till 1500 VD setting
would improve the visual impression a lot.

Even better an extra slider for object drawing distance in addition
to viewdistance (terrain drawing distance and fogline).


Here are some videos using on of the recent betas to analyze fog behavior:

Object detail: normal

STANDART VD 500m STANDART VD 1000m STANDART VD 1500m STANDART VD 5000m
PROPER ODDT 500m PROPER ODDT 1000m PROPER ODDT 1500m PROPER ODDT 5000m

Object detail: very high

STANDART VD 500m STANDART VD 1000m STANDART VD 1500m STANDART VD 5000m
PROPER ODDT 500m PROPER ODDT 1000m PROPER ODDT 1500m PROPER ODDT 5000m

Concentrate on the buildings - vegetation is the same.

You can see:
  • For 500m VD for all the transition is very nice and seamless.
  • Above that for non PROPER ODDT the buildings pop in.
  • With the PROPER ODDT even with high VD its nice.
  • The tweak does NOT work on vegetation.
    You can see it pop it for single trees, or 'grow' for woods very clearly.

My say it would be huge, if BI could make objects come into view from
fog for 1500m viewdistance setting. Above is probably too extreme.

A slider to changing object drawing distance independent to viewdistance
would be best of course.

Updated by Fireball over 5 years ago

  • Due date deleted (12/08/2009)

Updated by INNOCENTandCLUELESS about 5 years ago

As I described in http://dev-heaven.net/issues/show/5274 I have not only visual problems with that issue.
It also has a severe impact to the gameplay. If the viewdistance is higher then the drawing-distance of vehicles but by default the drawing-distance of vehicles is smaller then the drawing-distance of vegetation the vehicles simply loose cover at far distance.

Pretty funny effect, you spot an enemy tank at a distant hill, at map it must be covered with trees, you attempt to kill it with your tank but grenades explode at invisible trees.

If this ticket should stay closed maybe we continue the issue with the relations between the different viewdistances of different objects in the other ticket?

Updated by kju about 5 years ago

  • Status changed from Resolved to Closed
  • Assignee deleted (Dwarden)
  • Target version set to 1.05.62017

Also available in: Atom PDF