Support #26685

Multiplayer Player Respawn

Added by Jman almost 4 years ago. Updated over 3 years ago.

Status:Closed Start date:11/29/2011
Priority:Normal Due date:12/30/2011
Assignee:- % Done:

80%

Category:-
Target version:-
Component: Affected Version:
Close Reason:

Description

We've been experiencing a strange issue in ACE for a while now. It's hard to repro as it seems to be quite random. The issue is that sometimes when a player respawns by pressing escape twice in multiplayer (normally when they are they are unconscious and there is no medic around) and respawn from the main menu the message appears in globalChat 'player x was killed' but they do not seem to jump back into their respawned player. If there is another player at the respawn area that player will see the respawned player standing there. If the respawned player tries the respawn command again the message appears in globalChat 'player x was killed' again and the player at spawn see that players character die and respawn but the respawning player still does not jump back into their respawned player.

The only way to then bypass the issue is the reconnect. I orginally thought that it might be my PDB scripts causing the issue but I don't see how. I am using a player eventhandler on respawn to setvariable 0 some player's damage vars. Could that cause issues?. I've tried it on respawn and killed evh's but the issue still happens randomly. I was not sure whether to report this as I cannot give any definite repo steps but I thought I'd put it out there anyway.

The issue happens whether or not the A2 beta is running.

History

Updated by Sickboy almost 4 years ago

  • Due date set to 12/06/2011
  • Status changed from New to Feedback
  • Assignee set to Jman

Ty.

The issue happens whether or not the A2 beta is running.

Does it occur with v1.60 betas (so true v1.60 version, not the older 1.59 compatible ones)?

Updated by Jman almost 4 years ago

Both, v1.60 version and older 1.59 compatible ones.

Updated by rocko almost 4 years ago

  • Target version set to 1.13

Updated by Sickboy over 3 years ago

  • Target version changed from 1.13 to 1.14

Updated by rocko over 3 years ago

  • Assignee deleted (Jman)

Updated by rocko over 3 years ago

  • Due date changed from 12/06/2011 to 12/30/2011
  • Close Reason set to Cannot reproduce

Updated by rocko over 3 years ago

  • Status changed from Feedback to Expired

We have no idea.

Updated by Jman over 3 years ago

It could be related to one of the PersistentDB eventhandler scripts we run in our ACE missions. It is intermittent though so trying to find the sequence of events prior to the issue happening is not clear to me yet. The PDB scripts run a HandleDamage and a Respawn eventhandler on the player but I can see no reason why the scripts called by these eventhandlers could be at fault.

Updated by Xeno over 3 years ago

Jman wrote:

The PDB scripts run a HandleDamage...

That's most likely the problem. Only one HD EH at once otherwise one will overwrite the other.

Updated by Jman over 3 years ago

Thx for the input Xeno, I'll look into it.

Updated by rocko over 3 years ago

  • Target version deleted (1.14)

Updated by Jman over 3 years ago

This ticket can be closed. Thank you.

Updated by Sickboy over 3 years ago

  • Tracker changed from Bug to Support
  • Status changed from Expired to Closed
  • % Done changed from 0 to 100
  • Close Reason deleted (Cannot reproduce)

Updated by Sickboy over 3 years ago

  • Status changed from Closed to In progress
  • % Done changed from 100 to 80

Actually Jman still experienced the issue.

Question Jman; are all your players up2date with the latest ACE hotfixes available on the SU network when running Verify and Repair?
I believe we recently solved an issue with the respawn dialog closing upon death, and making the player stuck.

Updated by Jman over 3 years ago

Yes clients are up to date with the latest ACE hotfixes.
I changed the handleDamage EVH to a dammaged EVH in the PDB scripts but the issues still occurs.

Updated by rocko over 3 years ago

Any last words before close?

Updated by Jman over 3 years ago

No. Please close it.

Updated by rocko over 3 years ago

  • Status changed from In progress to Closed

Also available in: Atom PDF