Bug #2658

Auto report can not be disabled

Added by osmo over 6 years ago. Updated over 3 years ago.

Status:Expired Start date:07/07/2009
Priority:Normal Due date:06/01/2011
Assignee:- % Done:


Category:Game settings
Target version:-
Affected ArmA II version:1.58.78473 First affected build:
Reproduced by another DH user:No First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using:OA only BIForumURL:
Reproducible for you:No NGUrl:
Related to content of DLC: WIKIurl:


The automatic reporting does not turn off even when expert level is selected.

When we play on a dedicated server our human controlled players (usually the group leader) keep on reporting whatever they see over the radio ("UNKNOWN HELICOPTER", etc).

In difficulty settings, the Auto Report should be disabled by default on expert level, but it just seems to be enabled always. We've tried this on several co-op missions.

automaticreport.jpg (8.9 kB) osmo, 07/23/2009 23:12


Updated by kju over 6 years ago

  • Status changed from New to Assigned

Was this the same or different in A1/OFP?

Updated by osmo over 6 years ago

This seems to be different, as in A1 it only happened to me when I right-clicked on an enemy and had the "reveal target" button still set to right mouse button from key configuration. This issue, however, happens just by looking around and not pressing anything (I have also disabled the key for reveal target so it could not be caused by that).

Here's an example. We start a co-op mission in which we have empty helicopters near me. I hear (and everyone else hears) immediately my soldier reporting "UNKNOWN HELICOPTER...". Then if I turn my head to the right where some vehicles have been placed, my soldier reports "UNKNOWN VEHICLE...", etc. Sometimes multiple reports after each other of different objects my soldier sees. These messages can be seen in text and heard in radio.

Someone told me in the Bohemia Interactive Forum that this is caused by something called "Auto report" which can be enabled and disabled from the game options difficulty settings. I personally have expert level selected and everything disabled. I also noticed that on expert level this "Auto report" can not even be enabled.

On a dedicated server, I believe the difficulty settings are set for everyone by the server's config and selected level in the mission selection screen. However, we have been playing the game on "Expert" level, which means that Auto report setting should automatically be disabled. If these radio/text reports that our human-controlled players are saying in our multiplayer sessions are really this "Auto report", then there must be some bug/error which causes these auto reports to be enabled even if the expert level has been selected.

Updated by osmo over 6 years ago

Here is a screenshot of one of those reports. It happens completely automatically and has text + radio report. Very annoying and kills the realism & atmosphere.

Updated by alef over 6 years ago

  • Due date set to 10/07/2009

Updated by Fireball about 6 years ago

  • Due date changed from 10/07/2009 to 09/18/2009
  • Status changed from Assigned to Resolved
  • Target version set to 1.03.58627

Updated by kju about 6 years ago

  • Due date changed from 09/18/2009 to 12/18/2009
  • Status changed from Resolved to Assigned
  • Target version deleted (1.03.58627)
  • Affected ArmA II version changed from 1.02.58055 server to 1.04.59026

Updated by zGuba about 6 years ago

  • Category changed from Multiplayer to Game settings
  • Reproduced by another DH user set to No

Updated by Dwarden about 6 years ago

  • Assignee set to Dwarden

Updated by CarlGustaffa almost 6 years ago

Old ticket but what the heck... Having disabled autoreport on server, there is a great improvement in battle on what is being reported - pretty much nothing except those who reports via reveal functionality. The reports seems to be coming in just after mission join (and respawn?) and are afaik always of the "unknown" type.

Updated by kju over 5 years ago

  • Due date changed from 12/18/2009 to 07/14/2010
  • Status changed from Assigned to Feedback
  • Assignee deleted (Dwarden)
  • Affected ArmA II version changed from 1.04.59026 to 1.05.62017
  • Audio card set to Please specify!
  • Size of OS swap file set to Please specify!

Updated by kju over 4 years ago

  • Due date changed from 07/14/2010 to 06/01/2011
  • Operating system deleted (WinXP 32 bit)
  • Affected ArmA II version changed from 1.05.62017 to 1.58.78473
  • CPU deleted (Please specify!)
  • Audio card deleted (Please specify!)
  • Size of OS swap file deleted (Please specify!)
  • I am using some Mods set to No
  • I am using set to OA only
  • Reproducible for you set to No

Can we please get exact repro steps on this one (server config with correct settings as well),
and a simple demo mission.

Updated by zGuba over 4 years ago

  • Status changed from Feedback to Expired

Also available in: Atom PDF