Feature #26555

RU Vehicle Ammo reloads player-controlled Metis/Konkurs, but not AI CSW

Added by maturin over 3 years ago. Updated over 3 years ago.

Status:Rejected Start date:11/24/2011
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:-
Component: Affected Version:
Close Reason:BIS / Engine problem

Description

Repro:

Place a Metis or Konkurs CSW in the editor, a meter or two from a RU Vehicle ammo crate.

Fire a missile and the CSW will begin to reload automatically.

The AI, however, cannot reload this way. They will simply sit with an empty tube, or exit the CSW.

This means that the AI can't be used with ATGMs effectively.

The AI should be able to reload their CSW with the appropriate crate, like players can.

History

Updated by Robalo over 3 years ago

Is the ACE module "CSW for AI" present ?

Updated by Sickboy over 3 years ago

  • Status changed from New to Feedback
  • Assignee set to maturin

The CSW is auto-reloading player-controlled CSW from the vehicle box if placed in the vicinity? That's interesting :O

Updated by maturin over 3 years ago

Vehicle Ammo reloads everything that doesn't go on two legs, from tanks to mortars.

CSW for AI does not make a difference in this case. I can't get the AI to reload on its own initiative, either using the Vehicle Ammo or a dedicated missile box.

I'm really just looking for a way to get the AI to reload tubes autonomously, without a player in the group, or a tone of scripting.

The gunner automatically exits the tripod after expending its missile. If AI group leaders could command him to re-arm from a nearby missile box and reload the tube automatically, that would be good to.

And now that I tested that, I'm running into further problems.

1) The CSW Konkurs Missile ammo box floats a meter off the ground.

2) My AI Konkurs gunner has injured himself and mysteriously died when firing on the Utes runway. It doesn't look like it is a backblast problem because I can fire the missileat maximum elevation on a flat surface without being harmed. It may be some clipping issue with the tripod when prone.

Updated by maturin over 3 years ago

Upon further testing, it appears that no CSW controlled by AI can reload using Vehicle Ammo crates. Mortars, HMGs, etc can only rearm by proximity if they are player-controlled.

So I guess this ticket should be a feature request: the CSW for AI module should allow static weapons to rearm from Vehicle ammo crates when controlled by AI. This would be an enormous help for mission makers, because I know of no simple way to restore ammo as it is expended by scripts.

Those two glitches with the Konkurs observed above still stand, however.

Updated by Sickboy over 3 years ago

Vehicle Ammo reloads everything that doesn't go on two legs, from tanks to mortars.

Yes but automatically ?? You / the AI always has to manually go to the box, and select "Reload from box" or not? In both Vanilla and ACE.

There are several AI addons out there incl VFAI, and ASRAI that have special AI-reloading scripts so AI can take ammo from boxes, could that be related?

Please do not mix multiple (unrelated) bug reports in a ticket, certainly not somewhere later in some comment.

Updated by maturin over 3 years ago

Yes, automatically. If a vehicle is in proximity with an ammo, health or fuel-restoring support truck or box, you will get replenished automatically. There is a little flashing message on the screen that says "Rearming." There is no way to do this manually from the box, as there is no item for health or fuel, and the RU Vehicle Ammo only contains PK magazines.

I'm not running any AI mods.

I was planning on making new tickets for the other glitches that showed up during testing.

Updated by rocko over 3 years ago

  • Target version set to 1.13

Updated by rocko over 3 years ago

  • Close Reason set to BIS / Engine problem

AI only reloads a magazine if the corresponding CSWDM is in the cargo of the vehicle.

NOT reloading via an ammotruck sounds like a BIS issue. However, keep in mind with CSW's you have to manually reload magazines. In Vanilla this is done automatically.
So I assume this is again a BIS issue, with AI not reloading muzzles (There is already another ticket about it - search if you like).

This issue should be reproduced in vanilla.

Updated by Sickboy over 3 years ago

AI only reloads a magazine if the corresponding CSWDM is in the cargo of the vehicle.

What about reload if CSWDM is in the gear of the unit? But I suppose same difference..

So I assume this is again a BIS issue, with AI not reloading muzzles

AFAIK this is only relevant for second muzzle on multi-muzzle weapons. The first muzzle afaik works fine for reloading?

If it's a BIS issue, perhaps ticket should become a feature request; "Workaround for AI not reloading Mortars" or so?

What is interesting is that the Metis/Konkurs work, but not mortar/mg?

Updated by rocko over 3 years ago

  • Tracker changed from Bug to Feature

Updated by rocko over 3 years ago

  • Target version changed from 1.13 to Planned (Needs Contributors)

Updated by rocko over 3 years ago

  • Status changed from Feedback to Rejected
  • Assignee deleted (maturin)
  • Target version deleted (Planned (Needs Contributors))

Seems to be an Arma bug. Support trucks do not reload AI controlled static AT weapons.

Updated by rocko over 3 years ago

Someone might want to create a CIT ticket?

Also available in: Atom PDF