Bug #26450

ACE Javelin not arriving at target

Added by edwood almost 4 years ago. Updated almost 4 years ago.

Status:Rejected Start date:11/19/2011
Priority:High Due date:
Assignee:edwood % Done:

0%

Category:-
Target version:-
Component: Affected Version:
Close Reason:By design/Not a Bug

Description

I've been playing with the Javelins and have concluded that they are not working properly. (Of course it is possible that I'm a noob).

I'm using ACE build 519.

Testing was done online on a multiplayer server, and while running various other mods.

Issue was replicated using 7-10 Javelins.

There are possibly two separate issues.

[1] - Javelin missile not arriving at target
After locking on to the target - as witnessed by the Square/Circle confirmation, I fire the Javeline, and the missile flies up, never to return to the earth.

[2] - Target locking and mode switching
a) Target locking is temperamental.
Target was in clear sight, and the Javelin would not enter seek mode and/or lock on to the target.

b) TAB is also used by default for mouse-gestures, and with this turned on, the player can not switch between direct and top modes as the mousegestures interface pops up instead.

This problem may, or may not have existed in a previous build - last time I fired a Javelin may have been some weeks ago.

This is also my first ever bug report, so I hope it's useful.

History

Updated by Sickboy almost 4 years ago

  • Status changed from New to Assigned
  • Assignee set to zGuba
  • Priority changed from Normal to High
  • Target version set to 1.13

Updated by Sickboy almost 4 years ago

Btw, please add the RPT file, thanks!

Updated by zGuba almost 4 years ago

Are you trying to follow new Javelin lock on procedure? You need to enter optics view, zoom in to NFOV and enable TI mode.

AFAIK the gestures overlapping shouldn't be issue anymore, the mode switch should work anyway.

Updated by cyrilator almost 4 years ago

edwood wrote:

Target was in clear sight, and the Javelin would not enter seek mode and/or lock on to the target.

edwood, i just tried the Javelin and it work like a charm !

in fact The javelin CLU has been updated ! (my suggestion : #24340 "add to the Javelin the real clu effects instead of vanila effects".)

to lock a target you must use the thermal view with the narrow field of view (x9 magnification) this is exactly how the Javelin work in real life.

Very good work guys, congrats !

Updated by zGuba almost 4 years ago

  • Status changed from Assigned to Feedback
  • Assignee changed from zGuba to edwood

Is the issue clear now?

Updated by edwood almost 4 years ago

I will do some more thorough retesting and report back within 2 days.

Updated by edwood almost 4 years ago

I'm a noob.

This bug can be closed. This was a pebkac error. (user error).

When following the instructions precisely, the system works perfectly as designed.
http://ace.dev-heaven.net/search/javelin#FGM-148%20Javelin%C2%A0

I had made the mistake of thinking that both NFOV and Thermal Imaging were options (as opposed to mandatory steps).
I think I may have also switched to the CLU once or twice as opposed to loading the CLU.
A small helpful change would be to remove the addaction 'Weapon CLU' if the player primary weapon is Javelin (to avoid accidentally switching to CLU as opposed to loading it).

The square/circle indicator is still somewhat temperamental, and it would seem to make sense (to this noob) to remove this altogether.

Mousegestures menu still displays momentarily when pressing TAB, but this does not prevent the user from switching between Direct / Top modes.

Next time, I'll work harder before raising the bug report.

Ed.

Updated by Sickboy almost 4 years ago

  • Status changed from Feedback to Rejected
  • Target version deleted (1.13)
  • Close Reason set to By design/Not a Bug

Cheers :)

Updated by cyrilator almost 4 years ago

.

Updated by Sickboy almost 4 years ago

Sounds good, thanks!
But perhaps best put in new ticket

Also available in: Atom PDF