Bug #2644

Players are being teleported back to LHD for no reason

Added by Dr_Eyeball over 5 years ago. Updated over 5 years ago.

Status:Closed Start date:07/07/2009
Priority:Urgent Due date:07/10/2009
Assignee:Dr_Eyeball % Done:

100%

Category:Respawning
Target version:beta v0.2 Estimated time:3.00 hours

Description

Reported by wormeaten:

We were trying to play your map but have some problems from beginning.

We was have some Beam me up Scotty problems. Chopper gets us to the land turn back to pick up more people but suddenly we are again on the carrier before chopper get back to carrier and we didn’t lost live it was just real Star Trek teleport.

<end of report>
---------------

Probably cause: The initial starting position for players on LHD is calculated at the start and requires teleporting player from land to the LHD.
It must be triggering this somehow, maybe by JIP players. Probably the player Initialization field code is being executed for all players by the JIP player.

Solution: Add local checks. Stop using Initialization fields for players. Check vehicle Initialization fields too.

History

Updated by Dr_Eyeball over 5 years ago

  • Due date set to 07/10/2009
  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

Couldn't reproduce this problem, but I stopped using Initialization fields for start position of players, since JIP players might be triggering those init's again.

Also available in: Atom PDF