Feature #26435

Add the option to disable kill statistics on the map screen

Added by kraze over 3 years ago. Updated over 3 years ago.

Status:Closed Start date:11/18/2011
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:Interface
Target version:1.60.87580
Affected ArmA II version: First affected ArmA II version:
Reproduced by another DH user:No Single / Multi Player?:
I am using some Mods:No BIForumURL:
I am using: NGUrl:
Reproducible for you:No WIKIurl:
Related to content of DLC:

Description

The title says it all. Stats screen is a cheat. While "I"-button stats can be disabled - the much worse map screen stats can't (at least to my knowledge).
They are a huge cheat with one good example being that you can easily confirm kills using that screen since they show you who you've killed down to his unit class.

So at least add the option to disable this.


Related issues

related to ARMA2 Community Issue Tracker - Feature #26488: Customizable sorting for Diary items (especially Units) Assigned 11/20/2011
duplicated by ARMA2 Community Issue Tracker - Feature #11117: Option for disabling the statistics section on the map/br... Duplicate 06/09/2010

History

Updated by zGuba over 3 years ago

  • Category set to Interface
  • Status changed from New to Assigned
  • Affected ArmA II version deleted (Please select...)
  • Maxmem parameter deleted (Not set)
  • Difficulty deleted (Not set)
  • Language deleted (Please set for missions)
  • First affected build deleted (Please Specify...)
  • First affected ArmA II version deleted (Please select...)

Updated by zGuba over 3 years ago

AFAIK one can try disabling whole "Statistics" section, I'll see if I can handle it in ACE.

Updated by zGuba over 3 years ago

  • Tracker changed from Bug to Feature

Updated by kju over 3 years ago

Not possible as far as I can tell (I tried).

Why it is a feature now zGuba?

Updated by zGuba over 3 years ago

I can disable it by overriding CfgDiary >> FixedPages >> Statistics subentries, and possibly make it clientside option for ACE. I'm sorry but there's no way to enforce it serverside.

It's missing feature rather than bug, because designers didn't made it possible to hide with difficulty options rather than giving us option that doesn't work.

Updated by kju over 3 years ago

Yep true. I actually made an already.. :)

class CfgPatches
{
    class DisabledStatisticsView_Gameplay_C_PvPscene
    {
        units[] = {};
        weapons[] = {};
        requiredVersion = 0.1;
        requiredAddons[] = {"CAUI"};
        version = "2010-11-22";
        fileName = "DisabledStatisticsView_Gameplay_C_PvPscene.pbo";
        author = "PvPscene";
        mail = "pvpscene@web.de";
    };
};
class CfgDiary
{
    class FixedPages
    {
        class Statistics
        {
//            type = "DiaryPageStatistics";
//            displayName = "Statistics";
//            shortcuts[] = {};
//            showEmpty = 0;
            indexTitle = "";//"%$STR_LOGSUBJECT_STATISTICS";
//            indexIcon = "";
            recordTitle = "";//"%$STR_STAT_MISSION";
            text = "";//"%$STR_BRIEF_YOURKILLS<br/>%STAT_KILLS_ENEMY<br/>%$STR_BRIEF_YOURKILLS_FRIENDLY<br/>%STAT_KILLS_FRIENDLY<br/>%$STR_BRIEF_YOURKILLS_CIVIL<br/>%STAT_KILLS_CIVIL%<br/>%$STR_BRIEF_CASUALTIES<br/>%STAT_CASUALTIES";
            killsOnce = "";//"  %NAME<br/>";
            kills = "";//"  %COUNT x %NAME<br/>";
            casualtiesPlayerTotalOnce = "";//"  You (%NAME)<br/>";
            casualtiesPlayerTotal = "";//"  %COUNT x you (%NAME)<br/>";
            casualtiesPlayerOnce = "";//"  - by %NAME<br/>";
            casualtiesPlayer = "";//"  - %COUNT x by %NAME<br/>";
            casualtiesOnce = "";//"  %NAME<br/>";
            casualties = "";//"  %COUNT x %NAME<br/>";
            picture = "";//"#(argb,8,8,3)color(0,0,0,0)";
        };
    };
};

Updated by kraze over 3 years ago

Hopefully BIS will allow to make it server-side enforced

Updated by Suma over 3 years ago

An easy fix would be to let option "NetStats" disable even this kind of statistics (ingame only, they would always be available during debriefing). Another option is "DeathMessages", but that seems to be a bit unrelated.

Updated by Sickboy over 3 years ago

Suma wrote:

An easy fix would be to let option "NetStats" disable even this kind of statistics (ingame only, they would always be available during debriefing). Another option is "DeathMessages", but that seems to be a bit unrelated.

I would've suspected this already to be the case - sensitive to NetStats makes sense.

Updated by Suma over 3 years ago

Should be done in 86491. As the ticket is missing repro steps, I was unable to verify, as I was unable to show the stats screen during the game in the few missions I have tried.

Updated by kraze over 3 years ago

Great. That should improve the suspense (did that dude die or just went prone or got wounded in a foot?) both in Coop and PvP now (I admit I was prone to using stats screen from time to time myself)

And yeah showing who you've killed during debriefing is a perfect solution as the mission is over and no harm can be done.

Updated by kju over 3 years ago

  • Target version set to Upcoming version

Updated by kju over 3 years ago

  • Status changed from Assigned to Closed
  • Target version changed from Upcoming version to 1.60.87580

good job - it works

while the statistics menu is still there, it will remain empty now

Also available in: Atom PDF