Feature #264

Allow players to create new custom channels in-game

Added by Spooner about 6 years ago. Updated almost 6 years ago.

Status:Closed Start date:03/03/2009
Priority:Low Due date:
Assignee:Spooner % Done:

100%

Category:-
Target version:0.7.0

Description

Allow players to create new custom channels in-game (currently channels are added only via functions). Probably implemented by adding /join and /leave commands in the IM entry line.

p023.jpg (62.3 kB) kju, 03/18/2009 10:09

p007.jpg (141.8 kB) kju, 03/20/2009 07:21

History

Updated by Spooner about 6 years ago

  • Status changed from Assigned to Feedback

Don't really like the idea of buttons for this, since then I'd need to piss about with a text entry for the channel name (though leave and who could use a drop-down of currently subscribed channels.

  • /join frog
  • /leave [frog]
  • /who [frog] (not sure how to implement this, since if you JIP you won't know who is already in the channel. However, all members could send a confirmation when you join a channel, and then you can monitor join/leaves after that). Could list all the names in a single chat message.

For leave and who, you could leave off the channel name if you were in a channel when you issued the command.

Also, if I allow user-defined channels, I possibly need to ensure that the players can't leave scripted channels, though that may not be a problem (they could just join again if they wanted to).

There wouldn't be any need for passwords, since you'd just use an obscure channel name to stop other people joining it (I don't think you should know all the possible channels).

Updated by kju about 6 years ago

Can you change channels via the standard next and previous chat channel?

You could offer an additional logic similar to marker selection:
  • left-right: switch between standard channels
  • up-down: switch between custom ones

Updated by Spooner about 6 years ago

up-down is used for markers (remember you can put markers into channels so both lists can be open.

Having a system so that you can change your specific target (vehicle/channel) makes sense though and I suspect left-right might be the way to go there? e.g.

  • left-right: Standard channels (direct/self/etc)
  • shift-left-right: Subchannels (specific vehicle/user channel)

Updated by Spooner about 6 years ago

  • Status changed from Feedback to Assigned
  • Target version changed from Eventually to 0.7.0

Updated by Spooner about 6 years ago

  • % Done changed from 0 to 100

Updated by Spooner about 6 years ago

  • Status changed from Assigned to Resolved

Updated by kju about 6 years ago

  • Status changed from Resolved to Feedback

works nicely

yet what about that part?

Having a system so that you can change your specific target (vehicle/channel) makes sense though and I suspect left-right might be the way to go there? e.g.

  • left-right: Standard channels (direct/self/etc)
  • shift-left-right: Subchannels (specific vehicle/user channel)

Updated by kju about 6 years ago

ups - who gives always empty array here (testing as local host)

Updated by kju about 6 years ago

also writing /join X and /leave is bit annoying with the slash

what about these key works in addition:

+1
=> join 1
-1
=> leave 1

what about the messages about the guy joining a channel?
is this only for yourself? why twice?
it should be only for you and ppl already in the channel or not?

Updated by Spooner about 6 years ago

The problem with '/', I realised, was that it is also the key to open the chat window, so might be confusing, but it is the "standard" way to issue commands. I'd rather keep to always having a standard command prefix though, but having aliases of /+ and /- is a good idea (already implemented aliasing, so that is easy enough).

Updated by kju about 6 years ago

Hm German keyboard has starting chat by default on -. It is just next to right shift.
/ needs shift ß (next to 0) or num /

Updated by Spooner about 6 years ago

Ah, that would be the same as our '/' key then.

OK, best I can do is give you is STR_SPON_MAP_COMMAND_PREFIX (stringtable) which is '/' by default. You see, the problem is that although I can tell what keycode is being pressed, I can't tell what letter that actually refers to on the current keyboard.

Added /+ and /- anyway (where the '/' depends on stringtable).

Updated by kju about 6 years ago

no go here

and i meant "+1" and not "/+1" to join channel 1. not sure if there was a confusion here (plan is avoid / as its hard reachable).

Updated by Spooner about 6 years ago

Well, / is the standard command escape in any IM system I've ever used. What is that in German IMs (e.g. /me in Skype)?

Regarding /+ vs +, I'm trying to make it consistent. Anything starting with / is a command. Anything else will be used as IM.

Updated by kju about 6 years ago

yeah it is same. not every standard, is a good one :P

Updated by Spooner almost 6 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF