Bug #26317

Simple Support Module Airstrike doesn't happen

Added by F2kSel over 3 years ago. Updated almost 3 years ago.

Status:Closed Start date:11/13/2011
Priority:Normal Due date:02/13/2012
Assignee:Dwarden % Done:

0%

Category:BI Modules
Target version:1.62.95248
Affected ArmA II version:1.60.87580 First affected build:
Reproduced by another DH user:No First affected ArmA II version:1.62 Beta
I am using some Mods:No Single / Multi Player?:
I am using:CO (OA+A2) BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

OA Beta 1.60
Using the Simple Support Module to call in an Air strike on a building the plane shows up but never drops a bomb.
The problem seems even worse if I use the Scout with the laser marker and try to call for support, the only time I saw the plane was miles away circling.

OA 1.59
And using SSM the plane bombs the target, only the first plane after that they also just fly around doing nothing even though it's a different target

Reproduction
  1. Editor
  2. Launch mission
  3. Radio 0-8
  4. Point the cursor on the hanger
  5. Select 4 - air strike
  6. Wait for the aircraft

Observation
The plane or planes show up depending on how many strikes you call but nothing happens the planes just fly around.

Expected
The plane should come in and destroy the selected target and subsequent targets.

Summary
  1. 1.59 only first run get the plane to drop bomb.
  2. 1.60 no bombs and a no show if using laser marker.

Note
The other parts of the module are working correctly

bug_ssm.utes.7z (686 Bytes) F2kSel, 11/13/2011 04:16


Related issues

related to ARMA2 Community Issue Tracker - Bug #15096: Simple Support Module not working on Dedicated Server Assigned 11/13/2010 05/01/2011
related to ARMA2 Community Issue Tracker - Bug #22724: doTarget only works for a second Closed 07/23/2011 10/29/2011

History

Updated by kju over 3 years ago

  • Description updated (diff)

Updated by kju over 3 years ago

  • First affected ArmA II version changed from Please select... to 1.60 BETA

Updated by Fireball over 3 years ago

  • Due date set to 02/13/2012
  • Status changed from New to Assigned
  • Assignee set to Dwarden

Updated by Dwarden over 3 years ago

  • Target version set to 1.60 BETA

this is definitely regression since 1.59, can anyone confirm it with latest 1.60.86xxx beta build?

Updated by F2kSel over 3 years ago

I'm still seeing the same thing.

Call with some units and nothing shows up and with others they still fly around doing nothing.

Updated by Suma over 3 years ago

just call in an air strike on the hanger and wait for the aircarft.

Please, be more specific in the repro steps. Believe it or not, I have never called air strike before and I do not know how to do it.

Updated by Danil-ch over 3 years ago

to call in an air strike
use
Backspace 0-8-4

Updated by Suma over 3 years ago

Perhaps I am doing something wrong, but it seems to me the same issue was already present in 1.59.

What I do:

- run the mission
- aim cursor at the hanger
- press 0-8-4

Observed result:
- A message requesting CAS is heard, confirmation from HQ received immediately
- sometimes there is no plane for several minutes
- sometimes the plane appears (close or far), but does nothing and flies away

If I am doing something wrong, provide different repro steps. Otherwise please somebody confirm if you can see the issue with the steps given in 1.59.

Updated by kju over 3 years ago

Suma did you run CO or OA only? I think the SSM requires CO to work.

Updated by Suma over 3 years ago

I am running CO.

When I use a different repro, I get different results in 1.59 (not confirmed for 1.60 yet):

What I do:

- run the mission
- press Y to teamswitch into the rifleman
- aim cursor at the hanger
- press 0-8-4

Observed result:
- A message requesting CAS is heard, confirmation from HQ received immediately
- within a minute a plane appears and circles around

When I further modify the repro and aim with the rifleman to the scout instead to the hanger, the plane most often drops a bomb on the first run (killing both Scout and me). The only regression I was able to find is here: with 1.60 the plane does not drop the bomb (most likely because it does not want to engage a friendly target). All other aspects seem to be the same with 1.59 and 1.60: I was unable to let it drop a bomb on the hanger, and when I called the plane as scout, I did not see the plane, or it only passed by once (often far from me).

Updated by AvEngErZx over 3 years ago

Suma wrote:

Observed result:
- sometimes the plane appears (close or far), but does nothing and flies away

I can prove this, I played co-op Campaign (Operation Arrowhead) today morning with my friend. I called in an airstrike (Which I'm allowed to) and the A-10 just flew in and cycle around the target instead of dropping bombs on it.

I'm pretty sure that it is Vanilla OA Campaign and with only my sound mod running.

Updated by Suma over 3 years ago

@AvEngErZx: Which version this was? 1.59 or some beta?

Updated by Legislator over 3 years ago

I've reported that ages ago. Don't count it'll be fixed ever.

http://dev-heaven.net/issues/15096

At least now the CIT is flooded with similar tickets so there's hope the issue get's at least a little bit attention.

Updated by F2kSel over 3 years ago

Legislator I did read about the problems on a dedicated server but this is now happening in single player and 2d editor.

In my further tests what happens when the player is a Scout and the air strike is called is that plane gets spawned every time but the target waypoint appears at random, usually out at Sea when using Utes. Using the Scout to call in an air strike is broken in 1.59 through 1.60 and probably earlier versions.

1.60 betas
When using the rifleman to call the strike the planes waypoint is correctly positioned on the target but it doesn't bomb that target.

in 1.59.79384 and using the rifleman to call in an air strike the waypoint is correctly positioned and bombs released, it's not %100 but not too bad.

Updated by AvEngErZx over 3 years ago

Suma wrote:

@AvEngErZx: Which version this was? 1.59 or some beta?

1.60 BETA with Vanilla OA Campaign + JSRS Sound mod.

1.60.86476 (Before the latest released one)

Updated by kju over 3 years ago

  • Description updated (diff)

Updated by kju over 3 years ago

Relevant script code:
\ca\modules_e\SSM\data\scripts\init.sqf
http://pastebin.jonasscholz.de/1623

Mainly L45 onwards.

Observations:
  1. The script has a different handling if the unit has a LD.
  2. The waypoint issue seems to be due to bad script design of SSM. For units with a LD, there is no WP generated by the script it seems and relies to correct flight direction set for the plane
  3. The 1.59 vs 1.60 behavior could be due to the laserTarget created for non LD units:
#define BIS_SSM_LASERDESIGNATORCLASS "Laserdesignator" 
#define BIS_SSM_AIRSTRIKETARGETCLASS_WEST "LaserTargetWStatic" 
#define BIS_SSM_AIRSTRIKETARGETCLASS_EAST "LaserTargetEStatic" 

Suma said:

with 1.60 the plane does not drop the bomb (most likely because it does not want to engage a friendly target)

If that's the case the LaserTargets might need a different behavior? (or wrong LT used for each side?)

Updated by F2kSel over 3 years ago

You don't have to use the lazer designator for it not to show just the unit. If it does show up it will drop the bomb if you quickly switch to LD.

Just looking through the script I did notice that at the end it makes use of DoTarget This has also been broken for quite some time but I'm not sure how or this would affect Aircraft. #22724

Updated by Sickboy over 3 years ago

The code kju is referring at is actually ran when you are not using a laser designator, it's a dummy laser target.
However they seem correct; LaserTargetWStatic has side = 0 (east), and LaserTargetEStatic has side = 1 (west)

doTarget could be very well related to not engaging. But seems unrelated to Not showing up.

The code actually suggests that if the unit has a laser designator, but doesnt use the designator, there will be no action performed by the plane, so not using the designator resulting in no action seeems as designe.

Updated by F2kSel over 3 years ago

Using a unit without LD.
In the SSM script there is the following line _target hideobject True;
The problem with this is that the planes can't see the target when this is used.
Removing it or changing it to FALSE allows the bombs to fall.
The downside of this is that there's now a visible red laser marker above the object.
It's always been an annoyance of mine that deletecolletion was modified as that would have worked as it still allowed invisible objects to be targeted.

When unit does have a LD
The second problem of the plane not even flying to the target should be simple it just needs an addwaypoint inserting .
Simple test using cursor target works but probably needs something better.

_wp = (group _pilot) addWaypoint [getpos cursortarget, 0];//// modified to allow aircraft to fly to 
_wp setWaypointCompletionRadius 2000;///////////////////////// Target

When you have a LD in weapon list and call in an airstrike you should receive a message requesting the use of the LD otherwise the plane will just fly around looking for real targets to engage.

I still think DOTARGET should be fixed.

Updated by Sickboy over 3 years ago

Nice find!

What is the ticket id of the doTarget issue?

Updated by F2kSel over 3 years ago

#22724

I'll update the dotarget issue.

Updated by Dwarden over 3 years ago

  • Target version changed from 1.60 BETA to 1.61 BETA

seems this was not fixed fully yet, unless i'm wrong then close it as resolved

Updated by F2kSel over 3 years ago

Sorry for the above post which I removed, I got my modules mixed up I was testing the SOM module not SSM.

SSM Air Strike is still not functioning in 1.60 and betas.

I don't see any improvement.

Updated by Suma over 3 years ago

  • Status changed from Assigned to Resolved

In the SSM script there is the following line _target hideobject True;

This problem is fixed now in 87659, laser targets can be tracked now even when made invisible.

Together with #22724 fix this should make SSM more reliable now, hopefully at the 1.59 level.

Updated by kju over 3 years ago

  • Status changed from Resolved to Closed
  • Affected ArmA II version changed from 1.60 BETA to 1.60.87580

works (if the planes arrives - the SSM/planes are not 100% reliable it seems)

Updated by kju about 3 years ago

  • Target version changed from 1.61 BETA to 1.62.95248

Updated by F2kSel about 3 years ago

  • First affected ArmA II version changed from 1.60 BETA to 1.62 Beta

This seems to be broken again, the plane never flies to target but can be seen in the distance.

I tested a lasertarget and used hideobject true to make the target invisible, I then used an editor placed aircraft.
The plane does find an attack the target so it doesn't seem to be the same problem.

I can't roll back as I'm using beta 95208 not full RC 1.62
I'm sure it was working about six weeks back.

The same Repro can be used to see the issue.

Updated by kju about 3 years ago

Please create a new ticket (even if its mostly copy and paste)

Also available in: Atom PDF