Bug #26255

Prone AI can't move

Added by Robalo over 3 years ago. Updated over 3 years ago.

Status:Closed Start date:11/08/2011
Priority:Normal Due date:
Assignee:rocko % Done:

100%

Category:Complex
Target version:1.13
Component:sys_weaponrest Affected Version:
Close Reason:

Description

Observed with current ACE, with and without beta, easy to reproduce: order an AI to go prone then send it somewhere.
Note how it can't move until you have it change stance to crouch or standing.
Removing ace_c_anims.pbo did not help.

Repro_26255-ProneAI.utes.zip (834 Bytes) Robalo, 11/08/2011 11:34

ace_sys_weaponrest.pbo (138.6 kB) Sickboy, 11/09/2011 13:22


Related issues

related to A.C.E. for OA - Bug #26245: ACE breaks fixed pathfinding of beta 86162 Closed 11/07/2011

Associated revisions

Revision 756b09c8
Added by Robalo over 3 years ago

~fixed: AI stuck in prone position, fixes #26255

History

Updated by Sickboy over 3 years ago

  • Status changed from New to Feedback
  • Assignee set to Robalo

Whadabout ace_ai_*.pbo?

Reproduced with only @ACE modfolder active? Reprod with just @CBA?

Updated by Sickboy over 3 years ago

  • Category set to Complex
  • Target version set to 1.13
  • Component set to ?

Updated by Robalo over 3 years ago

Nope, not c_ai*, neither wounds, ruck or stamina.

Updated by Sickboy over 3 years ago

Interesting problem, Watson!

Updated by Sickboy over 3 years ago

  • Status changed from Feedback to In progress
  • % Done changed from 0 to 10

Updated by Sickboy over 3 years ago

  • File ace_sys_weaponrest.pbo added

Should be caused by; http://dev-heaven.net/issues/20253#note-9
http://dev-heaven.net/projects/ace-mod2/repository/revisions/11efcd0799776734ae141612354280d13dd15222/diff

Temporary workaround attached (reverted the change) but a proper fix should be applied.

Updated by Sickboy over 3 years ago

  • % Done changed from 10 to 40

Updated by Sickboy over 3 years ago

  • Assignee changed from Robalo to rocko
  • % Done changed from 40 to 50
  • Component changed from ? to sys_weaponrest

Updated by Robalo over 3 years ago

  • Status changed from In progress to Resolved
  • % Done changed from 50 to 100

Updated by Sickboy over 3 years ago

  • File deleted (ace_sys_weaponrest.pbo)

Updated by Sickboy over 3 years ago

Proper fix attached.

Updated by Sickboy over 3 years ago

  • Status changed from Resolved to Closed

Available in SU hotfix - please run Verify and Repair on the ACE Preset in Six Updater.

Also available in: Atom PDF