Bug #2614

Startup explosion occurs at airbase/LHD.

Added by Apocal about 6 years ago. Updated about 6 years ago.

Status:Closed Start date:07/06/2009
Priority:Urgent Due date:07/10/2009
Assignee:Dr_Eyeball % Done:

100%

Category:Gameplay
Target version:beta v0.2 Estimated time:2.00 hours

Description

Whenever game begins or new JIP player comes to base, an explosion occurs, killing them and any others in the vicinity.

History

Updated by Dr_Eyeball about 6 years ago

  • Status changed from New to Assigned
  • Assignee set to Dr_Eyeball
  • Priority changed from High to Urgent
  • Target version set to beta v0.2
  • Estimated time set to 2.00

Cause: unknown, probably AAS2 Base Protection mechanism

If the bug is only happening for east team, then that would be related to Base Protection which places artillery on any west players in the base (normally at the boundary). Since east players are classified as west via playerSide very early on (JIP limitation of command), then a more reliable check will need to be used like class side check.
For now the artillery effect will be removed too, just in case to avoid side effect on other players too. When arty effect is removed, it simply kills player by setting damage instead of using arty.

Solution: better JIP side checking, turn off AAS2 arty effect.

Updated by Apocal about 6 years ago

If the bug is only happening for east team...

It's happening for the West team as well. It only happens on initial spawns though, respawns are unaffected.

Updated by Dr_Eyeball about 6 years ago

  • Due date set to 07/10/2009
  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

Couldn't actually reproduce this bug, but there was only one possible cause, so that base protection option is turned off for now which then defaults to using standard death penalties. Not sure why it would trigger though for west side, since it worked ok in Arma 1.

Also available in: Atom PDF