Bug #26111

Under-barrel grenade launchers too loud for AI

Added by maturin over 3 years ago. Updated about 3 years ago.

Status:Closed Start date:11/03/2011
Priority:Normal Due date:
Assignee:Robalo % Done:

100%

Category:-
Target version:1.13
Component:c_weapon Affected Version:
Close Reason:

Description

AI can hear an M203 or GP25 firing from 600m away. They will identify it as a threat and go into combat mode. Fire a second time at this distance, even if you are prone in grass, and the AI will acquire you as a target.

This progression of awareness and spotting is dubious enough for loud sniper rifles at this distance. I doubt grenade launchers can be heard from so far away.

Associated revisions

Revision 34621a05
Added by Robalo over 3 years ago

Better eyes for snipers, spotters.
~fixed: AI hearing too well (improved stealth options), fixes #26111

Revision 632af44e
Added by Robalo over 3 years ago

GL heard from too far, refs #26111

History

Updated by Sickboy over 3 years ago

  • Status changed from New to Assigned
  • Assignee set to rocko
  • Target version set to 1.13

I think Rocko might've fixed this

Updated by Sickboy over 3 years ago

  • Status changed from Assigned to Feedback
  • Assignee changed from rocko to maturin
  • % Done changed from 0 to 50
  • Component set to c_weapon

Please confirm if it was fixed in yesterday's update.

Updated by maturin over 3 years ago

Do you mean version 518? Just tested and a sniper heard the shot at 600m, faced me and fired. All before the grenade exploded.

Updated by Sickboy over 3 years ago

  • Status changed from Feedback to Assigned
  • Assignee changed from maturin to Robalo
  • % Done changed from 50 to 10

Updated by Robalo over 3 years ago

  • Status changed from Assigned to In progress

These issues come from ACE's extended AI hearing ability, which hasn't changed in ages.
But the problem is there and the config can be tweaked to improve stealth.

Updated by Robalo over 3 years ago

  • Status changed from In progress to Resolved
  • % Done changed from 10 to 100

Updated by Sickboy over 3 years ago

  • Status changed from Resolved to Closed

Available in SU hotfix - please run Verify and Repair on the ACE Preset in Six Updater.

Updated by maturin over 3 years ago

Unfortunately, the problem has only been lessened slightly.

A full skill Spetsnaz Team Leader can hear a smoke grenade being launched out at 500m. At 600m he hears nothing.

Updated by Sickboy over 3 years ago

Tested with v1.60 betas?

Updated by rocko over 3 years ago

  • Status changed from Closed to Assigned
  • % Done changed from 100 to 0

Updated by maturin over 3 years ago

I have one of the latest beta patches, yes.

Updated by Robalo over 3 years ago

Grenade launchers are loud. What's the range at which they should no longer be heard by the max skilled units ?
Just need to know what to aim for when tweaking it again.

Updated by maturin over 3 years ago

Honestly, I have no idea. Was there a proportion for launcher vs. rifle in the vanilla config?

In vanilla and most sound mods it just seems like a lower sound, and also one that would not be instantly recognizable at distance, like gunshots are.

Updated by Sickboy about 3 years ago

  • Status changed from Assigned to In progress
  • % Done changed from 0 to 70

Final tweaks applied Robalo?

Updated by Robalo about 3 years ago

  • Status changed from In progress to Resolved
  • % Done changed from 70 to 100

I would say yes, the ammo is now less audible config-wise than the supersonic bullets fired from suppressed weapons. If it's still a problem, then it's more than just about grenade launchers.

Updated by Sickboy about 3 years ago

Sweet, thanks!!

Updated by Sickboy about 3 years ago

  • Status changed from Resolved to Closed

Available in the about to be released ACE for OA 1.13 RC5.

Also available in: Atom PDF