Bug #25986

ServerCommand not working

Added by neokika over 3 years ago. Updated almost 3 years ago.

Status:Rejected Start date:10/29/2011
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:Multiplayer
Target version:-
Affected ArmA II version:Please select... First affected build:Please Specify...
Reproduced by another DH user:No First affected ArmA II version:Please select...
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:No NGUrl:
Related to content of DLC: WIKIurl:

Description

ServerCommand is not functional both in version 1.59 and latest Beta patch.

Repro:
- Player joins dedicated server
- Logs in as admin
- Use scripting command - serverCommand "#logout"

History

Updated by kju over 3 years ago

  • Category set to Multiplayer
  • Status changed from New to Feedback

This is done on purpose. The change was to avoid abuse by cheaters.
See also: http://community.bistudio.com/wiki/serverCommand

You can still check for admin though:

AAS_IsPlayerAdmin = serverCommandAvailable "#kick";

Updated by neokika over 3 years ago

Yes, I see that it may become a problem with cheaters.

On another note, our community is in the way of expanding and supporting higher number of players in a game session and since we are public and there is no current support for multiple admins, we started working on a Multiple Admin Console, and would be nice if we could remotely kick or ban any problematic players using serverCommand.

Two things that could be done:
- Allow for multiple admins at once to be logged on
- Bring back the serverCommand functionality

Thanks Kju,
neo

Updated by kju over 3 years ago

Updated by neokika over 3 years ago

When talking with our server owner there seems to be issues when using BattleEye and regular players not being able to join and/or being kicked off the server.

neo

Updated by nux over 3 years ago

neokika wrote:

Two things that could be done:
- Allow for multiple admins at once to be logged on
- Bring back the serverCommand functionality

With the next Battleye update, i'll release a app that allows multiple admin to be on at the same time.
but its based on Be. so that is a requierment. visit my wip page www.ibattle.org if you want to read some about it.
And you should fix your BE problems as its unwize to run without it.

Updated by kju over 3 years ago

Agreed. Neo you need to fix your problems with using BE.

I suggest to reject this ticket as it only makes abuse possible
and it would be very hard to avoid it on the SQF level.

Updated by neokika over 3 years ago

Rgr, thanks.

Updated by kju almost 3 years ago

  • Status changed from Feedback to Rejected

Also available in: Atom PDF