Bug #25951

OA RPG Packs sometimes appear empty with ACE ruck system (tenative)

Added by maturin over 3 years ago. Updated about 3 years ago.

Status:Closed Start date:10/28/2011
Priority:Normal Due date:
Assignee:Robalo % Done:

100%

Category:-
Target version:1.13
Component:sys_ruck Affected Version:
Close Reason:

Description

This is a bug that I cannot reproduce reliably, so I need others to corroborate and report.

I am not sure when this issue arose, but it concerns the vanilla RPG packs carried by Takistani guerillas.

Repro:

Kill a Takistani RPG ammo bearer and pick up his ruck. Sometimes you will be able to access the ruck normally, other times it will appear empty. You can put items in it, but there are no rockets to be seen. I don't know if the pack has the weight of the rockets or not, and the pack works fine when attached to its original living carrier.

rpt.txt - RPT- most of the spam is Fallujah's fault (16.1 kB) maturin, 10/28/2011 18:46

#RUCK1_TEST_GROUP.Desert_E.7z (640 Bytes) rocko, 12/27/2011 16:14

#RUCK1_TEST_NOGROUP.Desert_E.7z (634 Bytes) rocko, 12/27/2011 16:14

ace_sys_ruck-#25951-fixed.7z (15.8 MB) Sickboy, 12/27/2011 17:03

Associated revisions

Revision b19b5b5c
Added by Robalo about 3 years ago

disabled conversion of rpg packs, fixes #25951

Revision a4a8b04c
Added by Sickboy about 3 years ago

Revert "disabled conversion of rpg packs, fixes #25951"

This reverts commit b19b5b5c49ad2ca93b9eb2d9198f0a450cc5dcc9.

Revision e48cc685
Added by Sickboy about 3 years ago

Fixed: DisableStaminaEffects should disable ruck-exchange on deddy. refs #25951

History

Updated by Sickboy over 3 years ago

  • Status changed from New to Assigned
  • Assignee set to Robalo
  • Component set to sys_ruck

Updated by Robalo over 3 years ago

I noticed this long ago with taking medical ACE rucks from dead medics. Same thing as here I guess, sometimes works, other times the items disappeared.
All I can do at this point is to limit ruck auto-conversion - disable it for RPG packs, do it only for players and the AI in their group etc.

Would be interesting to know this:

- can you access the items before picking up the dead guy's pack ? (used to be a regular scroll menu action, don't know if it got moved)
- when you took the pack and the items were lost, did you have another ACE pack on you already ?

Updated by maturin over 3 years ago

- can you access the items before picking up the dead guy's pack ? (used to be a regular scroll menu action, don't know if it got moved)

Yes, often I can use the action menu to retrieve the rockets while the bag is still on the corpse. It is only once I take the ruck that the contents vanish. However, if the body falls on top of the RPG pack, I may be unable to open it without first picking up the bag.

- when you took the pack and the items were lost, did you have another ACE pack on you already ?

No, I tested with units that carried no ruck.

Updated by maturin over 3 years ago

Scratch that. There are three possibilities:

1) The system will work correctly. RPG packs can be accessed through the Interact key on living units and the action menu on dead units. Rockets can be accessed through gear screen when you carry the ruck.

2) Rockets can be taken from a dead unit's RPG pack using the action menu and gear screen. Picking up the RPG pack will cause the rockets to disappear.

3) It is impossible to open a dead units pack using the gear menu. You have to pick up the entire pack, and the rockets will not be available. You may have an Open RPG Pack option in your action menu, but it doesn't do anything. There may be an Open RPG Pack option when looking at the corpse, but the gear screen only flashes into view momentarily, disappearing too soon to use.*

*This can even happen when accessing the ruck of a grouped unit through the Interact key. It appears that the ACE ruck system has all sorts of problems with the default OA RPG packs. Maybe they should be replaced by a new ACE version.

Updated by Sickboy over 3 years ago

  • Target version set to Planned (Needs Contributors)

Updated by rocko over 3 years ago

  • Target version changed from Planned (Needs Contributors) to 1.13

Updated by Sickboy about 3 years ago

Hows the status of this one Robalo?
Partially solved? Full solution for another time?

Updated by Robalo about 3 years ago

I can only confirm there are problems accessing rucks from dead AI, but we need a repro first, then tcp to fix it :)

Updated by Sickboy about 3 years ago

  • Target version changed from 1.13 to 1.14

Updated by maturin about 3 years ago

RPG packs of friendly units are still closing an instant after you open them. And if you take the entire ruck, no one can open it. I have seen this happen on youtube with other players as well.

Maybe the ACE ruck system should be deactivated for these OA RPG packs.

Updated by Sickboy about 3 years ago

Maybe you should provide some repro steps + mission so Robalo can actually reproduce it and fix it.

Updated by rocko about 3 years ago

He says he seen it on youtube, all we oughta do noa iswatch dem youtube for proof, mkay?!

Updated by Sickboy about 3 years ago

Youtube videos don't show reproduction details like other mods used, version, etc.

Updated by Robalo about 3 years ago

maturin wrote:

RPG packs of friendly units are still closing an instant after you open them. And if you take the entire ruck, no one can open it. I have seen this happen on youtube with other players as well.

Maybe the ACE ruck system should be deactivated for these OA RPG packs.

If it's just about the RPG packs then we can workaround it like that.

Updated by Robalo about 3 years ago

  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100

Updated by rocko about 3 years ago

I don't see why it should be limited to only RPG packs. IMO they are just normal rucks with RPG stuff in, so every pack could be affected.
But why I wonder most is how to reproduce it reliably. From reading the ticket I understand it so that it does not alway happen.

Updated by maturin about 3 years ago

It is not consistent, which is why the ticket is marked 'tentative' and why I haven't provided a repro mission despite all the badgering.

In a mission I made, the gear menu would close instantly when you opened an RPG pack. I have seen this happen on youtube with ACE rucks. In other missions, I could open packs worn by other AI just fine. However, sometimes ANY ruck will empty itself if you take it from another soldier (living or dead) through the gear menu. The contents will vanish.

Updated by Sickboy about 3 years ago

In a mission I made, the gear menu would close instantly when you opened an RPG pack.

If you provide this mission we have a repro or does it happen randomly in this mission?

Updated by rocko about 3 years ago

It seems the RPG pack is not converted for AI.

In my testings the RPG pack is still the Vanilla backpack.
Therefore you won't see stuff in it while it is on AI's back aka "Gear"-Action on dead AI body

Only when you open it "Open RPG-Pack" on dead AI body you see four RPG grenades.

When picking up the RPG pack from dead AI you won't see the content (ACE style) unless you click on "Open Pack".

I guess you are confused between being a Vanilla rucksack and the ACE rucksacks.
IMO the real bug is that the RPG pack is still a Vanilla backpack for some reason.

Updated by rocko about 3 years ago

Here are some repro missions finally

Updated by maturin about 3 years ago

I had consistent auto-closing of RPG packs in a missionon a usermade island, and didn't think that would be a useful repro.

I still can't reproduce the instant-closing, except for one mission where it was consistent. But I have worked something else out:

The documentation says that you need to use the Drop Ruck button to get the contents to remain properly in the ruck. However, in SP with AI-carried rucks, players are naturally going to take the rucks from the AI using the gear menu. In this case, any and all rucks will empty themselves. The player can access the rucks when the AI carries them, but if he removes them (a natural course of action in many situations), the items will be lost. So the rucks system has some confusing limitations in SP that are a major hazard to a mission if you suddenly lose all your AT rounds.

Updated by Sickboy about 3 years ago

Updated by Sickboy about 3 years ago

  • File ace_sys_ruck-#25951-fixed.7z added

I have reverted the Robalo change, and fixed the issue properly me thinks.
Please confirm.

Might not fix the other issues you mentioned, but in that case please put it in a new ticket.

Updated by Sickboy about 3 years ago

  • File deleted (ace_sys_ruck-#25951-fixed.7z)

Updated by rocko about 3 years ago

fixed

Updated by Sickboy about 3 years ago

  • Status changed from Resolved to Closed

Was already available on SU since 27th December.

Updated by Sickboy about 3 years ago

  • Target version changed from 1.14 to 1.13

Available in the latest ACE 1.13 Stable hotfix2 packages http://ace.dev-heaven.net/wagn/ACE_1_13.
(Besides already available on Six Updater hotfixes).

Also available in: Atom PDF