Bug #25882

AI too good spotting at night

Added by Sickboy over 3 years ago. Updated over 3 years ago.

Status:Closed Start date:10/26/2011
Priority:Normal Due date:
Assignee:Robalo % Done:

100%

Category:-
Target version:1.13
Component: Affected Version:
Close Reason:

Description

http://forums.bistudio.com/showthread.php?p=2044227#post2044227

by The Hebrew Hammer:

I removed the ace ai pbo's, even at night they can spot you from 1000 miles away.


Related issues

related to ARMA2 Community Issue Tracker - Bug #26117: Some ARMA2 vanilla AI soldiers in CO can initially detect... Closed 11/04/2011

Associated revisions

Revision 4d62ba3a
Added by Robalo over 3 years ago

~changed: Some units possibly had "magic" NVG abilities (nightvision=1 in config), fixed; refs #25882

History

Updated by rocko over 3 years ago

How reliable is a report that lacks proper details but is brilliant at using hyberboles?

1000 miles

Sounds more like tacti-fail.

Updated by Sickboy over 3 years ago

Not too reliable, yet it doesn't take away the potential truth in the report, for Robalo to confirm.
Not to mention that Robalo adjusts the skill at night by like 50% in his ASR_AI mods, something that is lacking from ACE, so there's clearly something going on ;)

Updated by rye over 3 years ago

Hawk eyes.

Updated by Sickboy over 3 years ago

  • Status changed from Assigned to Feedback

Updated by Robalo over 3 years ago

They're actually still too blind, day or night. The problem is their tracking ability after they detected you which is more obvious and annoying when it's dark. For that one I made a dynamic view distance adjustment based on the sun angle and fog density in ASR AI, but only for dedicated servers, so the player's VD won't be affected. Here's my test on regular difficulty, skill 0.5, where I dance around the guy and he will only see me from about 40m, but even then still not be able to identify me as enemy (I had to go hug him, if I had a knife could've easily stabbed him):
http://youtu.be/4Cq7HNPVM7A

Updated by Sickboy over 3 years ago

Perhaps this is related; http://dev-heaven.net/issues/26117

Updated by Robalo over 3 years ago

Thanks, I will add a possible fix for that one, making sure nightvision = 0 in config.

Updated by Sickboy over 3 years ago

Question is do nightvision goggles (+ NV/TI weapon modes) work at all for AI, or are they just for show.
Perhaps thats why nightvision = exists (CRUDE!). But otherwise it is at least also used on vehicles.

Perhaps its rather that nightvision = 1 isnt needed anymore since OA NV/TI stuff, but since A2 standalone content wasnt updated for it..

Updated by Robalo over 3 years ago

Yes, see my note here: http://dev-heaven.net/issues/26117#note-7

NVG item works, bug was fixed in ACE, hope they get it fixed in Vanilla too.

Updated by Robalo over 3 years ago

  • Status changed from Feedback to Resolved
  • % Done changed from 10 to 100

Updated by Sickboy over 3 years ago

Nice job karnale!

Btw - perhaps good to check it for vehicles too?

OA 1.59 nightvision = 1;

class Tank: LandVehicle
class Air: AllVehicles
class Mi24_Base: Helicopter
class UH1_Base: Helicopter
class BAF_Merlin_HC3_D: Helicopter

All of these were also present in A2 standalone, except the BAF Merlin of course.

Although I guess they need it ... :D

Updated by Robalo over 3 years ago

Checked, these vehicle classes still have nightvision = 1; in ACE:

Tank
Air
Mi24_Base
UH1_Base
BAF_Merlin_HC3_D

I did not want to touch those, perhaps it is normal, since these vehicles have NV optics usually. At most, this should be tweaked for each vehicle based on their capabilities.

EDIT: Oh, you beat me to it :)

Updated by Sickboy over 3 years ago

  • Status changed from Resolved to Closed

Available in the about to be released ACE for OA 1.13 RC2.

Also available in: Atom PDF