Feature #25784

Enemy Population

Added by antipop over 3 years ago. Updated over 3 years ago.

Status:Closed Start date:10/23/2011
Priority:Normal Due date:
Assignee:antipop % Done:

100%

Category:-
Target version:Multi-Session Operations - MSO v4.3
Component:Enemy Reproduced by another DH user:No
Close Reason: I am using some Mods:No
Affected Version:

Description

Here are some concerns from AAF in regards to Enemy population:

- Not enough infantry spawning. Probably primary concern.
- Not enough vehicles aswell.
- Enemy not spread out evenly. We either run into nothing for ages, or lots in a small space of time, then nothing again.
- Enemy spawning but not patrolling, just staying in roughly same vacinitiy. Running around abit, but nothing too strategic.
- Enemy spawning in either too small, or too large groups. No tactical sniper teams, RPG teams etc.
- Spawning in open, not in urban areas, or on strategic points like tops of valleys, which could provide excellent ambush positions etc.
- Enemies don't use buildings, ususally in open fields when we hit them, and are sitting ducks.
- Also, there is usually a lot of armour for the types of missions we are running. Sometimes we run into one squad, but then like 5 tanks and then a BRDM etc. Ruins the immersion a tad.
- Plus, I feel there aren't enough 'Camps'. Or when there are lots, they are spawned in either really good, or really bad localities. Camps that spawn at strategic points would be perfect.

History

Updated by friznit over 3 years ago

Have you tried Highhead's WICT integration? It's slightly different take on enemypop but adds much more intense and localised battles. It works best with smaller groups that tend to stick together.

http://forums.bistudio.com/showpost.php?p=2016831&postcount=118

Updated by wolffy.au over 3 years ago

Just looking at this again - I will address all these points once I've finished the Ambience modules.

Updated by Tupolov over 3 years ago

  • Status changed from New to Assigned
  • Priority changed from High to Normal
  • Target version changed from Planned to MSO v4.6

Updated by wolffy.au over 3 years ago

  • Status changed from Assigned to Feedback
  • Assignee changed from wolffy.au to antipop

Antipop - can I get an update on this ticket? Are all the points still relavent? Can you confirm it is not just island related ie you saw the same problems on Takistan or Chernarus?

Updated by Tupolov over 3 years ago

  • Tracker changed from Bug to Feature
  • Component set to Enemy

Updated by wolffy.au over 3 years ago

  • Project changed from Multi-Session Operations to MSO Enemy Generation
  • Category deleted (Script)

Updated by Tupolov over 3 years ago

  • Target version changed from MSO v4.6 to MSO v4.3

antipop wrote:

Here are some concerns from AAF in regards to Enemy population:

- Not enough infantry spawning. Probably primary concern.

TUP - Now can be configured in parameters.

- Not enough vehicles aswell.

TUP - Again can be configured now.

- Enemy not spread out evenly. We either run into nothing for ages, or lots in a small space of time, then nothing again.

TUP - This is now based on locations, let us know if there is a particular map you are seeing issues with.

- Enemy spawning but not patrolling, just staying in roughly same vacinitiy. Running around abit, but nothing too strategic.

TUP - This is by design, Enemy do defend or patrol but do not stray far from the location. Added house patrols now. Use HETMAN to get more strategic enemy movement.

- Enemy spawning in either too small, or too large groups. No tactical sniper teams, RPG teams etc.

TUP - Groups are set by BIS unfortunately. I would recommend creating your own group configs in your addon if you wish to see more diversity.

- Spawning in open, not in urban areas, or on strategic points like tops of valleys, which could provide excellent ambush positions etc.

TUP - This should now be fixed. Enemy pop spawned in all types of lcoations.

- Enemies don't use buildings, ususally in open fields when we hit them, and are sitting ducks.

TUP - As said enemy now (randomly) use the house patrol script.

- Also, there is usually a lot of armour for the types of missions we are running. Sometimes we run into one squad, but then like 5 tanks and then a BRDM etc. Ruins the immersion a tad.

TUP - Now configurable parameter on how much armour there will be.

- Plus, I feel there aren't enough 'Camps'. Or when there are lots, they are spawned in either really good, or really bad localities. Camps that spawn at strategic points would be perfect.

TUP - Camp % is set at 25% probability. You can configure this in the script enemy pop main.sqf.

Antipop - I will close this ticket if you don't provide feedback on these points within a day or so.

Updated by Tupolov over 3 years ago

  • Status changed from Feedback to Closed

Updated by Tupolov over 3 years ago

  • % Done changed from 0 to 100

Also available in: Atom PDF