Bug #25743

earthern_rampart / map_fort_rampart prevents AI in vehicle to see over it

Added by kOepi over 3 years ago. Updated over 2 years ago.

Status:Feedback Start date:10/21/2011
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:AI Issues
Target version:-
Affected ArmA II version:1.60 BETA First affected build:BUILD 83740
Reproduced by another DH user:No First affected ArmA II version:1.59 BETA
I am using some Mods:No Single / Multi Player?:
I am using:CO (OA+A2) BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

Hello guys.

I would like to introduce you to this issue with the AI in a vehicle and a fortified position,
in this case "earthern_rampart";

Observed

The AI is not able to see over the edge of the rampart. approximately covering half of a bmps profile it will
allow the AI to look "over" AND being attacked by AI.

In the Mission there are two BMPs each manned with commander and gunner behind ramparts which are in two different
levels placed. the right one is the standart level given in 3D editor and the left one is the one that gives the most cover, most visibility and freedom to use every weapon as the gunner, even before the gun "touches" the rampart.

As you can see in the mission the AI does not see you when you are on the other side, even shooting at them doesnt make them find you.

Expected

Expected would be that the commanders spots you and the gunner starts shooting at you aslong you are in sight of the commander/gunner, even when there rampart is blocking the line of fire.

arma2oa.RPT (2 MB) kOepi, 10/21/2011 17:04

rampart2d.utes.pbo.7z (1.1 kB) kOepi, 10/21/2011 17:04

rampart_test.utes.7z (711 Bytes) Hellfire257, 10/31/2011 00:37

rampart2d.utes.7z (1.2 kB) kOepi, 03/09/2012 13:42

History

Updated by Fireball over 3 years ago

  • Due date set to 11/13/2011
  • Status changed from New to Feedback

Thanks for your ticket. Please make a simple repro of your issue with a repro mission in Utes or Desert with minimal units needed, only showing that very issue.

Rampart sounds like a full user mission or is it not?

And please format your ticket to clear headers:

Observed

Expected

Repro steps

Be as precise as possible but no wall of text, now it's almost too much - or at least it's too unstructured.

Thank you in advance.

Updated by Hellfire257 over 3 years ago

Cannot reproduce.

I didn't use the attached mission but made one myself. The BMP engaged me when I made myself noticed.

Make sure you're also running no mods when reporting bugs. Your RPT suggests you're running ACE.

Updated by Fireball over 3 years ago

  • Reproducible for you changed from No to Yes

Please do not unset this, as it's reproducible for the original poster. The other checkbox (Repro'ed by another DH user) is unchecked for that reason. But apart from that you're right; verify that you can repro the bug without any mod before reporting.

Will reject if there's no usable repro and steps until due date.

Updated by zGuba over 3 years ago

  • Status changed from Feedback to Expired

Updated by kOepi about 3 years ago

hey guys, got time now again. do I create a new post?

still reproducable for me without any mods and latest BETA, same example Mission.

Updated by Fireball about 3 years ago

  • Description updated (diff)
  • Status changed from Expired to Feedback

Needs reproduction by another DH user for confirmation. Else its maybe a beta installation mistake or similar, since you say the build in your main menu says you were running 1.59.

Updated by Fireball about 3 years ago

  • Due date deleted (11/13/2011)

Updated by kOepi about 3 years ago

  • Affected ArmA II version changed from 1.59 BETA to 1.60 BETA

yes, that was my mistake, was unable to run it.
now I am sure I run the beta. 1.60.89223

actually my mission is pretty good, because it exposes only the turret.

Updated by Fireball about 3 years ago

When I start rampart2d.utes.pbo, through Scenarios, I only get a detached camera view above Utes airport and I hear some engine igniting, but it's out of sight. Also, no controls are available. Any idea what's going wrong?

Updated by kOepi about 3 years ago

its not a typical mission, but you can start it from the editor, try it via the editor.

Updated by kOepi about 3 years ago

Updated by kju over 2 years ago

  • Assignee deleted (admin)
  • Private changed from Yes to No

Also available in: Atom PDF