Bug #25633

[HR] First To Fight [Multiplayer] helicopter insertion kills human players 2, 3 and 4

Added by Hanzu almost 4 years ago. Updated over 3 years ago.

Status:Closed Start date:10/18/2011
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:Campaign
Target version:1.11.86734
Affected ArmA II version:1.60 BETA First affected build:
Reproduced by another DH user:No First affected ArmA II version:1.54.72888
I am using some Mods:No Single / Multi Player?:MP Only
I am using:CO (OA+A2) BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

Reproduce
  1. Play First To Fight in Multiplyer with 2-4 human players.
  2. Leave carrier by talking with helicopter pilot
  3. You all are automatically teleported inside helicopter
Observe
  1. Host player always survives, but one or all human players always die to this teleportation.
  2. Look around and you see their characters collapse on their seats
  3. Mission will fail and next mission will not be unlocked
Expected
  1. All characters should survive entering the helicopter
Notes
  1. Workaround for this is to tell client players to disconnect before talking with helicopter pilot and then join back when flight has alredy started.

This bug has happened with every patch we have tried.

Workaround

First_To_Fight__Multiplayer__kills_clients_in_helicopter_takeoff__5_.jpg - Lofty killed, Wolf killed (172 kB) Hanzu, 10/18/2011 22:06

First_To_Fight__Multiplayer__kills_clients_in_helicopter_takeoff__6_.jpg - Lofty killed, Wolf killed (172.6 kB) Hanzu, 10/18/2011 22:06

First_To_Fight__Multiplayer__kills_clients_in_helicopter_takeoff__8_.jpg - Before this client have to disconnect for mission to work (51.1 kB) Hanzu, 10/18/2011 22:06

First_To_Fight__Multiplayer__kills_clients_in_helicopter_takeoff__9_.jpg - Game desyncing because 2 joiners (180.6 kB) Hanzu, 10/18/2011 22:06

First_To_Fight__Multiplayer__kills_clients_in_helicopter_takeoff__10_.jpg - All synced and characters view controllable (183.2 kB) Hanzu, 10/18/2011 22:06

History

Updated by Hanzu almost 4 years ago

  • Due date deleted (01/19/2012)
  • Status changed from New to Resolved
  • Target version set to Upcoming version
  • Difficulty deleted (Expert)

Fixed.

Updated by Sickboy almost 4 years ago

  • Target version changed from Upcoming version to 1.60 BETA

Updated by Dwarden almost 4 years ago

  • Target version changed from 1.60 BETA to Upcoming version A2
  • Single / Multi Player? set to MP Only

Updated by Hanzu almost 4 years ago

  • Status changed from Resolved to Closed
  • I am using set to CO (OA+A2)
  • BIForumURL (Use new instead) set to http://forums.bistudio.com/showthread.php?t=107952

Fixed in ARMA 2 beta 1.11.86688, not tested yet because can't test multiplayer issues requiring 2 or more players alone, but I'm pretty confident this is fixed.

Thank you BIS!

If issue still shows up, let us know and this ticket can be re-Assigned.

Updated by kju almost 4 years ago

  • Target version changed from Upcoming version A2 to 1.11 BETA

Updated by kju over 3 years ago

  • Target version changed from 1.11 BETA to 1.11.86734

Also available in: Atom PDF