Bug #2562

Moving AI see too well

Added by acf over 6 years ago. Updated about 6 years ago.

Status:Closed Start date:07/05/2009
Priority:Normal Due date:08/24/2009
Assignee:acf % Done:


Category:AI Issues
Target version:1.03.58627
Affected ArmA II version:1.02.58134 First affected build:
Reproduced by another DH user: First affected ArmA II version:
I am using some Mods: Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you: NGUrl:
Related to content of DLC: WIKIurl:


Testing for Bug 2209 suggested that moving AI units were as observant as stationary AI. This does not seem realistic - movement should significantly degrade ability to observe. Putting it another way, stationary AI should see much better than moving AI. A formal test was needed to verify this suspicion.

To maximise repeatability, the test took place on the Utes runway. A single, ammo=0, skill=1, setunitpos "UP" Russian rifleman was placed at one end. A pair of skill=1 USMC riflemen were placed approximately 300m away. They were given a single waypoint with defined behaviour and speed. An 'OPFOR detected by BLUFOR' trigger hinted the OPFOR-BLUFOR distance. Tests were run at 2x speed for various behaviour

The results can only be taken as relative indicators of ability. Many variables may or may not affect visual detection and I don't know what they are, how much effect they have or how much they are randomised.


AI observers' ability does not vary greatly with their speed. A moving AI unit is nearly as likely to see you as a stationary one.

AI observer ability algorithms should take into account the speed of the observer. A coarse multiplier could be as simple as:

Movement_____Speed km/h__Visual ability
Slow walk________3_______50.0%
Fast walk________6_______25.0%

nb a 4 minute mile is ~24km/h

Utes_20seeing_20while_20moving.zip (997 Bytes) acf, 07/05/2009 01:15

Related issues

related to ARMA2 Community Issue Tracker - Bug #2209: AI units can't spot standing enemy at 250m. with clear li... Closed 06/22/2009


Updated by kju over 6 years ago

  • Status changed from New to Feedback

Thanks acf. Good report!

Repro steps / what to do for the test mission missing though.

The demo algorithm is ways to extreme.
At least even while sprint as human you can see fairly well.
Especially with 2nd mouse button zoom.

Updated by acf over 6 years ago

Thanks for the feedback.

Repro steps: it's basically a case of re-running the mission in the editor, adjusting the waypoint Behaviour and Speed as you go. There is always a bit of variation, at most about 10%, so the the figures I've quoted are averages of 3-5 runs on each setting.

The suggestion was an attempt to make the criticism constructive, the severe degradation was to get people thinking. I also have the view that target speed would have the inverse effect on its detectability - faster it moves, the easier it's seen - so there is compensation. I saw something like this in 2209 at an absolute level: a stationary target 250m away was not detected, a moving target was detected immediately and at longer ranges. It's difficult to draw detailed conclusions because there are so many potential variables - how does fatigue affect observation, for example?

If something like the suggestion is implemented, the AI would need to be encouraged to halt/pause and scan every so often in some behaviours to compensate (well, maybe just AWARE - they already pause in COMBAT and STEALTH and in SAFE they are supposed to be safe).

While I was testing, I was very conscious that I wouldn't have casually spotted the lone, standing, stationary OPFOR rifleman from 300m (he did have the trees behind him from my point of view). Also, one of the things that ArmA2 does make very easy (compared to real life) is sprinting without having to look where you are going - you can't trip over while you are zoom searching.

Updated by alef about 6 years ago

  • Due date set to 08/24/2009
  • Status changed from Feedback to Resolved
  • Assignee set to acf
  • Maxmem parameter set to Not set

This should have been fixed in 1_03. Most AI parameters has been tweaked. Could you please check? Thank you.

Updated by alef about 6 years ago

  • Target version set to 1.03.58627

Updated by Fireball about 6 years ago

  • Status changed from Resolved to Closed

Feedback timeout; due to own experience with patch 1.03 I can confirm this fixed.

Also available in: Atom PDF