Bug #25603

AI Spotting and Engagement decreased (Arma 2 : OA beta build 85510)

Added by Humvee28 almost 4 years ago. Updated almost 4 years ago.

Status:Rejected Start date:10/18/2011
Priority:Normal Due date:11/01/2011
Assignee:- % Done:

0%

Category:AI Issues
Target version:-
Affected ArmA II version:1.60 BETA First affected build:Please Specify...
Reproduced by another DH user:No First affected ArmA II version:1.60 BETA
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:No NGUrl:
Related to content of DLC: WIKIurl:

Description

It seems like that after applying the latest Beta Patch (85510 in my Case), the AI Spotting and Engagement Distances are heavy decreased.

Observed Behaviour:
Moving in upright and walking Pace towards the Enemy, who is looking in your Direction with free LOS, is possible without being spotted or engaged. First Contact Messages on both Sides at 200 Meters.

Expected Behaviour:
While moving towards the Enemy in clear visible Movement, Spotting and Engagement should happen earlier.

Reproduction Steps:
  1. Start the attached Repro Mission "AI_Spotting_Test.utes" in Singleplayer
  2. Move with your Group towards the Enemy in slow moving Pace.
  3. You will get the first Reactions on both Sides near the Airfield Fence (Distance here about 200 Meters)

AI_Spotting_Test.utes.pbo (4.7 kB) Humvee28, 10/18/2011 10:51

25603.utes.7z (1.1 kB) kju, 10/18/2011 12:35

25603b.utes.7z (1.1 kB) kju, 10/18/2011 12:35


Related issues

related to ARMA2 Community Issue Tracker - Bug #24631: Reveal is very Baised Closed 09/18/2011

History

Updated by kju almost 4 years ago

  • Description updated (diff)
  • Due date set to 11/01/2011
  • Category set to AI Issues
  • Status changed from New to Feedback
  • First affected ArmA II version changed from Please select... to 1.60 BETA

Updated by kju almost 4 years ago

Here is the mission automated having the AI leader view.
Two versions for the view of both sides.

I cannot see a difference in 1.59 vs latest 1.60 beta.

However what is strange is that if you watch the west Leader,
he immediately sees the east units and engages.

While watching the east unit, this does not seem to happen
and the west units move down to the airstrip before engaging.


Why did you remove the ammo of the west units (except the leader)?

Updated by Humvee28 almost 4 years ago

I don´t remember that it was so extreme with 1.59 Stable and the Beta Patches before?

What i mean is that i can´t remember that i could get so near to a static Enemy Group.

Since i tested the Scenario only as West Leader, i removed the Ammo to get the Contact Messages only from my Squad, without start firing.

Updated by Dwarden almost 4 years ago

any update on this problem (plus tested on 1.60.86xxx betas) ?

Updated by Humvee28 almost 4 years ago

I will check it out immediately, Dwarden.

Updated by Sickboy almost 4 years ago

Well pre-v1.60 all AI were super AI because skills were not properly applied.
Perhaps this is the difference you have measured. Question is what is the skill set to of the units.

Updated by Humvee28 almost 4 years ago

Unit-Skills are Default by Placement.

My Settings are : 1 - Friendly, 0.9 - Enemy, Super AI off.

Updated by Sickboy almost 4 years ago

Default placement is 0.66 or so, problem is pre v1.60 the unit skill didn't matter or didn't matter as much as it had to, so 0.66 could've been the same as 1.0.

Try putting the units to skill 1.0.

Actually, when analzying mission.sqm, I suppose you've placed groups, their skill is various, like:
  • Leader: 1.0
  • Others: 0.466666664
  • Last few units: 0.333333331 and 0.2.

So pre v1.60 all those units were basically using skill 1.0 regardless of mission.sqm skill setting,
and now in v1.60 they are more properly spread.

Updated by Sickboy almost 4 years ago

kju wrote:

However what is strange is that if you watch the west Leader,
he immediately sees the east units and engages.

While watching the east unit, this does not seem to happen
and the west units move down to the airstrip before engaging.

Perhaps related to: #24631

Updated by Humvee28 almost 4 years ago

Yep, East is setted as Group.

I´ve tried now with the two default Slider Settings (normal - 0.7, pro - 0.9) and the latest Beta (86434), and it seems good for me.

Spotting and Engagement started a good Amount earlier before you reach the Fence. Maybe it could be start a little bit more earlier, but i remember the Days of the

AK Snipers also, and so the Compromise should be good to go. :)

Since i´m playing always with ACE and ASR AI (I´m testing Patches with Mods and without, to get correct Results for everything),

this Case doesn´t matter me too hard, but i thought it would be a good Idea to mention it with a Ticket, due to the Vanilla Players Com.

EDIT : The courious thing is, before i setted up the Slider via Dropdown, it looked like the same Result before (1.0 also tested).

After setting up the Skill via Dropdown, i expirienced better Behaviour as mentioned above.

Updated by Fireball almost 4 years ago

So we can reject this one?

Updated by Humvee28 almost 4 years ago

Yes, we can! :D

Updated by Fireball almost 4 years ago

  • Status changed from Feedback to Rejected

Also available in: Atom PDF