Bug #25560

[HR] Manhattan mission Cpt. Shaftoe is sometimes killed by his chair because his feet are sticking through it.

Added by Hanzu about 4 years ago. Updated almost 4 years ago.

Status:Closed Start date:10/16/2011
Priority:Normal Due date:
Assignee:- % Done:


Target version:1.11.86734
Affected ArmA II version:1.60 BETA First affected build:
Reproduced by another DH user:No First affected ArmA II version:1.54.72888
I am using some Mods:No Single / Multi Player?:Both
I am using: BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:


  1. Set Difficulty Recruit and try to make AI as stupid as possible by disabling Super AI and decreasing AI difficulty value.
  2. Play Manhattan mission
  3. Visit FOB Manhattan often between completing Objectives to see if Cpt. Shaftoe is still standing (= alive)
  1. See Cpt. Shaftoe to stand with his both feet sticking through his chair.
  2. See Cpt. Shaftoe turning his whole body to face the direction from where you approach.
  3. See another soldier next to Cpt. Shaftoe always sitting and never stand up.
  4. Cpt. Shaftoe is sometimes found dead laying under his chair with blood on his feet.
  1. Cpt. Shaftoe should be made to always sit down on his chair. Supreme officer has zero reason to stand up for Cooper and even less reason keep standing during whole mission.
  2. Cpt. Shaftoe death should automatically end mission to failure. This would save you from making bad saves with Cpt. Shaftoe dead and making mission never ending.
  1. There has been a lot of discussion in the OFFICIAL MISSIONS subforums about this issue. So I'm nowhere near the only one to notice this issue.
  2. There has been an attempt for a fix in 1.04 patch, but it looks like that fix is not good enough, since issue still happens.
  3. I have not seen this when completing Manhattan twice with Expert Difficulty (and AI set as smart as possible), but now that I completed Manhattan with Recruit Difficulty Cpt. Shaftoe died twice while I was clearing Insurgent Sentry camps.
  4. The last Manhattan mission Objective/Task Report Cpt. Shaftoe can will be completed even when going close to dead Cpt. Shaftoe, but mission will not end even with all objectives done, since discussion with Cpt. Shaftoe normally ends this mission.
  5. Me and Fireball reproduced another Manhattan Multiplayer related issue together and both saw that when we went in front of Cpt. Shaftoe he rotated 180 degrees and turned his back to us (maybe because one AI controlled Razor Team member was running somewhere there to regroup with us) but mission ended successfully with him speaking to use but not looking to us.

Other reports of related problems
*http://forums.bistudio.com/showpost.php?p=1988343&postcount=6 (with 1.09 patch) *

Manhattan_mission_Cpt._Shaftoe_is_sometimes_killed_by_his_chair_because_his_feet_are_sticking_through_it__6_.jpg - Feet sticking through metal chair. (295.9 kB) Hanzu, 10/16/2011 22:54

Manhattan_mission_Cpt._Shaftoe_is_sometimes_killed_by_his_chair_because_his_feet_are_sticking_through_it__10_.jpg - Blood where foot penetrates metal chair = obvious reason for death. (433 kB) Hanzu, 10/16/2011 22:54

Manhattan_mission_Cpt._Shaftoe_is_sometimes_killed_by_his_chair_because_his_feet_are_sticking_through_it__12_.jpg - Mission will not end even with all objectives completed. (319.2 kB) Hanzu, 10/16/2011 22:54

Related issues

related to ARMA2 Community Issue Tracker - Bug #12248: [HR] Manhattan mission Task: Arrest Nikolayev malfunction Rejected 07/23/2010


Updated by Hanzu about 4 years ago

  • Description updated (diff)
  • Status changed from New to Assigned

Updated by Hanzu about 4 years ago

Death of Cpt. Shaftoe makes some Tasks/Objectives that were not yet completed to malfunction.

Known side effects of this issue:

Task: Arrest Nikolayev
There will be no usual radiomessage when you approach Khelm and Villager that usually bombs Niklayev's house is just sitting inside his green Skoda, but exits it and runs away to the other side of the village when you approach. Destroying Nikolayev's house with Javelin or by any means will not complete task.

Task: Arrest Lagushina
You find can find Lagushina and automatic dialog is triggered, but she will not move. Not even when wounded.

Updated by Sickboy about 4 years ago

  • Status changed from Assigned to Resolved
  • Target version set to Upcoming version


Fixed now. The camo net still collapses sometimes, Shaftoe doesn't seem to mind though.

Updated by Sickboy about 4 years ago

  • Target version changed from Upcoming version to 1.60 BETA

Updated by Hanzu about 4 years ago

  • Due date deleted (01/17/2012)
  • Status changed from Resolved to Closed
  • BIForumURL (Use new instead) set to http://forums.bistudio.com/showthread.php?t=125190
  • Single / Multi Player? set to Both

Fixed in ARMA 2 beta 1.11.86688. Because of this issue happened quite randomly, it would require multiple hours of Manhattan mission to see if fix is 100% reliable. I have a little bit doubt that issue is still not completely gone because:

Cpt. Shaftoe still stands up when Cooper approaches him first time.
Cpt. Shaftoe still rotates restelessly when talking and turns his back and faces away from Cooper.
Cpt. Shaftoe still has his feet sticking through his chair.

The only change I found was that Cpt. Shaftoe was moved some centimeters towards his table after the briefing ended but one of his knees is still partly inside the chair.

I still believe best choice would have been to keep him sitting down and not standing up for you (and for the rest of the mission).

But anyway, if problem is finally gone thank you BIS!

If issue still shows up, let us know and this ticket can be re-Assigned.

Updated by Dwarden about 4 years ago

  • Target version changed from 1.60 BETA to Upcoming version A2

Updated by kju about 4 years ago

  • Target version changed from Upcoming version A2 to 1.11 BETA

Updated by kju almost 4 years ago

  • Target version changed from 1.11 BETA to 1.11.86734

Also available in: Atom PDF