Bug #25531

When I play Sick1's Seal Team 6 DEVGRU at the last mission it occurs a CTD after finising loading with OA BETA

Added by msy over 3 years ago. Updated over 3 years ago.

Status:Closed Start date:10/16/2011
Priority:Low Due date:
Assignee:Suma % Done:

0%

Category:Game Crash
Target version:1.60.87580
Affected ArmA II version:1.60 BETA First affected build:85015
Reproduced by another DH user:No First affected ArmA II version:1.60 BETA
I am using some Mods:Yes Single / Multi Player?:
I am using:CO (OA+A2) BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

I am playing Sick1's campaign Seal Team 6 DEVGRU and at the last mission BAD KARMA II after the mission finishing loading map it occurs a CTD if I play with OA BETA at least from 1.59.85015 to 85478 every time. If I paly this mission with out beta (official full version 1.59.79384) then it is OK to play.

I don't know if this rpt file can help solve some problem. I am afraid maybe the new improvement in 1.60 beta has affected some third partys' mission.
The reference of the campaign is here:
http://forums.bistudio.com/showthread.php?t=120674
And there is some information from WINDOWS:
Problem Event Name: APPCRASH
Application Name: arma2oa.exe
Application Version: 1.59.85.478
Application Timestamp: 4e98435f
Fault Module Name: arma2oa.exe
Fault Module Version: 1.59.85.478
Fault Module Timestamp: 4e98435f
Exception Code: c0000005
Exception Offset: 005d849b
OS Version: 6.1.7601.2.1.0.256.1
Locale ID: 2052
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

ArmA_2_OA.rar - all three files are in it (1019.7 kB) msy, 10/16/2011 08:53

History

Updated by msy over 3 years ago

  • Description updated (diff)

Updated by msy over 3 years ago

  • Description updated (diff)

Updated by kju over 3 years ago

  • Category set to Game Crash
  • Status changed from New to Feedback
  • Assignee set to Dwarden

Please read: How to report a crash?
In short the dump files are missing.

Updated by msy over 3 years ago

I'm sorry I forgot to read how to report CTD issue...
I uploaded a new CTD rpt.rar which includes 3 files.

Updated by msy over 3 years ago

  • File deleted (arma2oa.RPT)

Updated by kju over 3 years ago

thanks

Exception code: C0000005 ACCESS_VIOLATION at 009D849B
graphics:  D3D9, Device: ATI Radeon HD 4800 Series        , Driver:aticfx32.dll 8.17.10.1086
resolution:  1680x1050x32
Addons:
Mods: f:\mod\@duala
Distribution: 1486
Version 1.59.85478
Fault address:  009D849B 01:005D749B F:\ArmA 2\Expansion\beta\arma2oa.exe
file:     5M9
world:    isladuala
campaign: Campaigns\devgru_cmp
battle:   Beginning
mission:  m9
Prev. code bytes: 00 7E 1C 8B FF 8B 87 4C 13 00 00 8B 0C B0 8B 11
Fault code bytes: 8B 02 FF D0 83 C6 01 3B B7 50 13 00 00 7C E6 5F

Registers:
EAX:6BEE6400 EBX:00001340
ECX:6E2782F8 EDX:00000001
ESI:00000048 EDI:7C2AE040
CS:EIP:001B:009D849B
SS:ESP:0023:0185EEE8  EBP:00001340
DS:0023  ES:0023  FS:003B  GS:0000
Flags:00210293

Updated by Dwarden over 3 years ago

  • Status changed from Feedback to In progress
  • Assignee changed from Dwarden to Suma
  • Priority changed from Normal to Low
  • Target version set to Upcoming version
  • NGurl (Use new instead) set to news:j7h4a0$jtj$1@new-server.localdomain

on queue for analysis ...

Updated by Dwarden over 3 years ago

  • NGurl (Use new instead) changed from news:j7h4a0$jtj$1@new-server.localdomain to news:j7h4be$jv4$2@new-server.localdomain

Updated by Suma over 3 years ago

  • Status changed from In progress to Resolved

The crash was caused by switchLight used on a helicopter. This scripting command type checking was implemented badly and using it on an object which was not in fact a street lamp could cause data corruption or a crash.

Fixed in 85604.

Updated by kju over 3 years ago

  • Target version changed from Upcoming version to 1.60 BETA

Updated by msy over 3 years ago

I confirm this CTD issue has been fixed, so it can be closed.

Updated by kju over 3 years ago

  • Status changed from Resolved to Closed

tx

Updated by kju over 3 years ago

  • Target version changed from 1.60 BETA to 1.60.87580

Also available in: Atom PDF