Bug #2552

AI and player climbing ladders

Added by F2kSel over 5 years ago. Updated over 4 years ago.

Status:Closed Start date:07/04/2009
Priority:Normal Due date:09/01/2010
Assignee:alef % Done:

100%

Category:AI Issues
Target version:1.51.71083
Affected ArmA II version:1.05.62017 First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:No NGUrl:
Related to content of DLC: WIKIurl:

Description

Bugs
  • two building position shown as #1, one on the top the other at the base
  • player hurst the AI as he reaches the top
  • player is stuck at that position
  • player falls at the edge
Expected
  • only one building position shown
  • previous human should not be hurt
  • player should be able to move around
  • player should no fall
Repro
  • order the AI climb the illuminant tower
  • as AI reached the top, climb it yourself
  • restart the mission, then climb the tower yourself
  • walk away and let you fall down

I've had a few problems with the AI and objects placed from the editor.

Illuminant tower, you carn't order an AI in your group to climb the tower.
Also as a player if you climb the tower you get stuck at the top,if you do happen to get free you can fall over the edge.

Anti Air Radar, if you order an AI to climb the ladder it gets stuck underneath and starts running on the spot.

A lot of objects carn't have the AI move to positions within them using waypoints unlike map buildings.

Some objects such as scaffolding can only have units in your group move to positions on in it but AI using way points carn't.

CIT_2552.Chernarus.7z - Illuminant tower: repro (695 Bytes) alef, 07/05/2009 17:53

CIT_2552_1.mp4 - Illuminant tower: clibimng (13.4 MB) alef, 07/05/2009 17:53

CIT_2552_2.mp4 - Illuminant tower: falling (1 MB) alef, 07/05/2009 17:53


Related issues

related to ARMA2 Community Issue Tracker - Bug #1678: Ladder Bug Closed 05/31/2009
related to ARMA2 Community Issue Tracker - Bug #6905: Player drops from top of the watchtower ladder when playe... Closed 12/13/2009
duplicated by ARMA2 Community Issue Tracker - Bug #4388: Illuminant tower bugs Duplicate 09/08/2009 01/18/2010

History

Updated by zGuba over 5 years ago

I guess that this is mostly model issue, since AI can use ladders on some buildings quite well when ordered to move to particular spot. However it likes to fall from the edges instead of going back the same way.

Updated by F2kSel over 5 years ago

I placed an AI at the top of the Illuminant tower and it stayed there quite well. I than placed a move point on him and was surprised to see that he could use the ladder to climb down even though he carn't climb up.

Updated by alef over 5 years ago

To order the AI climb up the ladder, you have to select the bottom.

Updated by kju over 5 years ago

  • Status changed from New to Feedback

Simple test / repro missions for each would be very helpful.

Updated by alef over 5 years ago

Repro
  • order the AI climb the illuminant tower
  • as AI reached the top, climb it yourself
  • restart the mission, then climb the tower yourself
  • walk away and let you fall down
Bugs
  • two building position shown as #1, one on the top the other at the base
  • player hurst the AI as he reaches the top
  • player is stuck at that position
  • player falls at the edge
Expected
  • only one building position shown
  • previous human sholud not be hurt
  • player should be able to move adound
  • player should no fall

Updated by alef over 5 years ago

  • Subject changed from AI and objects problems to AI climbing ladders

Updated by alef over 5 years ago

  • Due date set to 07/20/2009

Updated by alef over 5 years ago

  • Due date changed from 07/20/2009 to 11/01/2009
  • Status changed from Feedback to Assigned

Updated by alef over 5 years ago

  • Affected ArmA II version changed from 1.02.58134 to 1.03.58627

Updated by Fireball over 5 years ago

  • Affected ArmA II version changed from 1.03.58627 to 1.04.59026
  • Difficulty set to Not set
  • Reproduced by another DH user set to Yes
  • CPU set to Please specify!

The repro mission still shows the problem.

Also seeing this, e.g. with the raised hide (hunter seat).

Updated by Dwarden over 5 years ago

  • Assignee set to Dwarden

Updated by Fireball over 5 years ago

  • Due date changed from 11/01/2009 to 12/01/2009

Updated by Fireball over 5 years ago

  • Subject changed from AI climbing ladders to AI and player climbing ladders

Updated by zGuba almost 5 years ago

  • Affected ArmA II version changed from 1.04.59026 to 1.05.62017

Updated by kju over 4 years ago

  • Due date changed from 12/01/2009 to 11/01/2010
  • Audio card set to Please specify!
  • Size of OS swap file set to Please specify!
  • I am using some Mods set to No
  • Reproducible for you set to No

Updated by kju over 4 years ago

  • Due date changed from 11/01/2010 to 09/01/2010
  • Status changed from Assigned to Resolved
  • Assignee changed from Dwarden to alef
  • Target version set to 1.51.71083

Cannot repro either one. Seems resolved. Please confirm.

Updated by Dwarden over 4 years ago

  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF