Feature #25480

Incorrect RPG simulation

Added by tolko_download almost 4 years ago. Updated almost 4 years ago.

Status:Rejected Start date:10/14/2011
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:-
Component: Affected Version:
Close Reason:By design/Not a Bug

Description

1. RPG ammo has rocket-like engine. So the fly traectory should be straight on the most part of path, while the rocket engine is working. It is about 300m for RPG-7 (7V/7VL/7VM etc). On the second part (when rocket eng. is off) of route RPG behaves as a shell, spending kinetic and potential energy as a bullet.

2. RPG-7 V/VL/VM/VR/TBG/OG has a negative drift: wind effect is vice versa for RPG Rocket.

3. RPG-7 has native bipods. We have no a proper model for that feature but can you add it to RPG like rifles has ability to use blocks (sand bags, brick walls etc).

4. RPG-7 Rocket has behaviour like GL nades. It is activated only if rocket's stabilizer is deployed: about 20-30m after shoot.

The source I have is RPG-7 Manual (originaly on russian language).

I guess other RPG should have same balistic due common principes of rocket engine.

Наставление_по_стрелковому_делу_Ручной_противотанковый_гранатомет__РПГ-7_и_РПГ-7Д___1983_.djvu - RPG-7 Manual (1.6 MB) tolko_download, 10/14/2011 16:01

rpg_ballistic.utes.pbo (3.6 kB) tolko_download, 10/16/2011 08:30

rpg_01.JPG (73.5 kB) tolko_download, 10/16/2011 08:30

rpg_02.JPG (188.4 kB) tolko_download, 10/16/2011 08:30

rpg_03.JPG (82.6 kB) tolko_download, 10/16/2011 08:30

History

Updated by tolko_download almost 4 years ago

  • Description updated (diff)

text spelling

Updated by boota almost 4 years ago

1. No, RPG ammo still has ballistic drop over distance even with booster engine on. Drop over time is same with or without engine, exept while booster is active, grenade flies faster, obviously. Ballistic drop compensator in PGO-7 scope isn't just eye-candy.
In fact, with ACE ballistic model I can achieve accuracy I would never dream of with real RPG-7.
3. You're sure, you're not mistaking it with RPG-16, which looks very like RPG-7? Personaly I never saw bipod on RPG-7.

Updated by rye almost 4 years ago

3. http://upload.wikimedia.org/wikipedia/id/thumb/2/2a/Chicomtype69rpg.jpg/300px-Chicomtype69rpg.jpg
http://www.globalsecurity.org/military/library/policy/army/accp/in0546/image2204.gif

Updated by boota almost 4 years ago

True, Rye, if I put in google "RPG-7V2" instead of "RPG-7" there's a lot of them, seem they really started adding them as standard. Might explains why I never saw one, silly me.

Updated by Sickboy almost 4 years ago

  • Status changed from New to Feedback
  • Target version set to 1.13

Updated by tolko_download almost 4 years ago

boota wrote:

1. No, RPG ammo still has ballistic drop over distance even with booster engine on. Drop over time is same with or without engine, exept while booster is active, grenade flies faster, obviously. Ballistic drop compensator in PGO-7 scope isn't just eye-candy.
In fact, with ACE ballistic model I can achieve accuracy I would never dream of with real RPG-7.
3. You're sure, you're not mistaking it with RPG-16, which looks very like RPG-7? Personaly I never saw bipod on RPG-7.

1. Yeah, it has. But it is realy very small. Quote from RPG-7 manual in few varints (for understanding :P)

Страница 6
3. Наиболее действителен огонь из гранатомета по танкам, самоходно-артиллерийским установкам и другим целям, имеющим >высоту 2 м и более, на дальности прямого выстрела, равной для выстрела, равной для выстрела ПГ-7В - 330 м, ПГ-7ВМ - >310 м.

translate.google.com

page 6
3. The most valid fire a grenade at the tanks, self-propelled guns and other purposes, having a height of 2 m or >more, at a range of direct shot is equal to the shot, equal to the shot PG-7V - 330 m, PG-7VM - 310 m.

translate.ru

Page 6
3. Fire from a grenade cup discharge on tanks, samohodno-artillery installations and other purposes having height of >2 m and more, at the range of a direct shot equal for a shot, equal for shot ПГ-7В - 330 m, ПГ-7ВМ - 310 m. is most >valid

my translation

Page 6
3. The RPG fire is most effective against tanks, artillery and other targets with >= 2 m height, at the range of >straight shot (see comments below), which is 300 m for PG-7V, 310 for PG7VM.

The term "straight shot" is a difficult to translate to english, I believe there is same in english language. "Straight shot" means the highest point of trajectory doesn't cross plane parallel to a ground surface and with target height.

Currently we have very unrealistic traejctory, it crosses that plane with over 2x target's height.

RPG-7 with bipods was started to use when I wasn't born, many time ago ^^) So, there is no model with bipods, but at least would be nice to use ability to use weapon rest for RPG-7 (and other RPGs if it is allowed).

Thanks for attention.

Updated by q1184 almost 4 years ago

  • Status changed from Feedback to Rejected
  • Target version deleted (1.13)
  • Close Reason set to By design/Not a Bug

tolko_download wrote:

The term "straight shot" is a difficult to translate to english, I believe there is same in english language. "Straight shot" means the highest point of trajectory doesn't cross plane parallel to a ground surface and with target height.

Currently we have very unrealistic traejctory, it crosses that plane with over 2x target's height.

When you observe the rocket going above the 2 m target at 300 m before descending on it you are not considering the perspective (angular size of objects decreasing with distance). A 2 m target at 300 m is ~6.67 mils high while the highest point of trajectory (2 m at 150 m according to the ballistic table from the manual) makes 13.3 mils or twice as much. So if you shoot a 2 m target at 300 m with sight set to 300 and aim at the bottom, the rocket will go up as high as 2x the target height in your view. Which is what happens in the game currently. You can also track the rocket with a script and confirm that it doesn't go above 2 m above the aiming line when shooting at 300 m.

As for the bipods, please create a separate ticket, it's hard to deal with different issues in one.

Updated by tolko_download almost 4 years ago

Just completed some tests. Repro mission attached.

Got following results:

"==================== BEGIN ===================="
"initialHeightATL=0.27643"
"currentHeightATL=0.40649"
"currentHeightATL=0.519993"
"currentHeightATL=0.636175"
"currentHeightATL=0.743076"
"currentHeightATL=0.849979"
"currentHeightATL=0.949284"
"currentHeightATL=1.04347"
"currentHeightATL=1.13808"
"currentHeightATL=1.2283"
"currentHeightATL=1.31803"
"currentHeightATL=1.41408"
"currentHeightATL=1.50235"
"currentHeightATL=1.58947"
"currentHeightATL=1.67029"
"currentHeightATL=1.75616"
"currentHeightATL=1.86285"
"currentHeightATL=1.9484"
"currentHeightATL=2.03162"
"currentHeightATL=2.08808"
"currentHeightATL=2.15777"
"currentHeightATL=2.2317"
"currentHeightATL=2.30081"
"currentHeightATL=2.369"
"currentHeightATL=2.42684"
"currentHeightATL=2.48682"
"currentHeightATL=2.54168"
"currentHeightATL=2.59339"
"currentHeightATL=2.6392"
"currentHeightATL=2.68002"
"currentHeightATL=2.71514"
"currentHeightATL=2.74577"
"currentHeightATL=2.77227"
"currentHeightATL=2.79309"
"currentHeightATL=2.8083"
"currentHeightATL=2.81853"
"currentHeightATL=2.82439"
"currentHeightATL=2.82551"
"currentHeightATL=2.82191"
"currentHeightATL=2.81353"
"currentHeightATL=2.80028"
"currentHeightATL=2.7824"
"currentHeightATL=2.75937"
"currentHeightATL=2.73187"
"currentHeightATL=2.68594"
"currentHeightATL=2.63784"
"currentHeightATL=2.58791"
"currentHeightATL=2.55243"
"currentHeightATL=2.5059"
"currentHeightATL=2.44824"
"currentHeightATL=2.38769"
"currentHeightATL=2.32078"
"currentHeightATL=2.25149"
"currentHeightATL=2.17781"
"currentHeightATL=2.09982"
"currentHeightATL=2.01645"
"currentHeightATL=1.92731"
"currentHeightATL=1.83641"
"currentHeightATL=1.74"
"currentHeightATL=1.64072"
"currentHeightATL=1.53411"
"currentHeightATL=1.42161"
"currentHeightATL=1.30792"
"currentHeightATL=1.19175"
"currentHeightATL=1.07346"
"currentHeightATL=0.94928"
"currentHeightATL=0.780231"
"currentHeightATL=0.634735"
"currentHeightATL=0.496918"
"currentHeightATL=0.400278"
"currentHeightATL=0.271124"
"currentHeightATL=0.120859"
"currentHeightATL=-0.0310535"
"_bullet destroyed"
"===================== END ====================="

"getPosATL select 2" executed for RPG rocket in per frame handler and dumped to .RPT (see init.sqf).

2.82551 - initial height = 2.54908 m.
The T-72 is 2.2m height. Well it's not like "over 2x" as I said above but I see the difference 2.54908 - 2.19 = 0.35908 m.
Hmm?

Updated by tolko_download almost 4 years ago

Mission and screenshots

Updated by q1184 almost 4 years ago

You seem to be using PG-7VL, while the tables are for V/VM. VL is heavier and slower, resulting in a steeper trajectory.

Updated by tolko_download almost 4 years ago

PG-7V @ 330 m:
"==================== BEGIN ===================="
"initialHeightATL=0.277201"
"currentHeightATL=0.375254"
"currentHeightATL=0.471043"
"currentHeightATL=0.558739"
"currentHeightATL=0.656609"
"currentHeightATL=0.735689"
"currentHeightATL=0.816307"
"currentHeightATL=0.884874"
"currentHeightATL=0.966"
"currentHeightATL=1.04744"
"currentHeightATL=1.1313"
"currentHeightATL=1.21766"
"currentHeightATL=1.30194"
"currentHeightATL=1.38881"
"currentHeightATL=1.47584"
"currentHeightATL=1.5623"
"currentHeightATL=1.64667"
"currentHeightATL=1.72904"
"currentHeightATL=1.81127"
"currentHeightATL=1.89067"
"currentHeightATL=1.9708"
"currentHeightATL=2.04657"
"currentHeightATL=2.12222"
"currentHeightATL=2.19405"
"currentHeightATL=2.2643"
"currentHeightATL=2.32807"
"currentHeightATL=2.387"
"currentHeightATL=2.45634"
"currentHeightATL=2.5067"
"currentHeightATL=2.5469"
"currentHeightATL=2.5717"
"currentHeightATL=2.60041"
"currentHeightATL=2.62669"
"currentHeightATL=2.64727"
"currentHeightATL=2.66243"
"currentHeightATL=2.67213"
"currentHeightATL=2.677" 2.677 - 0.277201 = 2.399799 > 2.19 // a bit higher than IRL (maybe related to native dispersion)
"currentHeightATL=2.6766"
"currentHeightATL=2.67094"
"currentHeightATL=2.66039"
"currentHeightATL=2.6447"
"currentHeightATL=2.62366"
"currentHeightATL=2.59771"
"currentHeightATL=2.56617"
"currentHeightATL=2.53097"
"currentHeightATL=2.49068"
"currentHeightATL=2.44616"
"currentHeightATL=2.38324"
"currentHeightATL=2.32519"
"currentHeightATL=2.25843"
"currentHeightATL=2.20231"
"currentHeightATL=2.12863"
"currentHeightATL=2.05413"
"currentHeightATL=1.97756"
"currentHeightATL=1.89787"
"currentHeightATL=1.81532"
"currentHeightATL=1.72767"
"currentHeightATL=1.63729"
"currentHeightATL=1.54154"
"currentHeightATL=1.44347"
"currentHeightATL=1.33992"
"currentHeightATL=1.23403"
"_bullet destroyed"
"===================== END ====================="

PG-7VM @ 310 m:
"==================== BEGIN ===================="
"initialHeightATL=0.277416"
"currentHeightATL=0.372044"
"currentHeightATL=0.461416"
"currentHeightATL=0.54813"
"currentHeightATL=0.626925"
"currentHeightATL=0.700611"
"currentHeightATL=0.769384"
"currentHeightATL=0.841143"
"currentHeightATL=0.917158"
"currentHeightATL=0.99544"
"currentHeightATL=1.09302"
"currentHeightATL=1.17284"
"currentHeightATL=1.25435"
"currentHeightATL=1.317"
"currentHeightATL=1.39656"
"currentHeightATL=1.47442"
"currentHeightATL=1.55225"
"currentHeightATL=1.62975"
"currentHeightATL=1.71886"
"currentHeightATL=1.79684"
"currentHeightATL=1.87536"
"currentHeightATL=1.93898"
"currentHeightATL=2.00868"
"currentHeightATL=2.06994"
"currentHeightATL=2.12873"
"currentHeightATL=2.18196"
"currentHeightATL=2.23081"
"currentHeightATL=2.27255"
"currentHeightATL=2.30923"
"currentHeightATL=2.34047"
"currentHeightATL=2.36601"
"currentHeightATL=2.38598"
"currentHeightATL=2.40067"
"currentHeightATL=2.40995"
"currentHeightATL=2.41361" 2.41361 - 0.277416 = 2.136184 < 2.19 // looks like OK
"currentHeightATL=2.41213"
"currentHeightATL=2.40512"
"currentHeightATL=2.39285"
"currentHeightATL=2.37561"
"currentHeightATL=2.35347"
"currentHeightATL=2.32555"
"currentHeightATL=2.2931"
"currentHeightATL=2.25502"
"currentHeightATL=2.21241"
"currentHeightATL=2.16439"
"currentHeightATL=2.08956"
"currentHeightATL=2.01834"
"currentHeightATL=1.94052"
"currentHeightATL=1.88601"
"currentHeightATL=1.81178"
"currentHeightATL=1.7328"
"currentHeightATL=1.64913"
"currentHeightATL=1.56102"
"currentHeightATL=1.46825"
"currentHeightATL=1.37091"
"currentHeightATL=1.26926"
"currentHeightATL=1.16457"
"_bullet destroyed"
"===================== END ====================="

Well, q1184, you're right. :) At least in this aspect. Ty for attention.

Also available in: Atom PDF