Bug #25463

[1.60 beta only] Warning Message: 'type/' is not a class ('type' accessed) - .: Value type not matching: != Array

Added by kju over 3 years ago. Updated over 3 years ago.

Status:Closed Start date:10/14/2011
Priority:Normal Due date:
Assignee:Suma % Done:

0%

Category:Error Message
Target version:1.60.87580
Affected ArmA II version:1.60 BETA First affected build:85434
Reproduced by another DH user:Yes First affected ArmA II version:1.60 BETA
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

On screen error for a 1.59 client when joining a 1.60 beta (dedicated) server.
I think it started with the latest, 85434 - at max 1-2 earlier. Also shown in rpt.

Warning Message: 'type/' is not a class ('type' accessed)
.: Value type not matching:  != Array

Happens for every mission.


Related issues

related to ARMA2 Community Issue Tracker - Bug #25461: [1.60 only] "CreatorId not supported client-side" shown i... Closed 10/14/2011

History

Updated by Suma over 3 years ago

  • Status changed from New to Resolved

Fixed in 85473 (new "type" format in saves reverted).

BTW: "Happens for every mission." really is not a good issue report. It does not happen for a mission which does not transfer values using publicVariable, therefore it does not happen for my very basic missions I use for testing by default. Good report should never use words "every", "any", "some", "most". Always select one particular example as a repro, and add "It happens in many missions" as a note only.

Updated by kju over 3 years ago

Agreed. To be fair I thought it would really happen for every. We tried 5 and all did. :)
In the future I will stick to naming the used mission.

Updated by kju over 3 years ago

  • Target version set to Upcoming version

Updated by kju over 3 years ago

  • Target version changed from Upcoming version to 1.60 BETA

Updated by Qazdar over 3 years ago

I'm using 85330 and it happens for me,i also add that this happens also for 1.60 beta users connecting to 1.59 DS.

Updated by kju over 3 years ago

Latest beta patch: ARMA2_OA_Build_85478.zip

http://www.arma2.com/beta-patch.php

Updated by kju over 3 years ago

  • Status changed from Resolved to Closed

Fixed here.

Updated by kju over 3 years ago

  • Target version changed from 1.60 BETA to 1.60.87580

Also available in: Atom PDF