Bug #25419

Using autopilot landing using SU34 causes damage to the plane

Added by Qazdar over 3 years ago. Updated about 3 years ago.

Status:Closed Start date:10/13/2011
Priority:Normal Due date:
Assignee:Suma % Done:

0%

Category:Vehicles
Target version:1.60.87580
Affected ArmA II version:1.60 BETA First affected build:Please Specify...
Reproduced by another DH user:Yes First affected ArmA II version:Please select...
I am using some Mods:No Single / Multi Player?:
I am using:CO (OA+A2) BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

Well to prove this,i made a small repro mission in which you have SU34 heavily damaged.

Repro
  1. Run the mission in the editor
  2. Use landing autopilot
  3. The plane will crash after hitting the dirt

Note: I tried with av8B (same settings) and landing was smooth

Exp
Landing autopilot is not supposed to cause damage to the plane

The only proof i can give is that i landed many times (not even in airfields) using heavily damaged SU34 and landing was successful.

Suggestion
Make landing gear stronger.

su34autopilotfailHullred.utes.7z (612 Bytes) kju, 10/13/2011 04:11

su34autopilotfailHullred2.utes.7z (706 Bytes) kju, 10/14/2011 04:40

My_personal_landing.avi (6 MB) Qazdar, 10/21/2011 19:26

Autolanding.avi (2.8 MB) Qazdar, 10/21/2011 19:26

History

Updated by Qazdar over 3 years ago

  • Description updated (diff)

Updated by kju over 3 years ago

  • File deleted (su34autopilotfailHullred.pbo)

Updated by kju over 3 years ago

  • File su34autopilotfailHullred.utes.7z added
  • Description updated (diff)
  • Due date set to 01/01/2012
  • Category set to Vehicles
  • Assignee set to Suma
  • Affected ArmA II version changed from Please select... to 1.60 BETA
  • Reproduced by another DH user changed from No to Yes
  • I am using set to CO (OA+A2)
  • Reproducible for you changed from No to Yes

Updated by Fireball over 3 years ago

  • Status changed from New to Assigned

Is this one caused by betas?

Updated by kju over 3 years ago

I'd guess not. Probably more of a model problem or non perfect auto landing routine.

Updated by Suma over 3 years ago

  • Status changed from Assigned to Rejected

I have tried it 3x in row and the landing was perfect each time, no crash, plane not destroyed.

Even if it was not, I would argue that performing emergency landing on autopilot is something one should not attempt.

Updated by Qazdar over 3 years ago

Please,retry using a plane with very minimum health.

Updated by Suma over 3 years ago

This is what I did, using the repro attached to this issue. Still, no luck (airplane always landed safely).

Updated by kju over 3 years ago

Suma did you use the release or developer version - the later may have some config tweaks (for planes), we do not have (yet)?
(I think to recall something was fixed and announced in another ticket)

Updated by Suma over 3 years ago

Kju, good idea. I am not aware of any Su34 tweaks, only data tweaks which you do not have should be for L-39. To be sure, I have tested Retail + beta patch now and the landing was flawless again.

Did you reproduce it?

Updated by Qazdar over 3 years ago

Really weird,i'm using steam version by the way,but i don't how it can have a relation with the game itself.

Updated by kju over 3 years ago

Its quite weird. 1.59 is fine for me. Tested various angles etc.
With latest beta it crashes 100%. Here is a video of it:
http://www.youtube.com/watch?v=FoXmjgshXss

What I noticed is that in 1.59 he always lands an the NW corner of the runway,
while with the beta it is always in the center and it looks like he is pulling up
(a little) just before the touch down - which probably causes the crash.


To rule out player influence, here is an automated version of the repro.

setAccTime 4;

planeOne action ["Land", planeOne];

One idea I had that may influence it too: the users viewdistance setting?

Here is the rpt of both sessions: http://pastebin.jonasscholz.de/1602

This has no influence, does it?

Warning: Road selection asf3 has wrong name format
Warning: Road selection mud has wrong name format

Updated by Suma over 3 years ago

  • Status changed from Feedback to Assigned

There was only one way how I managed it to crash, and that was by modifying the repro mission to contain an player as observer external to a plane, just watching the AI to land, not with the autopilot used on a players plane. As I agree AI and player should have equal conditions, this is something I might check later.

However, to ease my mind: Are you guys really really sure you were able to reproduce the problem with the exact repro attached here?

Updated by Qazdar over 3 years ago

I'm ready to record a video if you are interested showing SU34 failing to land even with a yellow hull state ...

I don't use auto landing script but i manage man y times to land this plane on natural runways ... what i think of the auto landing is that it is too hard : the plane just hits the dirt ...

Updated by Qazdar over 3 years ago

Updated by kju over 3 years ago

Suma it seems difficulty settings/overall AI skill related.

With recruit, regular it never happens.
With veteran and expert it always happens.

Using the automated demo mission.

Viewdistance, terraingrid have no effect here.

Repro
  1. New profile
  2. Set difficulty to veteran/expert
  3. Editor
  4. Load su34autopilotfailHullred2.utes
  5. Notice how AI crashes on landing
  6. Change to recruit, regular and AI is able to land safely.

Updated by Suma over 3 years ago

Great. I was able to repro it now, and to fix it. Plane will start the flare a bit sooner, resulting in a smoother landing (85998)

Updated by kju over 3 years ago

  • Due date deleted (01/01/2012)
  • Target version set to Upcoming version

Updated by kju over 3 years ago

  • Target version changed from Upcoming version to 1.60 BETA

Updated by admin over 3 years ago

  • Status changed from Assigned to Resolved

Updated by kju over 3 years ago

  • Status changed from Resolved to Closed

works. tx

Updated by kju about 3 years ago

  • Target version changed from 1.60 BETA to 1.60.87580

Also available in: Atom PDF