Bug #25336

Anyone can confirm working ACE Ruck/WoBack feature?

Added by fREAk over 3 years ago. Updated about 3 years ago.

Status:Closed Start date:10/10/2011
Priority:Normal Due date:
Assignee:Tupolov % Done:

0%

Category:ACE
Target version:-
Component:NOMAD Reproduced by another DH user:No
Close Reason: I am using some Mods:No
Affected Version:

Description

Since playing and editing MSO (3.42) i never got the ACE Ruck / WeaponOnBack features working.
I've got the Ruck on back, but no contents in it.
I always did a Workaround with the "ACE Respawn with same Weapon" Module, placed into the Template.
Well, this obviously does'nt work for the reconnects, so i startet to investigate the Code,
but can't find any odds. So far i'm wondering about beeing the only one who got that problem.

thanks in advance,

fREAk

History

Updated by fREAk over 3 years ago

correction 3.42 -> 3.44

Updated by friznit about 3 years ago

To fix (work around) the the ACE backpack and items on reconnect (Nomad module), you need to do the following:

in core\modules\nomad\main.sqf at line 123 underneath the line #include <mods\aaw_s.hpp>

add the following:

#include <mods\ace_sys_ruck_s.hpp>
#include <mods\ace_sys_wounds_s.hpp>
#include <mods\ace_rangefinder_s.hpp>
#include <mods\ace_earplugs_s.hpp>
#include <mods\ace_glasses_s.hpp>

Make sure they're not included in the array [if (isClass(configFile>>"CfgPatches">>"ace_main")) then {}, cos that doesn't seem to work (either it's not properly detecting ACE or the syntax is wrong. I'm not sure which but I've never figured out how to make it work properly).

For ACE backpack/items on Respawn after death, just use the ACE editor module (ACE_Respawn_with_weapons), because for similar reasons the MSO script version never worked properly.

Downside is it means the scripts aren't ACE independent and we'd end up with two different version on GIT, which is why it's not a priority for the dev team. But it's a simple enough work around to do yourself for future releases.

Updated by friznit about 3 years ago

I should add, clearly you need to check that those .hpp files which Robalo provided do actually exist in core\modules\nomad\mods. They should be if you're using MSO 3.45 or later.

Updated by Tupolov about 3 years ago

  • Status changed from New to Feedback
  • Assignee changed from Rommel to friznit

Updated by Tupolov about 3 years ago

Issue 1: ACE Backpack and Respawn
1. Load up with ACE backpack and fill it.
2. Respawn, ACE backpack contents are missing.

Issue 2: ACE Backpack and Reconnect
1. Add ACE Backpack and fill it
2. Disconnect and reconnect, backpack contents are missing. (note lots of errors in RPT weapon_on_back error)

Issue 3: ACE medical supplies and Reconnect
1. Add medical supplies
2. Disconnect and Reconnect - medical slots disappear and medical supplies are placed in items.
3. A respawn will fix the medical slot issue.

Updated by Tupolov about 3 years ago

  • Status changed from Feedback to Closed
  • Assignee changed from friznit to Tupolov

Fixed in latest Nomad revision.

Also available in: Atom PDF