Bug #25302

multiplication medkits

Added by Myau almost 4 years ago. Updated almost 4 years ago.

Status:Closed Start date:10/09/2011
Priority:Normal Due date:
Assignee:Sickboy % Done:

100%

Category:-
Target version:1.13
Component:sys_wounds Affected Version:
Close Reason:

Description

If in multiplayer game with other player and save mission, then after loading in client-player multiplicate medkits...

Use 3 modules in mission:
1) Wounded system
2) Full heal in war
3) All can use medkits

AliceBug.Desert_E.pbo (4.1 kB) Myau, 10/09/2011 15:37

_ACE_Wounds_Test.Desert_E.7z (1.1 kB) Sickboy, 10/26/2011 19:20

ace_sys_wounds-_25302-fixed5.7z (5.1 MB) Sickboy, 10/27/2011 09:34


Related issues

related to A.C.E. for OA - Task #25804: Actual ruck gear lost on player disconnect/reconnect to s... Rejected 10/23/2011

Associated revisions

Revision 825f0cb3
Added by Sickboy almost 4 years ago

~ FIXED: Multiplication of MedicalGear upon disconnect/reconnect same unit. fixes #25302

Revision 45b51901
Added by Sickboy almost 4 years ago

FIXED: Locality checks for addMedicalGear. fixes #25302

History

Updated by Myau almost 4 years ago

If use bag, then in bag (in client-player) create 10 medkits, 10 adrenaline etc on 10 medicaments....

Updated by Myau almost 4 years ago

http://www.youtube.com/watch?v=IqxIFaW5QbQ

Big screen - Client
Small screen - server

Updated by rocko almost 4 years ago

  • Target version set to 1.13

Updated by Sickboy almost 4 years ago

  • Status changed from New to Assigned
  • Assignee set to Sickboy
  • Component set to sys_wounds

Updated by rocko almost 4 years ago

  • Tracker changed from Bug to Support

Updated by rocko almost 4 years ago

  • Target version deleted (1.13)

Updated by Sickboy almost 4 years ago

This should occur because the client-player initializes as if they are JIP / starting the mission.
My idea would be to put a flag on the unit object after the items have been added,
and checking for this flag upon initialize.

For respawn, the respawn eventhandler should be sufficient (probably already used).

I reckon this issue will be the same for e.g Rucks-from-Config (new feature), and perhaps others.

Updated by Sickboy almost 4 years ago

  • Status changed from Assigned to In progress
  • % Done changed from 0 to 20

Updated by Sickboy almost 4 years ago

  • Status changed from In progress to Resolved
  • % Done changed from 20 to 100

Updated by Sickboy almost 4 years ago

  • File ace_sys_wounds-_25302-fixed.7z added

Attached fix; needs to be available on each connected machine incl server,
and the mission should be fully restarted once (no load/resume).

Updated by Sickboy almost 4 years ago

  • File deleted (ace_sys_wounds-_25302-fixed.7z)

Updated by Sickboy almost 4 years ago

  • File ace_sys_wounds-_25302-fixed2.7z added

Updated by Sickboy almost 4 years ago

  • Tracker changed from Support to Bug
  • Target version set to 1.13

Updated by Sickboy almost 4 years ago

Please confirm.

Updated by Myau almost 4 years ago

If ace_sys_wounds-_25849-fixed2.7z have fix for this bug, then fix not work.
Result test how in # 2 message

Updated by Sickboy almost 4 years ago

:O thanks, yes should include the fix :o

All clients + server have the fix??

Updated by Myau almost 4 years ago

Sickboy wrote:

:O thanks, yes should include the fix :o

All clients + server have the fix??

Yes

Updated by Sickboy almost 4 years ago

  • File deleted (ace_sys_wounds-_25302-fixed2.7z)

Updated by Sickboy almost 4 years ago

  • File ace_sys_wounds-_25302-fixed3.7z added

Here you go :)

Updated by Myau almost 4 years ago

No different

Updated by Sickboy almost 4 years ago

Myau wrote:

No different

:O Testing with latest beta or 1.59 vanilla? (no rpts)
(the beta should have highest chance of being fixed.. will run tests anyway)

Mission fully restarted, no load?

Updated by Myau almost 4 years ago

Sickboy wrote:

Myau wrote:

No different

:O Testing with latest beta or 1.59 vanilla? (no rpts)

Edit// Different have.. After load i have in GP/Pistol slots 2 medkits (On before fix i did have 4)
But in Ruck i have many many medicaments

Last beta build

Updated by Sickboy almost 4 years ago

Roger, gotcha, are you speaking about the host-player or client-player?

Updated by Myau almost 4 years ago

Sickboy wrote:

Roger, gotcha, are you speaking about the host-player or client-player?

Host-client and client-client is equal
I did setup arma&ace for other computer

equal build
equal versions
equal Arma2
equal Ace
equal fix files

Updated by Myau almost 4 years ago

Medicaments for some reason, appear in a backpack client

Updated by Sickboy almost 4 years ago

Copy - but the question rather is - do you experience exactly the same issues on host-player AND client-player, or are there any differences between the two :)

Myau wrote:

Medicaments for some reason, appear in a backpack client

Sorry, what do you mean? Tnx!

Updated by Myau almost 4 years ago

Sickboy wrote:

Copy - but the question rather is - do you experience exactly the same issues on host-player AND client-player, or are there any differences between the two :)

We try:
I did server, my sister did client
My sister did server, i did client
No different

Myau wrote:

Medicaments for some reason, appear in a backpack client

Sorry, what do you mean? Tnx!

U can see on video - in ruck summon 10 epinephrine, 10 morphine, 10 bondage, 10 dunno what, 4 medkits. And 2 medkits in GP/pistol slot

After last fix, 2 medkits no summon in pistol/GP slot. But in Ruck no different (10 10 10 10 4)...

Updated by Myau almost 4 years ago

Medicaments summon only in client-player. Server-player not have summon-medicaments.

Updated by Myau almost 4 years ago

For understanding.

Serverplayer 2 medkits, 2 ep, 2 mor, 2 bond, empty ruck
Clientplayer 2 medkits, 2 ep, 2 mor, 2 bond, empty ruck

Save&Load

Serverplayer 2 medkits, 2 ep, 2 mor, 2 bond, empty ruck
Clientplayer 4(after last fix 2) medkits, 2 ep, 2 mor, 2 bond, ruck with 10 ep, 10 mor, 10 bond, 10 less bond, 4 medkits

//i try say right, but i not sleep above 24 hours - brain not work...

Updated by Sickboy almost 4 years ago

  • File ace_sys_wounds-_25302-fixed4.7z added

Thanks - the explanation helped a lot :)

Hopefully following fix works, includes 2 CBA addons. Fully restart mission first.

Updated by Myau almost 4 years ago

No different :(/

Updated by Sickboy almost 4 years ago

strange - checking in some minutes, diner first :)

Updated by Myau almost 4 years ago

Sickboy wrote:

strange - checking in some minutes, diner first :)

Oh... i did want fastered ending this, because very want sleep...
Sorry, i can't continium check... me need sleep... *gotosleep

Updated by Sickboy almost 4 years ago

Thanks and np - nn :)

For starters the bug that you do not have any Ruck magazines on start, I cannot reproduce.
I am playing with a US Army Medic, backpack n all.

Attached my test mission, will check yours too.

Updated by Sickboy almost 4 years ago

The units in your test mission do not have a Rucksack, hence they do not have any ruck content :)
But that means it's rather strange that after SQSL, the second player suddenly has ruck content :D

Clientplayer 4(after last fix 2) medkits, 2 ep, 2 mor, 2 bond, ruck with 10 ep, 10 mor, 10 bond, 10 less bond, 4 medkits

Try my test mission :O

Updated by Myau almost 4 years ago

Sickboy wrote:

But that means it's rather strange that after SQSL, the second player suddenly has ruck content :D

Why SQSL? For repro not need quit from game. Need only save and load.

Try my test mission :O

Ok, today i will check...

Updated by Myau almost 4 years ago

Sickboy wrote:

Try my test mission :O

O-o-oh...

We did start your mission:

Server-player have: 2 medkits, 2 ep, 2 mor, 2 bond, ruck with 10 ep, 10 mor, 10 bond, 10 less bond, 4 medkits

Client-player have: 2 medkits, 2 ep, 2 mor, 2 bond, ruck with 10 ep, 10 mor, 10 bond, 10 less bond, 4 medkits

Save&Load

Server-player have: 2 medkits, 2 ep, 2 mor, 2 bond, ruck with 10 ep, 10 mor, 10 bond, 10 less bond, 4 medkits

Client-player have: 2 medkits, 2 ep, 2 mor, 2 bond, ruck with 10 ep, 10 mor, 10 bond, 10 less bond, 4 medkits

We drop all items from rucks on ground and Save&Load

Server-player have: 2 medkits, 2 ep, 2 mor, 2 bond, empty ruck

Client-player have: 2 medkits, 2 ep, 2 mor, 2 bond, ruck with 10 ep, 10 mor, 10 bond, 10 less bond, 4 medkits

We repeate this test 3 times and in 1th times server-player did not have 2 medkits in GP/Pistol slots, after start mission. After Save&load medkits in GP slots did not summon.

Re the medkits, you were right, I was confusing the IFAKK bandages for medkits (headbang), for this I have attached fix :D

This fix not work /);

Updated by Sickboy almost 4 years ago

  • % Done changed from 80 to 90

Thanks a lot :)

So seems working well for the most part.

The issue with client-player ruck restoring after save/load or disconnect/reconnect is a limitation of the Ruck System; #25804

So only real bug left is that the server-player did not always get the 2 medkits in pistol slots?

After Save&load medkits in GP slots did not summon.

Means that even after Save+Load, the server-player did not get his 2 medkits in Pistol slots?

This fix not work /);

The fix works fine, you dont'get multiplication of the medkits anymore in Pistol slots after Save/Load. So fix fine.

Updated by Myau almost 4 years ago

So only real bug left is that the server-player did not always get the 2 medkits?

Yes. In 1th start mission, game not give me 2 medkits. I am server-player...
After mission restart, give....

Means that even after Save+Load, the server-player did not get his 2 medkits in Pistol slots?

Yes. Only after restart mission...

Updated by Myau almost 4 years ago

For understanding:

1th test:

We did start your mission:

Server-player have: *0* medkits, 2 ep, 2 mor, 2 bond, ruck with 10 ep, 10 mor, 10 bond, 10 less bond, 4 medkits

Client-player have: 2 medkits, 2 ep, 2 mor, 2 bond, ruck with 10 ep, 10 mor, 10 bond, 10 less bond, 4 medkits

Save&Load

Server-player have: 0 medkits, 2 ep, 2 mor, 2 bond, ruck with 10 ep, 10 mor, 10 bond, 10 less bond, 4 medkits

Client-player have: 2 medkits, 2 ep, 2 mor, 2 bond, ruck with 10 ep, 10 mor, 10 bond, 10 less bond, 4 medkits

We drop all items from rucks on ground and Save&Load

Server-player have: 0 medkits, 2 ep, 2 mor, 2 bond, empty ruck

Client-player have: 2 medkits, 2 ep, 2 mor, 2 bond, ruck with 10 ep, 10 mor, 10 bond, 10 less bond, 4 medkits

Restart mission.
2th and 3th test:
We did start your mission:

Server-player have: 2 medkits, 2 ep, 2 mor, 2 bond, ruck with 10 ep, 10 mor, 10 bond, 10 less bond, 4 medkits

Client-player have: 2 medkits, 2 ep, 2 mor, 2 bond, ruck with 10 ep, 10 mor, 10 bond, 10 less bond, 4 medkits

Save&Load

Server-player have: 2 medkits, 2 ep, 2 mor, 2 bond, ruck with 10 ep, 10 mor, 10 bond, 10 less bond, 4 medkits

Client-player have: 2 medkits, 2 ep, 2 mor, 2 bond, ruck with 10 ep, 10 mor, 10 bond, 10 less bond, 4 medkits

We drop all items from rucks on ground and Save&Load

Server-player have: 2 medkits, 2 ep, 2 mor, 2 bond, empty ruck

Client-player have: 2 medkits, 2 ep, 2 mor, 2 bond, ruck with 10 ep, 10 mor, 10 bond, 10 less bond, 4 medkits

Updated by Sickboy almost 4 years ago

Copy. Only open issue is Server-Player not having 2 medkits in pistol slots in your first test.
Hopefully I will be able to reproduce it.

The ruck issue for client-player is a limitation of the Ruck system #25804

Updated by Myau almost 4 years ago

Hopefully I will be able to reproduce it.

Oh... i dunno how repro this... Show like random...
But i try several times start game and mission and try find regularity...

Updated by Myau almost 4 years ago

New info. This bug work not only on server-player.

On 4th test Pistol-slots-medkits loss client player. Continiued test.
12th test - Server-player loss medkits
20th test - Client-player loss medkits
22th test - Server-player loss medkits
31th test - Client-player loss medkits
37th test - Client-player loss medkits

Updated by Myau almost 4 years ago

Test over.
Hope, this help for u...

Updated by Sickboy almost 4 years ago

Thanks! No errors in RPT ?

What is rather strange is that the same script is used to add the PistolSlot Medkits AND the RuckSack items :O

I can add sys_wounds package with DEBUG enabled - so if you can reproduce the issue again, and then send me the rpt file, we should have some better view on whats up.

Updated by Myau almost 4 years ago

Errors in RTP not have server and client.
Ok, give please debug file

Updated by Sickboy almost 4 years ago

  • Status changed from Feedback to Resolved
  • % Done changed from 90 to 100

Updated by Sickboy almost 4 years ago

  • File deleted (ace_sys_wounds-_25302-fixed3.7z)

Updated by Sickboy almost 4 years ago

  • File deleted (ace_sys_wounds-_25302-fixed4.7z)

Updated by Sickboy almost 4 years ago

Thanks! And ehrm, I think I found the issue :) I didn't enable debug, as the issue should be fixed for real :)

The issue probably only occured with more than 1 player, and gets even bigger depending on the amount of players :P

Updated by Myau almost 4 years ago

Ok, we now will repeat test.

Updated by Myau almost 4 years ago

Ready.
For 30 tests, 0 medkits loss in client and server.
Nice :/)

Updated by Sickboy almost 4 years ago

Woo :) Thanks again for testing and feedback Myau and Siss!

Updated by Sickboy almost 4 years ago

Myau wrote:

np... help please with this ticket... http://dev-heaven.net/issues/25825
Just... if i have all files, AGS (and maybe all 2-parts-weapon) broke... is serious...
If i have fix, then i create new ticket. Need your confirm...

No need for new ticket. Just wait patiently on Rocko response.
Please keep comments about other tickets, in those tickets themselves. Not in different tickets like this one :)

Updated by Myau almost 4 years ago

I dunno this after fix or not, but...
If i push on numbers under epinephrine, morphine and bondages in inventary, i loss it...

Updated by Sickboy almost 4 years ago

Myau wrote:

I dunno this after fix or not, but...
If i push on numbers under epinephrine, morphine and bondages in inventary, i loss it...

Probably that's how you drop them.. anyway - this ticket is about medkit multiplication :-p

Updated by Sickboy almost 4 years ago

  • Status changed from Resolved to Closed

Available in the about to be released ACE for OA 1.13 RC1

Also available in: Atom PDF