Bug #25266

AI makes excessive use of binoculars since 1.60 beta

Added by kju over 3 years ago. Updated over 2 years ago.

Status:Closed Start date:10/08/2011
Priority:Normal Due date:
Assignee:Suma % Done:

80%

Category:AI Issues
Target version:1.60.87580
Affected ArmA II version:1.60 BETA First affected build:84467
Reproduced by another DH user:Yes First affected ArmA II version:1.60 BETA
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

Repro 1+2
  1. Launch attached mission in the editor
  2. Notice how the west special forces make use of the binoculars
  3. In 1.59 they don't

Obs
???

Exp
???

Repro 3 (M107UsesBinocular.desert_e.7z):

Obs
A M107 sniper spots a target at 500m (reveal is used).
He gets out the binocular (vector) first to look at it (confirm enemy?).
Only then he switches to the M107 to engage.

Exp
Realism wise this might be OK - no idea.
As player with strong optics I would only use a binocular to scan the horizon.
But if the enemy/target is already spotted, I would always use the weapon itself to confirm it.

Repro
  1. Editor
  2. Start
  3. Watch M107 behavior

Note
Did not test with 1.59 but fairly certain in 1.59 he would not get out the binocular.

AI_20test.Takistan.7z (1.1 kB) kju, 10/08/2011 05:55

AIExcessiveBinocUse.Desert_E.7z (1.4 kB) kju, 10/08/2011 05:55

M107UsesBinocular.desert_e.7z (957 Bytes) kju, 10/13/2011 13:16

1.59.85248_AI_uses_binoculars_like_birdwatchers_and_not_like_soldiers.jpg - Sykes, Rodriquez and O'Hara using binoculars simultaneously (275.3 kB) Hanzu, 10/13/2011 18:29

arma2oa_2011-10-21_15-06-50-65.avi (7.1 MB) Danil-ch, 10/21/2011 08:09

binoc.Chernarus.pbo (9.9 kB) Danil-ch, 10/21/2011 08:46

binoc.Desert_E.zip - simplified binoc repro (1.2 kB) Suma, 10/21/2011 09:38

ai-binoc-simple.Desert_E.7z (1004 Bytes) Suma, 10/21/2011 12:32

AIBinocnew.Desert_E.pbo (7.2 kB) Danil-ch, 11/02/2011 12:54

arma2oa_2011-11-02_19-54-28-48.jpg (277.2 kB) Danil-ch, 11/02/2011 12:54


Related issues

related to ARMA2 Community Issue Tracker - Bug #12143: KSK specops/CZech Special forces units using pistols at l... Closed 07/19/2010
related to ARMA2 Community Issue Tracker - Bug #26273: AI makes excessive use of binoculars during the night Rejected 11/09/2011
related to ARMA2 Community Issue Tracker - Bug #33133: AI makes excessive use of binoculars while moving (almost... Assigned 06/17/2012

History

Updated by kju over 3 years ago

AI_20test.Takistan.7z is the demo mission from Tonci87:

Follow these steps:
  • Proceed on the road
  • Half your squad will take out its Binos once they notice the enemy.
  • There is a good chance that some of them won´t join the fight but will remain with their Binos on their Eyes.

Tonci87 said:

There is a small wall along the road. Order your men individually to positions on that wall.
Notice how awfully long they take if they are under fire.
You will propably notice that your AI likes to stand up A LOT during the firefight.

His video: http://www.youtube.com/watch?v=4B4JnCnTBhA

Updated by kju over 3 years ago

A few points by me:
  • Yes in 1.59 the AI does not use the binocular in this situation, but it seems to make perfectly sense to identify the unknown targets (quicker).
  • I cannot see them use the binoculars later on again.
  • The CZ spec ops have the pistol bugs. See #12143.
  • I don't see how the comments by Tonci87 in addition are related to this. Sure there are other AI issues and we have tickets for those.

So bottom line for me so far is in 1.59 AI used binoculars less/not in this situation.
Missions that really show faulty/excessive binocular uses would be needed.

Updated by kju over 3 years ago

  • First affected build changed from Please Specify... to 84467

fabrizio_T said:

Personally i started noticing this massive binoculars use since patch build 84467. Not really new.

Updated by Fireball over 3 years ago

  • Status changed from Feedback to Resolved

Marking resolved according to http://forums.bistudio.com/showpost.php?p=2036846&postcount=31.

I've seen the following post too, which states that there is still occasional "funny" use of binocs by the TLs, but this is not something introduced by betas. This was always somewhat the case, nothing serious.

Updated by kju over 3 years ago

  • Due date deleted (11/01/2011)
  • Target version set to 1.60 BETA

Updated by Fireball over 3 years ago

  • Status changed from Resolved to Feedback
  • Target version deleted (1.60 BETA)
  • Reproduced by another DH user changed from No to Yes
  • Reproducible for you changed from No to Yes

Updated by Fireball over 3 years ago

  • Due date set to 10/22/2011

Updated by kju over 3 years ago

Here is one demo mission.

Obs
A M107 sniper spots a target at 500m (reveal is used).
He gets out the binocular (vector) first to look at it (confirm enemy?).
Only then he switches to the M107 to engage.

Exp
Realism wise this might be OK - no idea.
As player with strong optics I would only use a binocular to scan the horizon.
But if the enemy/target is already spotted, I would always use the weapon itself to confirm it.

Repro
  1. Editor
  2. Start
  3. Watch M107 behavior

Note
Did not test with 1.59 but fairly certain in 1.59 he would not get out the binocular.

Updated by Fireball over 3 years ago

  • Status changed from Feedback to Assigned
  • Assignee set to Suma

Updated by Fireball over 3 years ago

  • Description updated (diff)

Updated by Fireball over 3 years ago

  • Description updated (diff)

Updated by Hanzu over 3 years ago

Playing Manhattan mission (for repro purposes) with 85248 and Razor Team is using binoculars like some group of birdwatchers who see a rare bird and not like soldiers. Every time they disembark vehicle they all take binoculars almost simultaneosly. When you order them back to Get In vehicle they again want to use binoculars then take some steps and then take binoculars again before finally getting in.

3 men looking binoculars simultaneosly is rising the whole team since none of them is covering. Also going anywhere on foot with these fools is really annoying since they take out binoculars and stop every 20 meters or so. This is worst thing I have ever seen happened to AI. You have to completely drop those binoculars from each Razor Team member to be able to play normally. See my attached screenshot.

Updated by Sickboy over 3 years ago

Not much details, but another user complaining about excessive bino usage; http://forums.bistudio.com/showthread.php?p=2041278#post2041278

Updated by Hanzu over 3 years ago

That poster is not mentioning what build he is using.

I played about 30 minutes with latest 85598 yesterday and I didn't see Razor Team to take out their binoculars even once when earlier they would have all taken out their binos about 10 times in 30 minutes.

So maybe this issue has been quietly fixed. I will report here if I see it even once.

Someone who can play right now (not me) should try attached demomission.

Updated by Robalo over 3 years ago

This should be fixed according to changelog (haven't tested it to be able to confirm yet):

[85280] Improved: AI smarter in using binoculars.

Updated by Danil-ch over 3 years ago

Not fixed.

Updated by Hanzu over 3 years ago

Robalo wrote:

This should be fixed according to changelog (haven't tested it to be able to confirm yet):

[85280] Improved: AI smarter in using binoculars.

So you failed to read above replys. Definately not fixed in 85280 since excessive binocular using made AI more stupid than ever with later build 85598.

Improved is not same as fixed. Why would changelog even say fixed instead of improved when nothing was broken before this changelog comment appeared, in this case I see not improved but increased use of AI binocular activity.

If nothing else proves how crazy this issue is, making all previous AI tweaking to go down the drain, I have to add savegame which anyone can load to bring up situation where your whole team is using binoculars simultaneosly like bunch of birdwatchers lacking completely any self protection and awareness of enemy precence.

Just try demomissions attached here to see how things are with latest build.

Updated by Danil-ch over 3 years ago

Here repro mission just run and watch.

Updated by Sickboy over 3 years ago

Video notes saved to wiki: http://dev-heaven.net/projects/cis/wiki/CIT#Videos

These are the closest I could find to a repro mission + steps: http://dev-heaven.net/issues/25266#note-1

Hanzu could you do something like that for your repro too? I guess a savegame might be useful, but not the only way.

I hope this one will help (although not very clear / elaborate, the steps seem simple):
Danil-ch wrote:

Here repro mission just run and watch.

Updated by Suma over 3 years ago

Danil-ch wrote:

Here repro mission just run and watch.

Great. I have simplified the mission a bit (attached). What I found interesting is the problem did not show when I tried to reduce the size of the BLUFOR group.

Updated by Hanzu over 3 years ago

Unfortunately I need to wait some more hours before I'm in a situation where I can test, but to me it looks we might be on wrong track here.

http://dev-heaven.net/attachments/14694/1.59.85248_AI_uses_binoculars_like_birdwatchers_and_not_like_soldiers.jpg

For me all 3 members of Razor Team used binocular repeatedly and often simultaneously.
  1. One of them (Sykes) had a sniper so using binoculars was not justified.
  2. Razor Team is small group with only 4 members so why are they doing it so excessively if group size would matter.

Could this be related to modes like Safe, Aware, Danger and so on? I used the default one and did not change it manually at all.

Updated by Suma over 3 years ago

Sickboy wrote:

My take would be that if there is a man in the group who has a scope, the issue doesn't occur, while if there is no scoped units, they all turn to their binocs :)

In the given repro all man have the same gear (all are team leaders). I think speculating about possible causes has a little value. If you see another situation which you think requires a different repro, feel free to post it.

Updated by Suma over 3 years ago

Here is one more repro, this time with a small group only. Note that your subordinate frequently looks behind.

Updated by Suma over 3 years ago

  • Status changed from Assigned to Resolved

Issues shown in all repros attached so far should be fixed in 85678. Fix is:
- subordinates void using binocs a lot
- leaders somewhat avoid using binocs when in a combat
- binocs are never used again on a target which was watched through binocs recently
- a few minor tweaks in exact conditions when and how long binocs should be used

Updated by kju over 3 years ago

  • Status changed from Resolved to Feedback
  • % Done changed from 0 to 80

binoc.Desert_E and binoc.chernarus work nicely now. Well done.
Just the leader takes out the binoc and makes meaningful use.

However in AIExcessiveBinocUse.Desert_E it is still very weird.
From the West group almost all units take out the binoc to check the enemy group.

Did you try that repro Suma?

In the ai-binoc-simple.Desert_E I don't get the repro steps (as it requires player interaction
being the group leader, right?).

Updated by kraze over 3 years ago

The issue is still there. Playing http://www.armaholic.com/page.php?id=15486 almost all units get their binos out after I've grabbed a recorder from the chopper - as a result they keep falling back, looking through binos.
Maybe will try to "butcher" the mission later and make a repro from that position

Updated by kju over 3 years ago

How about some proper repro steps kraze?

Updated by Suma over 3 years ago

  • Status changed from Feedback to Resolved

However in AIExcessiveBinocUse.Desert_E it is still very weird.
From the West group almost all units take out the binoc to check the enemy group.

I have tried it again now, and I do not see any excessive binoc usage there. Most often I can see a leader using binocs, often also one other member, however the binoc use is brief and does not look strange to me.

Note: the chat messages detecting binoc use seem to be a bit unreliable. It seems to me they quite often reporting binoc use even when the unit is in fact not using it (e.g. it is running at the moment).

I am marking as resolved unless there is some clear and well documented repro proving otherwise.

Updated by Danil-ch over 3 years ago

I edited AIExcessiveBinocUse.Desert_E to make it more noticeable.
just start and look at your teammates.
Mission is the same as before I just changed the squad.
I use 85889.

Updated by Sickboy over 3 years ago

Suma wrote:

Note: the chat messages detecting binoc use seem to be a bit unreliable. It seems to me they quite often reporting binoc use even when the unit is in fact not using it (e.g. it is running at the moment).

Strange - this could indicate issues with currentWeapon function, or that the AI somehow still has the Binoc selected while moving :O.
Perhaps related to the setAccTime?

 1 setViewDistance 2000;
 2 player allowDamage false;
 3 setAccTime 4;
 4 
 5 sleep 1;
 6 
 7 while {true} do
 8 {
 9     {
10         _weaponClass = currentWeapon _x;
11         if (_weaponClass in ["Binocular","Binocular_Vector"]) then
12         {
13             player sideChat format ["%1 uses Binocular",_x];
14         };
15     } forEach allUnits;
16 
17     sleep 1;
18 };

Updated by Suma over 3 years ago

  • Status changed from Resolved to Assigned

Great repro.

Updated by Suma over 3 years ago

  • Status changed from Assigned to Resolved

86022 introduces a concept of "designated spotter". In each formation at most one unit with binoculars (the one highest ranked, or a group leader, if possible) is considered a "spotter", and if someone is not a "spotter", he will use binocs only to watch targets which he personally discovered, never to watch targets reported by others. (Spotter still can use binocs on all targets).

This should hopefully fix the remaining issues.

Updated by kju over 3 years ago

  • Due date deleted (10/22/2011)
  • Target version set to Upcoming version

Sounds good - thanks!

Updated by mr.g-c over 3 years ago

Suma wrote:

86022 introduces a concept of "designated spotter".

Very nice Suma! This is the road you should go with AI issues ;-)

Updated by kju over 3 years ago

  • Target version changed from Upcoming version to 1.60 BETA

Updated by kju over 3 years ago

  • Status changed from Resolved to Closed

works nicely. good job

PS: it is strange that the leader remains standing while the other AI lays down/takes cover.
in case someone wants to make a repro out of it.

For example in:
  • AIBinocnew.Desert_E
  • AIExcessiveBinocUse.Desert_E

Updated by Sickboy over 3 years ago

Possible regression mentioned; http://forums.bistudio.com/showthread.php?p=2076352#post2076352
No details yet.

Updated by kju over 3 years ago

  • Target version changed from 1.60 BETA to 1.60.87580

Also available in: Atom PDF