Bug #25257

Need fix and add safe radius for MHQ deploy

Added by Kol9yN almost 4 years ago. Updated over 3 years ago.

Status:Closed Start date:10/07/2011
Priority:Trivial Due date:
Assignee:Kol9yN % Done:

100%

Category:BLUFOR Vehicles
Target version:1.50
Affected Version: GPU VRAM size:
Operating system: I am using some Mods:
Graphics card: Reproducible for you:
Difficulty: Related to content of DLC:
CPU: Affected ArmA3 version:
System RAM size: Single / Multi Player?:

Description

Need add a check "if cars and heli continue stay in base radius(not been moved and empty and not have damage) rotate cars with base to if MHQ redeplyed near previous base postion (radius 30meters)!" Not rest, only rotate and place to default positions.


Related issues

related to Insurgency - Bug #24073: Jams vehicles in the objects Closed 09/02/2011
related to Insurgency - Task #24122: Physical barricades around base Resolved 09/04/2011
related to Insurgency - Task #24126: Vehicles respawn delay Closed 09/04/2011

History

Updated by Kol9yN almost 4 years ago

  • Target version changed from 0.81a to 0.82

Updated by Kol9yN almost 4 years ago

Second solution - OR! If MHQ redeployed nearby H,servpoint,medic in radius 10-20m, dont reset H, servpoint and medic position. This i think is very good solution - no magical vehicles rotations, resets, respawns. Rotate only mhq!

Updated by Dominges almost 4 years ago

Let me rephrase that google translate BS.

Then you deploy MHQ, helicopter (if remote controlling enabled) will try to take-off and land at MHQ, even if MHQ deployed 100 km away from original base. And if MHQ deployed near buildings/vehicles, helicopter will try to land inside a building/etc. Also, if helicopter destroyed, it will respawn at MHQ, not base. And it will explode, if MHQ helipad is inside a building/under other vehicles.

Updated by Kol9yN almost 4 years ago

Thrid solution to mhq deploy:
- Integrate simple COIN sys, this allow see when you place base (all objects cars, H, servp is one segment) objects in fixed radius of current MHQ place!

Updated by Kol9yN almost 4 years ago

And about vehicles damage inside HQ deploy radius

Updated by Kol9yN almost 4 years ago

Dominges wrote:

Let me rephrase that google translate BS.

Then you deploy MHQ, helicopter (if remote controlling enabled) will try to take-off and land at MHQ, even if MHQ deployed 100 km away from original base. And if MHQ deployed near buildings/vehicles, helicopter will try to land inside a building/etc. Also, if helicopter destroyed, it will respawn at MHQ, not base. And it will explode, if MHQ helipad is inside a building/under other vehicles.

Yes! And !!!Boom!!! while never stoped! :) Because heli respawn on cars!

Updated by Kol9yN almost 4 years ago

  • Subject changed from Need fix radius of base & vehicle check damage in radius to Need fix and add save radius for MHQ deploy & vehicle check damage in radius
  • Description updated (diff)

Updated by Kol9yN almost 4 years ago

  • Description updated (diff)
  • Status changed from New to Assigned

Updated by Kol9yN almost 4 years ago

Or check if mhq deployed in radius of previous base location, dont reset main camp positions (!!!how it realised with vehilces!!!)

Updated by Kol9yN almost 4 years ago

  • Status changed from Assigned to In progress

Updated by Fireball almost 4 years ago

  • Subject changed from Need fix and add save radius for MHQ deploy & vehicle check damage in radius to Need fix and add save radius for MHQ deploy
  • Description updated (diff)

Updated by Fireball almost 4 years ago

  • Subject changed from Need fix and add save radius for MHQ deploy to Need fix and add safe radius for MHQ deploy

Updated by Fireball almost 4 years ago

  • Status changed from In progress to Resolved
  • % Done changed from 0 to 100

Applied in changeset commit:3db654c0d16f3b8d8540f23ea4eb9c635e1f1c9c.

Updated by Fireball almost 4 years ago

Please test the fix and tell me if it's satisfactory.

It's for every "bug" in every mission or game; whenever you make something idiot proof, you will find a bigger idiot who breaks it anyway, somehow.

Updated by Kol9yN almost 4 years ago

  • Status changed from Resolved to In progress
  • Assignee changed from Fireball to Kol9yN

Updated by Fireball almost 4 years ago

  • Status changed from In progress to Resolved

Applied in changeset commit:05a300a546479086e05599b80d2e0168b7e1b988.

Updated by Kol9yN almost 4 years ago

  • Priority changed from Urgent to Low

Updated by Kol9yN almost 4 years ago

  • Status changed from Resolved to In progress
  • Priority changed from Low to Normal

Updated by Kol9yN almost 4 years ago

  • % Done changed from 100 to 80

- Sometimes players deploy HQ very close to houses and cars or heli resp on roofs or inside buildings, make check if MHQ try deploy nearby some buildings in distance <30m cancel deploy with message.

Updated by Kol9yN almost 4 years ago

  • % Done changed from 80 to 100

Updated by Kol9yN almost 4 years ago

  • Status changed from In progress to Resolved
  • Priority changed from Normal to Trivial

Updated by Kol9yN almost 4 years ago

  • Status changed from Resolved to Closed

Updated by Fireball over 3 years ago

  • Target version changed from 0.82 to 1.50

Also available in: Atom PDF