Bug #25252

incorrect bullet velocity drop for 30x113mm round at long distance (M230 chaingun)

Added by cyrilator over 3 years ago. Updated over 3 years ago.

Status:Closed Start date:10/07/2011
Priority:Normal Due date:
Assignee:q1184 % Done:

100%

Category:Config
Target version:1.13
Component:c_vehicle Affected Version:
Close Reason:

Description

According to this wikipedia link :

http://en.wikipedia.org/wiki/M230_Chain_Gun

the 30x113mm can reach a target distant of 1000m in two seconds (it's ok in game) but for long range, a 3000m point target is supposed to be reached in about 12 seconds.

I checked the flight-time needed to reach a point target at 3000m and it took 22 seconds !! 10 seconds more than the theoretic flight time.

Associated revisions

Revision 50354184
Added by q1184 over 3 years ago

~ fixed: Apache cannon rounds time of flight. Fixes #25252

History

Updated by Huggy over 3 years ago

Might be just me but i am not even able to reach out with that cannon that far ingame.
Limitations while using FCS are around 2200 ~ 2500 meters

Might be just me..........

@author:

1st: wikipedia is not the most reliable source to look for informations
2nd: same page of your source "Muzzle velocity 805 m/s (2,641 ft/s)" do some math according this value for 2 secs

Updated by cyrilator over 3 years ago

Huggy wrote:

Might be just me but i am not even able to reach out with that cannon that far ingame.
Limitations while using FCS are around 2200 ~ 2500 meters

you should try again because FCS with M230 still work at 3000m (put your view distance at max, aim with FCS at ±3080m wait during ±22 seconds of time flight and the shell should hit at ±3000m.

1st: wikipedia is not the most reliable source to look for informations

maybe, so what is the true timeflight ? 12 seconds or 22 seconds for 3000m ?

2nd: same page of your source "Muzzle velocity 805 m/s (2,641 ft/s)" do some math according this value for 2 secs.

805m/s is at the muzzle exit, during this 1000m flight distance the bullet lost speed.
With ACE it take 1,7 second to reach 1000m. (i suppose they said 2 seconds on wikipedia to rounding)

The question concern bullet velocity drop at long range,
Does the bullet lost that much speed and really require 22 seconds (instead of 12 secs according to wiki) ? or is there an error with the bullet velocity drop coefficient ?

time flight ingame :

1000m : 1,7 secs.
2000m : 7 seconds.
3000m : 22 seconds.

Updated by rocko over 3 years ago

  • Assignee set to zGuba

Updated by zGuba over 3 years ago

  • Status changed from New to Feedback
  • Assignee changed from zGuba to q1184

I guess that air friction is set too high for that bullet. q1184, since You're most experienced with such values, could You check it please?

Updated by zGuba over 3 years ago

  • Category set to Config
  • Component set to c_vehicle

Updated by rocko over 3 years ago

  • Target version set to 1.13

Updated by cyrilator over 3 years ago

another example IRL :

http://www.youtube.com/watch?v=vbTjmCz-Ilk

in this link you can see a French Tiger helicopter using his 30x113mm autocannon similar to the AH64D M230 Chaingun.

at 2:12 the gunner shot the first shell from 2000m distance (telemeter display is visible), the first shell hit at 2:18.

6 seconds for 2000m range.

i don't see how the round would require 22 seconds for 3000m.

Updated by Huggy over 3 years ago

Edited because of wrong informations and poor research
@cyrilator: Thanks for correcting me

But i agree, even with air friction and gravity, it should not need 22 seconds to fly 3000 meters.

I am still not able to reproduce 3000 meter combat distance with FCS though

Updated by cyrilator over 3 years ago

no, you are mixing up two differents Giat 30 autocannons (now built by Nexter group).

http://en.wikipedia.org/wiki/GIAT_30

- The Giat 30M781 autocannon equips the Eurocopter Tiger chambered with the 30x113mm and having a muzzle velocity of 810m/s

- The Giat 30M791 is another 30mm autocannon equipping the Dassault Rafale fighter, chambered with the 30x150mm round, this one have a muzzle velocity of 1025m/s.

Updated by Huggy over 3 years ago

My fault sorry

Updated by rocko over 3 years ago

Is it reproduceable without ACE, btw?

Updated by Sickboy over 3 years ago

Have you reconfirmed this with the latest v1.60 betas, these have afaik fixes for speed over distance etc.

Updated by cyrilator over 3 years ago

I installed the latest Beta version v1.60 (build 87105)

and it's still has bad results, maybe getting even worst :

I enabled the laser designator, pointed the laser at ground level (flat relief) at 3000m. the bullet flies during exactly 30 seconds(!) and hit at 2840m.

I tested to lasering at higher range (3100m,3200m,3300m up to 3600m) to try to hit at an exact range of 3000m, but the bullet always fall at a maximum range of 2850m.

Updated by Sickboy over 3 years ago

  • Target version changed from 1.13 to 1.14

Updated by Sickboy over 3 years ago

Thanks!

Updated by rocko over 3 years ago

  • Status changed from Feedback to Assigned

Updated by q1184 over 3 years ago

  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100

Updated by cyrilator over 3 years ago

Now the bullet velocity is much closer to the real time flight. (it took approximately 10 seconds to reach 3000m)

Updated by Sickboy over 3 years ago

  • Status changed from Resolved to Closed
  • Target version changed from 1.14 to 1.13

Available on Six Updater, run Verify and Repair.
Will also be included with Stable.

Also available in: Atom PDF