Bug #25223

Control of UAV is always with server player, even if the team leader has the UAV terminal backpack

Added by Varanon over 3 years ago. Updated over 3 years ago.

Status:Closed Start date:10/06/2011
Priority:Normal Due date:
Assignee:Dwarden % Done:

0%

Category:BI Modules
Target version:1.60.87580
Affected ArmA II version:1.60 BETA First affected build:85123
Reproduced by another DH user:No First affected ArmA II version:1.60 BETA
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

Obs
The setup is like this:
The team leader has a UAV backpack that is by scripting synchronized to the UAV module.
Usually, the team leader (resp. the one in posession of the UAV backpack) should have control over the UAV.

However, starting with beta #85213, the control of the UAV is always with the player that hosts the server.

Repro
  1. Host the mission and choose slot 2 (player 2)
  2. Have a 2nd player play the other slot
  3. The host player will control the UAV
  4. Start and activate the UAV as host
  5. All fine
  6. Now, reverse the roles
  7. As host choose player 1
  8. Have the 2nd player play the other slot
  9. The host player will again have control over the UAV.

uavtest.Desert_E.7z - repo mission for the above issue (1.1 kB) Varanon, 10/06/2011 17:33


Related issues

related to ARMA2 Community Issue Tracker - Bug #25458: Scripting issues with OA campaign 07 Eye of the Typhoon m... Closed 10/14/2011
related to ARMA2 Community Issue Tracker - Bug #22448: UAV module is broken. All added UAV modules are "renamed"... Assigned 07/17/2011 10/30/2011

History

Updated by Sickboy over 3 years ago

  • Status changed from New to Assigned
  • Assignee set to Dwarden
  • Reproducible for you changed from No to Yes

Updated by kju over 3 years ago

  • Description updated (diff)
  • Operating system deleted (Win7 64 bit)
  • Language deleted (Please set for missions)

Updated by kju over 3 years ago

Might be the same cause as of #25458. Init vs EH execution.

Updated by Varanon over 3 years ago

This bug seems to be fixed with 85510

Updated by kju over 3 years ago

  • Status changed from Assigned to Closed
  • Target version set to 1.60 BETA

tx

Updated by Anunnaki over 3 years ago

Perhaps this is the same issue like here:
http://dev-heaven.net/issues/22448

I will do some tests till end of week.

Updated by kju over 3 years ago

  • Target version changed from 1.60 BETA to 1.60.87580

Also available in: Atom PDF