Bug #25201

MP - Helicopter breaks when co-pilot jumps out.

Added by Rg almost 4 years ago. Updated over 3 years ago.

Status:Closed Start date:10/06/2011
Priority:Normal Due date:
Assignee:hladas % Done:


Category:Game physics
Target version:1.01.85675
Difficulty: Reproducible for you:No
Reproduced by another DH user:No First affected build:
CPU: Affected TOH version:
I am using some Mods:No First affected TOH version:
I am using: Single / Multi Player?:


Using PreOrder-Beta

[Person A]
1) Auto-Start the helicopter and let it go to full throttle.
2) Fly up into the air 100+ meters.

[Person B]
1) Jump out of the helicopter.

It seems that the helicopter blades break off and the helicopter falls to it's death, while [Person B] parachutes safely to the ground. Maybe the parachute is breaking the blades?

MP_Test_1.United_States_H.rar (1.5 kB) Rg, 10/06/2011 06:33


Updated by hladas almost 4 years ago

Revision 85160
Parachutes are ignored for blades collisions.

Updated by hladas almost 4 years ago

  • Status changed from New to In progress
  • Assignee set to hladas
  • Reproduced by another DH user set to No
  • I am using some Mods set to No
  • Reproducible for you set to No

Updated by hladas almost 4 years ago

  • Target version set to Upcoming version

Updated by Rg almost 4 years ago

Fix confirmed in experimental patch. (Only tested once in a medium helicopter, but looks like it's solved)

Updated by Master85 over 3 years ago

  • Category set to Game physics
  • Status changed from In progress to Closed
  • Target version changed from Upcoming version to 1.01.85675

Also available in: Atom PDF