Task #25065

BTR-70 does not use KPVT against APCs

Added by maturin over 3 years ago. Updated over 2 years ago.

Status:New Start date:10/01/2011
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:Model
Target version:Planned (Needs Contributors)
Component: Affected Version:
Close Reason:

Description

The BRDM-2 uses its 14.5mm to great effect against APCs such as LAV-25s and other BRDMs.

The BTR-70 carries the same weapon, yet will not fire it against these vehicles. As a result, its gun is useless for its intended purpose.

Latest version of ACE.

History

Updated by Sickboy over 3 years ago

  • Status changed from New to Assigned
  • Assignee set to VKing
  • Target version set to 1.13

Sounds familiar.
Repro mission and rpt missing.

Updated by maturin over 3 years ago

Sickboy wrote:

Sounds familiar.
Repro mission and rpt missing.

There's no repro mission. Just put an LAV-25 and BTR-70 on the Utes runway and watch what happens.

Tested below with no other mods. =====================================================================
C:\Program Files\Steam\steamapps\common\arma 2 operation arrowhead\Expansion\beta\arma2oa.exe
"C:\Program Files\Steam\steamapps\common\arma 2 operation arrowhead\Expansion\beta\arma2oa.exe" "-mod=C:\Program Files\Steam\steamapps\common\arma 2;Expansion;ca;Expansion\beta;Expansion\beta\Expansion;@cba;@ace;@acex;@acex_usnavy;@acex_ru" -nosplash -world=empty -showScriptErrors -maxMem=2047 -cpuCount=2 =====================================================================
Exe timestamp: 2011/09/30 20:32:53
Current time: 2011/10/01 14:04:32

Version 1.59.85015
Item str_disp_server_control listed twice
Warning: looped for animation: ca\wheeled\data\anim\uaz_cargo01_v0.rtm differs (looped now 0)! MoveName: kia_uaz_cargo02
Warning: looped for animation: ca\wheeled\data\anim\uaz_cargo01_v0.rtm differs (looped now 1)! MoveName: uaz_cargo02
Warning: Road selection asf3 has wrong name format
Warning: Road selection mud has wrong name format
[5307,107.728,0,"XEH: PreInit Started. v3.3.0"]
[5307,107.909,0,"MISSINIT","","utes",false,true,false,"CACHE ENABLED? (XEH, Generic Compile, Function Compile)",[true,true,true],"Disable caching with cba_disable_cache.pbo"]
[5307,118.511,0,"XEH: PreInit Finished"]
[5307,118.599,0,"XEH: VehicleCrewInit: 2"]
[7690,124.89,0,"XEH: PostInit Started"]
[7690,125.101,0,"CBA_VERSIONING",["#CBA_HASH#",["cba","ace","acex","acex_ru","acex_usnavy"],[[[0,7,10,167],-1],[[1,12,1,509],-1],[[1,12,0,346],-1],[[1,12,0,60],-1],[[1,12,0,63],-1]],[[0,0,0],0]]]
[7690,125.915,0,"XEH: PostInit Finished; [true,false,false,true,false,true,true,true,true,false,1,1]"]
Warning: Road selection asf3 has wrong name format
Warning: Road selection mud has wrong name format
[9850,176.691,0,"XEH: PreInit Started. v3.3.0"]
[9850,176.701,0,"MISSINIT","","utes",false,true,false,"CACHE ENABLED? (XEH, Generic Compile, Function Compile)",[true,true,true],"Disable caching with cba_disable_cache.pbo"]
[9850,177.268,0,"XEH: PreInit Finished"]
[9850,177.396,0,"XEH: VehicleCrewInit: 2"]
[9878,179.11,0,"XEH: PostInit Started"]
[9878,179.165,0,"CBA_VERSIONING",["#CBA_HASH#",["cba","ace","acex","acex_ru","acex_usnavy"],[[[0,7,10,167],-1],[[1,12,1,509],-1],[[1,12,0,346],-1],[[1,12,0,60],-1],[[1,12,0,63],-1]],[[0,0,0],0]]]
[9878,179.217,0,"XEH: PostInit Finished; [true,false,false,true,false,true,true,true,true,false,1,2]"]

Updated by rocko over 3 years ago

Works fine for me in current dev build. And AFAIK there have been no further changes according to the KPVT.

Updated by maturin over 3 years ago

rocko wrote:

Works fine for me in current dev build. And AFAIK there have been no further changes according to the KPVT.

Are you using beta patches? I was running CO with the latest SixUpdater build and the latest beta. Russian BTR-70 and USMC LAV-25. All ACE mods except ACE_SM were enabled.

Updated by rocko over 3 years ago

Using the latest beta.

Do I have to maintain a minimum or maximum distance to cause them not firing? In my test, on desert, distance was ~500-700m or so.

Updated by maturin over 3 years ago

rocko wrote:

Using the latest beta.

Do I have to maintain a minimum or maximum distance to cause them not firing? In my test, on desert, distance was ~500-700m or so.

Oh, no I tested at 50-150m so I could be sure of mutual recognition.

Updated by zGuba over 3 years ago

This can be particularly related to betas, which reduce AI seeing capability. Can You reproduce it with 1.59 stable?

If so, we should check AI seeing values and behavior with and without commander.

Updated by maturin over 3 years ago

zGuba wrote:

This can be particularly related to betas, which reduce AI seeing capability. Can You reproduce it with 1.59 stable?

If so, we should check AI seeing values and behavior with and without commander.

The problem persists with 1.59. And the BTR has definitely spotted me, and swiveled its turret to aim at my vehicle. Do BTRs even have commanders?

Updated by zGuba over 3 years ago

Yes they do.

Updated by rocko over 3 years ago

minEngagement Range too high? So they do not fire under 50m - 100m?

Updated by maturin over 3 years ago

No, I tested it at 100 and 400 meters

Updated by Sickboy over 3 years ago

  • Assignee changed from VKing to Robalo

Updated by rocko over 3 years ago

  • Due date set to 10/21/2011

Any final words before friday?

Updated by maturin over 3 years ago

I never saw any evidence that visibility was the culprit, although I guess we never checked zGuba's idea about commanders. I will wait for the next version of ACE and see if the problem disappears.

Updated by rocko over 3 years ago

  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100

Setting to resolved then. Reopen if still an issue after next update.

Updated by maturin over 3 years ago

Hold the phone, guys,

I just tested and if there is no commander in the vehicle, the gunner will use the KPVT.

Repro: Place empty BTR-70, a two crewman group with the player as commander, and a BMP for a target. Order you subordinate to enter the BTR as gunner. He will automatically attack the BMP with his 14.5mm gun. If the player is inside the vehicle as commander, he will only use attack armored targets with the gun if ordered to. An AI commander will never order an attack using the KPVT.

Updated by maturin over 3 years ago

Further findings:

BTR-60s from ACE 2 have the same problem. Commanders will not allow their gunners to fire on armored vehicles.

BMP-2s will not use their 30mm cannon on BTR-60s and 70s unless the commander exits the vehicle.

Updated by rocko over 3 years ago

  • Status changed from Resolved to In progress

Updated by Robalo over 3 years ago

What's weird is that the BTR-70 will engage the BMP-2 HQ variant, but not the regular BMP-2. Need to compare the configs for those 2.

Updated by Sickboy over 3 years ago

Robalo wrote:

What's weird is that the BTR-70 will engage the BMP-2 HQ variant, but not the regular BMP-2. Need to compare the configs for those 2.

There's not only config involved of CfgVehicles, but also CfgWeapons/Magazines/Ammo perhaps, but more importantly, I suppose there's also relation to the Model, Geo Lod? if im not mistaken.

Updated by Robalo over 3 years ago

Sickboy wrote:

Robalo wrote:

What's weird is that the BTR-70 will engage the BMP-2 HQ variant, but not the regular BMP-2. Need to compare the configs for those 2.

There's not only config involved of CfgVehicles, but also CfgWeapons/Magazines/Ammo perhaps, but more importantly, I suppose there's also relation to the Model, Geo Lod? if im not mistaken.

The model perhaps, but not the weapon/ammo, I limited the testing scenario to exclude that aspect, having exactly the same shooter, 2 very similar targets.

Updated by Robalo over 3 years ago

If I changed just the model in the BMP-2 config, to use the HQ model just for testing, then the BTR-70 will engage it.

Updated by Robalo over 3 years ago

Another interesting/strange find is that changing the threat config for the BMP-2 from

threat[] ={0.9,0.9,0.7};

to
threat[] ={0.9,0.2,0.7};

will enable the BTR-70 to engage it.

Updated by Robalo over 3 years ago

  • Category set to Model Request
  • Status changed from In progress to Assigned
  • Assignee deleted (Robalo)
  • Target version changed from 1.13 to Planned (Needs Contributors)
  • % Done changed from 100 to 0

Of course, that's not a good fix because it will make the BMP-2 a target even less interesting than an unarmed UAZ car.
Plus, it only seems to fix engaging the Taki target, but not the Russian one (older model from A2). So it's a model issue more than anything else.

Updated by rocko over 3 years ago

  • Target version changed from Planned (Needs Contributors) to 1.13

Updated by rocko over 3 years ago

  • Category changed from Model Request to Model

Updated by rocko over 3 years ago

Perhaps some1 sends Dwarden or Suma or Marek an email and asks how to calculate damageResistance from the model correctly?

Updated by Sickboy over 3 years ago

  • Tracker changed from Bug to Task
  • Target version changed from 1.13 to Planned (Needs Contributors)

Updated by rocko about 3 years ago

  • Status changed from Assigned to New

Updated by rocko about 3 years ago

  • Due date deleted (10/21/2011)

Also available in: Atom PDF