Bug #2500

Graphic artefacts with ATI cards

Added by GingerMcAle almost 6 years ago. Updated almost 4 years ago.

Status:Closed Start date:07/03/2009
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:Visual
Target version:1.05.62017
Affected ArmA II version: First affected build:
Reproduced by another DH user:No First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:No NGUrl:
Related to content of DLC: WIKIurl:

Description

Artefacts over the full screen

Videos showing it:
- bug starts at 0:40, 31 MB, flash video, high quality http://www.tsviewer.com/lager/arma2.2009-05-29.21-32-42-18_1.flv
- video on youtube (low quality) http://www.youtube.com/watch?v=imN3xa0sZxU

Facts and other interesting stuff about it:
- its not a heat or overclock problem
- only affecting the 3D image; the 2D overlay images (team member avatars, comunication menu) seem not to be affected
- bug did occur in Arma 1 too bet less often
- tested with ATI drivers 9.5 and 9.6
- bug occured since first Arma 2 version
- when you have the bug, you can trigger it by looking in different directions (if you look up into the sky everything is fine, if you look down it comes back)
- when graphic settings are set to high the bug comes faster, when graphic settings are low, it does sometime do not come
- bug does not show up on Utes or less frequent, so reprodoce only with big map
- ATI 3xxx cards are also affected
- bug does occur also when game is in window mode
- bug seems not happen with Windows 7 (http://forums.bistudio.com/showpost.php?p=1343462&postcount=190 and http://forums.bistudio.com/showpost.php?p=1339440&postcount=174)
- it seems the bug does occur when the VRAM of the graphic cards gets FULL (http://img199.imageshack.us/img199/8859/arma2graphatt.png)

Steps for reproduction:
- max all graphic settings, everything on highest value
- open Tschernarus in editor
- place you inside a chopper at biggest city in south at the coast
- fly around, low at the city, after max 60 seconds you get the error

This seems to be the fastest way to get the problem.

When having the graphic settings on medium, it takes longer to get the erorr. When graphic settings are on low, the problem seems not to come or less frequent.

Screens:
- http://forums.bistudio.com/showpost.php?p=1292834&postcount=1
- http://forums.bistudio.com/showpost.php?p=1294676&postcount=29
- http://forums.bistudio.com/showpost.php?p=1301761&postcount=1

DxDiag.txt (60.7 kB) GingerMcAle, 07/03/2009 11:35

ArmA2.cfg (335 Bytes) GingerMcAle, 07/03/2009 11:35

username.ArmA2Profile (458 Bytes) GingerMcAle, 07/03/2009 11:35

DxDiag.txt (51.8 kB) Convoke, 07/03/2009 17:06

DxDiag.txt - DX Diagnostics (57.2 kB) Toniezz, 01/02/2010 14:55

ArmA2.cfg - ArmA 2 config file (404 Bytes) Toniezz, 01/02/2010 14:55

Toniezz_2eBH.ArmA2Profile - ArmA 2 Toniezz' profile (9.1 kB) Toniezz, 01/02/2010 14:55

ArmA2_fresh.cfg (401 Bytes) Toniezz, 01/03/2010 22:28

ArmA2.cfg (401 Bytes) Toniezz, 01/24/2010 23:42


Related issues

duplicated by ARMA2 Community Issue Tracker - Bug #2118: Graphics Corruption When Using "Default" Setting On Video... Duplicate 06/18/2009 08/24/2009

History

Updated by kju almost 6 years ago

  • Category set to Visual
  • Status changed from New to Feedback

GingerMcAle please attach dxdiag, arma2.cfg, arma2profile.

Updated by alef almost 6 years ago

GingerMcAle wrote:

- it seems the bug does occur when the VRAM of the graphic cards gets FULL (http://img199.imageshack.us/img199/8859/arma2graphatt.png)

This is I've experienced in nVidia too, also in A1, with any driver version.
Using Rivatuner HW display, most of the times I get crashes/corruptions/mess as used vram reaches the top.
The only workaround I know is to set the texture allocation not to "Default", or typing -FLUSH sometimes.

Updated by INNOCENTandCLUELESS almost 6 years ago

strange, me too, once this is starting, it is becoming worst and worst until crash.

me -> Nvidia 8800 GTX

Updated by kju almost 6 years ago

Seems like a driver issue.

Did you try a new clean XP with 182.50 driver on a separate partition?

Updated by shezan74 almost 6 years ago

Same problem for me. The problem will be less evident when disabling Anti Aliasing and Anisotropic filter.
On some occasions this happened again, and will be tackled away by reducing memory usage (texture details) to default or low

Updated by GingerMcAle almost 6 years ago

My Arma settings are default, but here are the requested files and dxdiag.

Updated by alef almost 6 years ago

  • Due date set to 10/03/2009
  • Status changed from Feedback to Assigned

Thank you GingerMcAle.

Updated by Convoke almost 6 years ago

Absolutely same problem, but in my case, graphic corruption appears even at normal settings.

Updated by Thr0tt almost 6 years ago

Same issue on HD3850 AGP / Windows XP.

ASROCK AM2NF3-VSTA | AMD Phenom II x4 955 BE 3.2GHz | Sapphire HD3850 AGP (9.6) CCC | Corsair - TWIN2X4096-6400C5 4 GB |Samsung 2232BW 22" LCD | X-Fi Ultimate Gamer (5.1) | LiteOn DH20A4P DVD-RW | Saitek Cyborg Evo Joystick | M$ Windows XP Pro SP3.

Updated by kju almost 6 years ago

  • Maxmem parameter set to Not set

Maxmem used?

Updated by Blueshift almost 6 years ago

Same problem on a NVIdia GTX260. For me, this occurs both with maxmem=2047 or no maxmem.
Same, worth and worth until crash. Got "receiving" messages too just before but not each time (50% of the time), or just some small freezes.

It seem to work by zones of some sorts. I've got this while walking through the map, from one point to another.

For exemple, Ive got this in the campaign, in the begining of the Razor2 mission, but not around the camp (+/- 100m). If I come back in the US camp, strange gray artifacts and sometimes crash.

To got there, I think I made the game work using maxmem=1900 but i'm not sure, I have to test this a little more.

- edit - I just used maxmem = 1024 but the game freeze, I had to kill it via the taskmanager. Was around 300/400 memory usage.
- edit - i7 920, 3Gb DDR3, GTX260, XP32, PSU Corsair 650 Watts and mobo is an Asus P6T. NVidia Drivers are 182.5, rolled back from 186.18 where it occurs too.
- edit - Just tried maxmem=1900, came back in Razor2 mission'camp and shake my head.
Result is a blue screen of death, with the error :
PAGE_FAULT_IN_NONPAGED_AREA
  • STOP: 0x00000050 (0xE81EF000,0x00000000,0xE8001C6A,0x00000001)

In windows event observer i've got no error. :/

Updated by idecchi almost 6 years ago

im having exactly the same problem.
When I turn Texture quality to normal it won't happen but when it comes to High or Very High , it happens even when I set my Video fan speed up to 100% in catalyst.
I think it has something to do with video memory.

ARMA2 steam version 1.02.58136
Windows XP professional SP3
Catalyst 9.5 / 9.6

CPU AMD Athlon X2 6000+ 3GHz
Memory 4GB
M/B Gigabyte GA-MA770-S3
Video Card Sapphire ATI Radeon HD 4850 512MB PCI-E

Updated by kju almost 6 years ago

tx good info!

Updated by Scrub almost 6 years ago

Alt-Tabbing make the problem go away for a while. If I do this and fly away from the city, the problem stays away.

Updated by Thr0tt almost 6 years ago

Try the Shift - flush when it happens, this will flush the memory but will happen after it fills again. It is a work around for some that have the issue less frequently but for those of us where it happens in the first 5-10 mins of gameplay this is unacceptable.

Updated by Blueshift almost 6 years ago

NVidia Cards : put -openal in your shortcut, it improves a lot, GPFX artifacts are much less frequent in my game now (there's still ctd).

Could someone with ATI cards try this ?
Credits goes to this guy : http://dev-heaven.net/issues/show/2607#note-6

Updated by El_MUERkO over 5 years ago

Using the Windows 7 RC-64bit, a pair of crossfired HD4870s and CAT 9.7 and beta 9.8 drivers I'm getting similar issues.

Updated by Skeptic over 5 years ago

Anyone tried 9.8 Cats? BIS says it had memory fragmentation/flushing fixed. This is very much similar to texture eviction bug in earlier nVidia versions when 8800GT 512MB first came out.

I can confirm that setting VidMem to Very High on 1Gb HD4890 seems to help with XP 32bit on 9.6. About hour long sessions and still OK.

9.6 on W7 64bit works fine with VidMem at default...

Updated by zGuba over 5 years ago

  • Due date changed from 10/03/2009 to 10/14/2009
  • Status changed from Assigned to Feedback
  • Reproduced by another DH user set to No

What about 1.04? Maybe it has been fixed?

IMO it's something about model vertices getting screwed. Saw that with BI Javelin in A1.

Updated by Fireball over 5 years ago

  • Due date changed from 10/14/2009 to 10/28/2009
  • CPU set to Please specify!

Giving more time for feedback - anyone?

Else I'll expire this.

Updated by GingerMcAle over 5 years ago

What does this mean? The problem is still not fixed.

Updated by Fireball over 5 years ago

  • Affected ArmA II version changed from 1.02.58134 to 1.04.59026

Thanks.

Updated by Fireball over 5 years ago

Possibly related to #4042?

Updated by GingerMcAle over 5 years ago

Possibly, but only Bohemia could bring some light into it i think.

Updated by Dwarden over 5 years ago

  • Assignee set to Dwarden

Updated by Fireball over 5 years ago

  • Due date changed from 10/28/2009 to 11/28/2009
  • Status changed from Feedback to Assigned

Updated by kju over 5 years ago

Same here with 4890 using default (video memory).
On different values, all works fine.

Updated by Vipera over 5 years ago

I have the same problem on ATI 4870 with 1GB memory. If i increase textures quality from Normal than I see sometimes graphic artefacts as shown in the first post.
My spec:
MB: ASUS_P5Q-PRO | CPU: Intel Quad Q9550 (2.83Ghz) | Video: ATI Radeon 4870 (1 Gb) | RAM 4 Gb | Sound: X-Fi Fidelity | Trackir 3 Pro | Joystick: Logitech Extreme 3D Pro | OS: Windows 7 - 64bit

Updated by kju over 5 years ago

  • Due date changed from 11/28/2009 to 11/14/2009
  • Status changed from Assigned to Feedback

Can you please test the latest beta patch and report back:
http://www.arma2.com/beta-patch.php

[59924] Fixed: More 32b overflows caused by 8 GB RAM + large VRAM.

Updated by kju over 5 years ago

  • Due date deleted (11/14/2009)
  • Status changed from Feedback to Resolved
  • Assignee deleted (Dwarden)

No feedback. Setting to resolved.

Reopen to feedback if still applies to the latest beta.

Updated by Toniezz over 5 years ago

Hello, I am running the latest patch for ArmA 2 (1.05) and am still having this problem.

I have tried several settings and reinstallations of the latest ATI drivers and ATI Catalyst software (v9.12).
I have tried to downscale my graphics in ArmA 2, with no success
I have tried all video memory settings in ArmA 2, with no success
I have tried several VRAM and GPU clock settings in my Catalyst settings

The problem is exactly as described in this Bug#2500.

Intel Core i7 ™ 920 (d0) 2700MHz ASUS P6T SE 4 GB of OCZ 2000 MHz DDR3 SDRAM ATI® Radeon HD 4870, 512 MB Seagate 40.0 GB, Maxtor 160 GB
Iiyama ProLite E2208HDS Creative Sound Blaster X-Fi XtremeGamer Windows XP Professional, Service Pack 3 CoolerMaster 700W Silent Pro PSU Coolermaster 690 Big Tower

Updated by Fireball over 5 years ago

  • Status changed from Resolved to Feedback

Toniezz wrote:

I have tried several settings and reinstallations of the latest ATI drivers and ATI Catalyst software (v9.12).
I have tried to downscale my graphics in ArmA 2, with no success
I have tried all video memory settings in ArmA 2, with no success
I have tried several VRAM and GPU clock settings in my Catalyst settings

Did you try deleting your ArmA2.cfg (first, make sure ArmA2 is not running) and then starting ArmA2 and reconfiguring 3D resolution and FSAA again? This could enable the newest fixes to detect your memory correctly.

Updated by Toniezz over 5 years ago

Fireball wrote:

Did you try deleting your ArmA2.cfg (first, make sure ArmA2 is not running) and then starting ArmA2 and reconfiguring 3D resolution and FSAA again? This could enable the newest fixes to detect your memory correctly.

Thanx, will try that. For now I had turned down my GPU clock and Memory clock both to 510 MHz. It hasn't come back within the hour I played. But I will try again with default clocks (GPU 750 MHZ, Memory 900 MHz) and a new ArmA2.cfg file.

Just a question, I see that in the default settings of CCC the 3D refresh rate override is disabled (Display options). Could it have something to do with 3D refresh rates of ArmA 2 and the desktop display? Does anyone have experience with that feature in ArmA 2? Just curious, I am hoping that with the new cfg file it is resolved.

Thanx for the quick reply!

Updated by Toniezz over 5 years ago

I tried the update for the ArmA 2 config file but to no reveal (see attached file). After an hour gameplay the glitch came back and came back after 5 minutes everytime I flushed the memory (shift + minus) or tabbed out and back in, tried all memory settings in ArmA 2 again (low, normal, high, very high and default).

I have set my GPU Clock and Memory Clock back to 510 MHz and turned on the 3D refresh rate overwrite to 'same as display' as a last resort. I will test more this week and let you all know if that helps for the long run. I will also try running ArmA 2 on a lower resolution then my native resolution of my desktop (1920x1080).

Thanks for your replies and suggestions.

Updated by kju over 5 years ago

Try GPU-Z to monitor your GPU.
Like temp, load and such.

Updated by Toniezz over 5 years ago

I have set my GPU Clock and Memory Clock back to 510 MHz and turned on the 3D refresh rate overwrite to 'same as display'. I deleted the ArmA.cfg file and let ArmA set everything by default. Now the problem only happens after more then a hour gaming, but much less agressive. A simple flush of the memory and I can go on for hours and hours. I am satisfied by this sollution. I hope it stays like this because gaming is much nicer then resolving computer issues.

Thanx for the help guys and I hope my experience can help others.

Game On!

Toniezz out...

Updated by Fireball about 5 years ago

  • Due date set to 02/07/2010
  • Status changed from Feedback to Resolved
  • Target version set to 1.05.62017

Sounds pretty much like a hardware issue Toniezz, I'm sorry.

But thanks for your feedback, I'll mark this as resolved since the bug for any other user seems to be gone.

Updated by kju about 5 years ago

  • Due date deleted (02/07/2010)
  • Status changed from Resolved to Closed

Updated by GingerMcAle almost 5 years ago

Please dont mark this as resolved or closed. The problem is still there and also present in OA. Newest victim of that one in ArmA 2: http://forums.bistudio.com/showpost.php?p=1680395&postcount=1012

Updated by kju almost 5 years ago

  • Affected ArmA II version deleted (1.04.59026)

GingerMcAle create a new ticket and provide up-to-date information. Ty

Updated by Dwarden almost 5 years ago

  • I am using some Mods set to No
  • Reproducible for you set to No

the problem with the 'rarity' of this cases it seems to be as some hidden flaw in the GPU or firmware of these GPU cards...

or combination of card and driver vs game ...

there is no repro to follow and no patter to track

i have ATI cards from 2xxx, 3xxx, 4xxx and 5xxx serie and i don't have these issues

yes in past there were some vertexes out of range in ARMA 1 and some similar issue in early ARMA 2 but
that all got fixed by engine updates and some in drivers by AMD

since then i'm unable to replicate reports like the one above

Updated by Blueshift almost 5 years ago

Mmm...

Why you still persist into thinking it's a GPU problem...

I'm relativly sure it's a CPU problem. Most of us have an i7 920 and quite the same mobos by the time the game came out with i7 on the same timeframe... (so they were not tested).

i7 CPU's hardware design were a revolution, not GForces or ATIs' designs. The game couldn't have been tested with last year's "new" i7 CPU/mobos, but could with the gfx cards, because gfx cards are just bigger card than older gfx cards.

I've got this problem, with a GeForce. I'm not alone. And some of us have with ATI. The funny thing is most of us have i7.

And about the reproducibility, if I play 2 hours I've got the problem, so I really can't agree. It happens when the player changes of zone (usually after the "incomming" message if you've got a slow pc).

Try that :
i7 920/Asus P6T/DDR3 memory/all details max
- play 2 hours (to "heat" the components)
- go in one zone with some meshes with high memory bandwidth required
- go in another adjacent zone with some completly different meshes, less memory bandwidth required
- move your head fast
- go back in zone 1
- move your head fast
- go back in zone 2
- move your head fast
- ...repeat until you've got the bug.

imho it's because when the cpu starts to handle meshes as objects and when it tells the gpu to unloads old meshes / reload others meshes, memory leaks on edges. Try formating the memory before using it, maybe, because I can smell "yeah I overwrite the memory 'cause it's faster woops I forgot \n's..."

BI, use more than one dev on this once by month because it's quite sad we can't play since one year you released the game.

At least, TRY to fix it.

And ANYWAY, if you have this memory leak, sincerly, this can be fixed by auditing the source. Some piece of code is badly calling a memory/graphic driver, and noone in your company have a clue, because you've got this problem since ARMA1... It could be a good thing to fix this for future games.

???

Updated by Fireball almost 4 years ago

  • Status changed from Closed to Resolved
  • Target version changed from 1.05.62017 to 1.60 BETA

I think these artifacts were an issue ever since, but only seemed to be rendered visually mostly by ATI cards, hence the subject.

For the record, this issue is probably only fixed now by the recent 1.60 BETA and closed in error due to lack of evidence and repro, hence I re-open it as Resolved for the protocol and shift the target version up.

Forum thread for reference.

Updated by Suma almost 4 years ago

The recent fix was a fix of a quite recent issue. While the visual symptoms may look similar, the issue reported here could not be caused by the same cause, as the cause was introduced after 1.59

Updated by Fireball almost 4 years ago

  • Status changed from Resolved to Closed
  • Target version changed from 1.60 BETA to 1.05.62017

Ok, thanks for the info!

Updated by kju almost 4 years ago

  • Target version changed from 1.05.62017 to 1.60 BETA

This is completely unrelated Fireball.

Most likely this one is related or the same as #16714.

Updated by kju almost 4 years ago

  • Target version changed from 1.60 BETA to 1.05.62017

Also available in: Atom PDF