Bug #24898

When a player joins a server and spawns far away from others he won't be able to communicate until he gets closer to them

Added by neokika over 3 years ago. Updated about 3 years ago.

Status:Closed Start date:09/25/2011
Priority:Normal Due date:
Assignee:Dwarden % Done:

0%

Category:Multiplayer
Target version:1.60.87580
Affected ArmA II version:1.60 BETA First affected build:Please Specify...
Reproduced by another DH user:No First affected ArmA II version:Please select...
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

When a player joins a server and spawns far away from others he won't be able to communicate until he gets closer to them

Repro:
- Run example mission on a Dedicated Server
- Player_1 joins mission
- Player_2 joins mission
- Player_1 and Player_2 can communicate fine since they are near
- Player_1 teleports (click on map) away from the spawn position (> 7000m to be safe)
- Player_2 stays at base
- They can still communicate fine even at distance
- Player_3 joins and is very far from Player_1 but near Player_2
- Communication between Player_2 and Player_3 is good since they are close
- Communication between Player_1 and Player_3 is bugged, Player_1 sees Player_3 text but without name, Player_3 does not receive any communications from Player_1
- All players regroup and communication issues are gone

Notes:
- When testing, I was getting closer by chopper and between 2500/3000 meters away from the other player, I started to hear him and the issue was gone
- I'm guessing that the problem is a distance synchronization issue, and when a player joins the synchronization radius with others must be a lot bigger (map size)
- Test mission had to be in Chernarus so you can get far away

commsBugTest.Chernarus.pbo (3.3 kB) neokika, 09/25/2011 20:59


Related issues

related to ARMA2 Community Issue Tracker - Bug #14191: Object synchronization in Multiplayer at > 1.5km not prec... Closed 10/05/2010 12/01/2011
related to ARMA2 Community Issue Tracker - Bug #24146: JIP during briefing causes new player to not be able to c... Assigned 09/04/2011 12/04/2011
related to ARMA2 Community Issue Tracker - Bug #19213: JIP players do not register on other clients at extreme r... Duplicate 04/26/2011 12/20/2011
related to ARMA2 Community Issue Tracker - Bug #27200: JIP Players don't synchronise until they get close to you Closed 12/20/2011 12/20/2011
related to ARMA2 Community Issue Tracker - Bug #26968: When the player occupies a camera, he transmits direct co... Assigned 12/10/2011

History

Updated by Sickboy over 3 years ago

  • Status changed from New to Feedback
  • Assignee set to neokika
  • Priority changed from Urgent to Normal
  • Target version deleted (1.59.79384)
  • Affected ArmA II version changed from Please select... to 1.59.79384

Can it be reproduced with the latest beta version on both server and client?
http://www.arma2.com/beta-patch.php

Updated by neokika over 3 years ago

Yes, we did the same test just now with latest beta patch on all clients and server - Build 84868 - and the issue it is still there.

Thanks,
neo

Updated by kju over 3 years ago

You mean communicate via ingame VON?

Updated by neokika over 3 years ago

Yes, although it seems more of a MP syncronization issue then VON problem.

neo

Updated by kju over 3 years ago

Ok thanks.

What MinErrorToSend value do you use both on the server and for the clients?
Ref: http://community.bistudio.com/wiki?title=basic.cfg

Updated by neokika over 3 years ago

First Test (1.59):
MinErrorToSend = 0.01

Second Test (84868 and different server):
MinErrorToSend = 0.001

Seems that the behaviour was exactly the same.

neo

Updated by kju over 3 years ago

ok ty

Updated by Sickboy over 3 years ago

  • Status changed from Feedback to Assigned
  • Assignee changed from neokika to Dwarden
  • Affected ArmA II version changed from 1.59.79384 to 1.60 BETA

Updated by Suma over 3 years ago

Please, clarify repro steps: What "communication" is this about, VON, chat or both?

I was unable to reproduce the issue so far (build 86060). Both chat and VON worked fine for all players for me.

Updated by neokika over 3 years ago

Suma wrote:

Please, clarify repro steps: What "communication" is this about, VON, chat or both?

I was unable to reproduce the issue so far (build 86060). Both chat and VON worked fine for all players for me.

It's VON and chat communication, so both.
Make sure that you move (or teleport) far away (> 5000m) from the spawn position before last player joins.

neo

Updated by Dwarden over 3 years ago

  • Target version set to Upcoming version

Updated by Suma about 3 years ago

Might be fixed with #27200, worth retesting.

Updated by neokika about 3 years ago

I can confirm this is fixed in 1.60. Ty.

Updated by kju about 3 years ago

  • Status changed from Assigned to Closed
  • Target version changed from Upcoming version to 1.60.87580

Also available in: Atom PDF