Bug #24875

OA beta patch 84868 direction of new created vehicles not updated immediately on clients when running on dedi servers

Added by Xeno almost 4 years ago. Updated over 3 years ago.

Status:Closed Start date:09/25/2011
Priority:Normal Due date:10/19/2011
Assignee:Suma % Done:

0%

Category:Multiplayer
Target version:1.60.87580
Affected ArmA II version:1.60 BETA First affected build:Please Specify...
Reproduced by another DH user:Yes First affected ArmA II version:1.60 BETA
I am using some Mods:No Single / Multi Player?:
I am using:OA only BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

The direction of new created vehicles on dedicated servers is not updated immediately on clients.
The vehicle slowly turns to the direction issued by a setDir after creation.

Expected
The new direction should be available on clients immediately.

See also the following video:
http://www.youtube.com/watch?v=Urx84qqTx2I

Attached is a simple test mission, please run on a dedicated server.
The two tanks are destroyed with setDamage 1, then deleted and a new destroyed one is created with the same direction and position.
You can clearly see that the new tanks slowly turn into the previous direction.

mpdirection.Desert_E.pbo.7z (1.1 kB) Xeno, 09/25/2011 12:07

mpSetDirSlow.Desert_E.zip - Show slow rotation with setDir right after createVehicle (1.2 kB) Suma, 10/12/2011 12:00

History

Updated by Xeno almost 4 years ago

I forgot to mention that something similar also happens with new created AI (either normal infantry units or AI in vehicles).

Once created they slide to the new position and direction instead of moving there normally.

Updated by kju almost 4 years ago

  • Due date set to 12/01/2011
  • Category set to Multiplayer
  • Affected ArmA II version changed from Please select... to 1.60 BETA
  • Reproduced by another DH user changed from No to Yes
  • Reproducible for you changed from No to Yes
  • First affected ArmA II version changed from Please select... to 1.60 BETA

Confirmed. Still works fine with 1.59.

Most likely due to the change in setDir and setPos handling.

Updated by zGuba almost 4 years ago

  • Status changed from New to Assigned
  • Assignee set to Dwarden
  • Language deleted (Please set for missions)

Updated by zGuba almost 4 years ago

  • I am using set to OA only

Updated by Fireball almost 4 years ago

  • Assignee changed from Dwarden to Suma

This is one for Suma, I believe.

Updated by Xeno almost 4 years ago

Not fixed in 84984

Updated by Suma almost 4 years ago

  • Status changed from Assigned to Resolved

Fixed in 85002

Updated by kju almost 4 years ago

  • Due date deleted (12/01/2011)
  • Target version set to Upcoming version

Updated by Sickboy almost 4 years ago

  • Target version changed from Upcoming version to 1.60 BETA

Updated by Master85 over 3 years ago

I can confirm it's fixed in 85015

Updated by kju over 3 years ago

  • Status changed from Resolved to Closed

Updated by Fireball over 3 years ago

  • Status changed from Closed to Feedback

This is regressed again or still not fixed in build 85330.

I can see it happen clearly on server-spawned items, e.g. in Warfare BE V2.070 Lite CO debug - Zargabad, which we used to debug #25095, when run on a DS. Within the minute helos are spawning and they're turning very slowly in the right direction.

Updated by kju over 3 years ago

  • Due date set to 10/19/2011

Updated by Fireball over 3 years ago

Yeah, the attached mission is not applicable, but the observed issue is the same. I'll try to create a new one when I found out how it shows.

Updated by kju over 3 years ago

What Fireball is saying that he sees the issue in Warfare, but it cannot be reproduced with this one.
He will investigate to find a repro.

Updated by Suma over 3 years ago

I can reproduce it in the Benny Warfare debug mission quite easily.,
What I can see in the Benny Warfare is the createVehicle is not followed with setDir immediately, some other things are done meanwhile, therefore . The trouble is what you see is technically correct. The vehicle is first created facing north (createVehicle currently does not support orienting vehicle at the creation time) and later turned using setDir. There is no specific message for setDir, therefore the client smooths the movement as it would do with any other movement. A proper fix would be to implement a new variant of createVehicle, where you provide the direction as well, and use this variant in the mission for vehicle creation.

However I understand there might exist plenty missions working like this, and adjusting all of them may be unreasonable. I will think about some engine side workaround.

Updated by Xeno over 3 years ago

I was already wondering why I couldn't reproduce it anymore, I'm always using setDir after createVehicle array...

Updated by kju over 3 years ago

My take:
People need to adjust their missions (if necessary).
There is a working and simple solution - apply setDir immediately after vehicle creation.

Sure createVehicle with direction would be nice, but I'd personally prefer the effort spent
on other scripting issues or new SQF commands instead.

Updated by Suma over 3 years ago

People need to adjust their missions (if necessary).

People are us as well in this case, the problem shows in official Warfare missions as well.

apply setDir immediately after vehicle creation.

What I find as a problem here is what is "immediately" (does it matter if there are a few script instuction in between? How much is too much?), and if this is really guaranteed to work. The trouble shows whenever the server manages to send a position update before the setDir is executed. I will check when exactly this can happen.

Updated by Suma over 3 years ago

I have created a simple example with setDir immediately after createVehicle, yet is still shows slow rotation consistently.

I have a fix ready, however I am unable to make that fix backward compatible with 1.59 without increasing network traffic, which I would like to avoid.

I have implemented the fix, but it is "sleeping" until 1.60, with no verification possible before version increase (i.e. before 1.60 Release Candidate).

Updated by ViperMaul over 3 years ago

When you are ready you could make an official public release candidate and wake up changes like this to give us an opportunity to help you confirm the fix. I believe you have used the release candidate method on a previous patch.

Apologies if this is what you meant already.

Updated by Suma over 3 years ago

This fix was awaken by releasing 1.60 beta 86277

Updated by kju over 3 years ago

Hm I still see the spawned tank to turn slowly in 86277 (both client and server).

Can someone else please test.

Updated by kju over 3 years ago

  • Status changed from Resolved to Closed

Works now fine (86652).

Updated by kju over 3 years ago

  • Target version changed from 1.60 BETA to 1.60.87580

Also available in: Atom PDF