Bug #24631

Reveal is very Baised

Added by F2kSel over 3 years ago. Updated almost 3 years ago.

Status:Closed Start date:09/18/2011
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:AI Issues
Target version:1.60.87580
Affected ArmA II version:1.60 BETA First affected build:Arma2
Reproduced by another DH user:Yes First affected ArmA II version:1.09.78183
I am using some Mods:No Single / Multi Player?:
I am using:CO (OA+A2) BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

When using the reveal command it works better for one side than the other.
It also only seems to have a limited range 25 meters (I accept this may be by design).

I've tested Arma2, OA and latest OA Betas and get the same results.

Reproduction
I have set up a trigger to issue the reveal command to both units at the same time.
Load the example and observe the results.

Obervation
West responds instantly and would kill East except it has no ammo, wait long enough and East will eventually turn to West.

Expected
Both units to react in the same manner.

Bug_Reveal.utes.7z (962 Bytes) F2kSel, 09/18/2011 20:35

Reveal.utes.7z - More logging/chat info (1 kB) kju, 09/19/2011 05:58


Related issues

related to ARMA2 Community Issue Tracker - Feature #12417: Enhance the command reveal - allow to specify the knowled... Closed 07/28/2010
related to ARMA2 Community Issue Tracker - Bug #12405: the command reveal doesn't fully reveal as it should Rejected 07/28/2010
related to ARMA2 Community Issue Tracker - Bug #25603: AI Spotting and Engagement decreased (Arma 2 : OA beta bu... Rejected 10/18/2011 11/01/2011

History

Updated by kju over 3 years ago

  • File Reveal.utes.7z added
  • Description updated (diff)
  • Assignee set to Dwarden
  • Operating system deleted (WinXP 32 bit)
  • Graphics card deleted (ATI5850)
  • Graphics card driver version deleted (10.6)
  • Reproduced by another DH user changed from No to Yes
  • CPU deleted (i5 750)
  • System RAM size deleted (4000)
  • GPU VRAM size deleted (1024)

Updated by kju over 3 years ago

I can confirm the issue on close distance too. However when further apart it cannot be observed.

To the basics: Reveal sets knowsAbout level to 1 about the target unit.
For some reason at close distance for west/the west AI it changes to 4 immediately.
This leads to the way quicker turn and engagement reaction of the west AI.


That aside the reveal command needs serious improvements to be a lot more useful. See ref tickets.

Updated by Suma over 3 years ago

Is is really biased to West, or is it biased to a side friendly to a player? What difficulty settings?

Updated by kju over 3 years ago

The player is civilian. The player also has set:

civilian setFriend [east,1]

(no idea why - F2kSel has to explain)

Both AI units have default skill (skill=0.58936644;).
F2kSel has used Regular difficulty according to his ticket.
I have tested with veteran.

Updated by F2kSel over 3 years ago

Yes I did try playing about with friendly settings but got the same result. I even place the civilian on the other side of the island in case he was revealing the OPFOR but again got the same result.

Updated by Suma over 3 years ago

  • Status changed from New to Assigned

I consider it strange enough to warrant a check, then.

Updated by Suma over 3 years ago

  • Assignee changed from Dwarden to Suma

Updated by zGuba over 3 years ago

Isn't it an config related accuracy problem? RU_Soldier_Base has accuracy lower than USMC_Soldier_Base, thus it would probably be recognized as enemy earlier.

http://browser.dev-heaven.net/configclasses/config/CfgVehicles%3EUSMC_Soldier_Base?version=48
accuracy = 2

http://browser.dev-heaven.net/configclasses/config/CfgVehicles%3ERU_Soldier_Base?version=48
accuracy = 1.5 - should be 2 as well

There are also other issues like this with OA units, most notably guerillas and militiamans:

http://browser.dev-heaven.net/cfg_vehicles/config/TK_INS_Soldier_Base_EP1?version=48
http://browser.dev-heaven.net/cfg_vehicles/config/TK_GUE_Soldier_Base_EP1?version=48
accuracy = 0.7

Due to this inconsistency they all will be probably engaged much earlier than other units.

Updated by Suma over 3 years ago

  • Status changed from Assigned to Resolved
  • Assignee deleted (Suma)

@zGuba: I do not thing config inconsistencies are explanation here, as units are very close and easy to recognize.

Debugging has shown a bug introduced when suppressive fire was implemented (rev. 47448, 19.9.2007). As as a result of the bug, unidentified enemy targets were actively watched only for a very brief moment. For some reason this moment was always hit by the west unit, but never by the east one (perhaps somehow related to the order in which AI for "centers" is performed). With this bug fixed, both units react very fast, as expected.

Fixed 84692

Updated by kju over 3 years ago

  • Target version set to Upcoming version

Excellent news. Sounds like a subtle but significant issues sorted!

Updated by maturin over 3 years ago

Remember that Chernarussian civilians are in fact friendly to West and hostile to East, even though they are non-combatants. You need to test as an animal.

Updated by F2kSel over 3 years ago

I still get the same result, you can even test as Opfor looking at Blufor and still Blufor reacts quickly compared to Opfor.

The only time I got Opfor to react in the same way was to change Blufor Soldier for an M2 static gunner or Hummer.

Updated by zGuba over 3 years ago

  • Due date set to 12/18/2011

Sounds great!

maturin wrote:

Remember that Chernarussian civilians are in fact friendly to West and hostile to East, even though they are non-combatants. You need to test as an animal.

civilian setFriend [east,1]

Updated by Sickboy over 3 years ago

Civilians should be friendly to any side.
I bet Chernarussian Civilians are simply set to West side or are of Resistance side?

Updated by kju over 3 years ago

yep

Updated by Sickboy over 3 years ago

F2kSel wrote:

I still get the same result, you can even test as Opfor looking at Blufor and still Blufor reacts quickly compared to Opfor.

The only time I got Opfor to react in the same way was to change Blufor Soldier for an M2 static gunner or Hummer.

That's expected, as 689 was yesterdays build, and it was fixed in 692 instead, which is available today in 731.
http://www.arma2.com/beta-patch.php

Updated by F2kSel over 3 years ago

I just tested the new patch and it seems very much improved.

Both units react equally dependent on skill settings.
Units respond well even if one is M2 Gunner.
Now works at Greater distances.
Last I don't know if this is intentional units react even behind buildings previously they reacted very slowly.

From my point of view it's working well.

Thanks guys.

Updated by kju over 3 years ago

  • Due date deleted (12/18/2011)
  • Status changed from Resolved to Closed
  • Target version changed from Upcoming version to 1.60 BETA

Confirmed fixed.

units react even behind buildings previously they reacted very slowly

Well they are revealed after all. 1 means they know the position.
They just cannot figure out the side yet (the accuracy config value of infantry is great than 1).

Updated by kju almost 3 years ago

  • Target version changed from 1.60 BETA to 1.60.87580

Also available in: Atom PDF