Bug #24558

Campaign issues - missing overdub dialog

Added by admin almost 4 years ago. Updated over 3 years ago.

Status:Closed Start date:09/16/2011
Priority:Normal Due date:
Assignee:Dwarden % Done:

0%

Category:Campaign
Target version:1.60.87580
Affected ArmA II version:1.60 BETA First affected build:84467
Reproduced by another DH user:No First affected ArmA II version:1.60 BETA
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC:BAF WIKIurl:

Description

I started BAF Lancers as a replay (no revert), and not only were there no squad member icons at bottom left, but there was no sound on the overdubbing of the guy talking, and the game never left the initial blurry state, and would not progress. > Had to abort. Same thing happens when any campaign mission is replayed.

http://forums.bistudio.com/showthread.php?t=124982&page=3
http://forums.bistudio.com/showthread.php?t=124982&page=2

Repro:

- start attached mission
- use radio ALPHA

Observed:

???

Expected:

???

kbTellTest.Desert_E.7z - Repo mission (1 kB) Varanon, 09/16/2011 15:19

History

Updated by admin almost 4 years ago

  • Description updated (diff)

Updated by rok almost 4 years ago

  • Reproduced by another DH user changed from No to Yes

Updated by Varanon almost 4 years ago

Updated by Varanon almost 4 years ago

For the repo mission, use radio ALPHA to reproduce. It simply executes kbAddTopic/kbTell

Updated by Fireball almost 4 years ago

  • Category set to Campaign
  • Status changed from New to Assigned
  • Assignee set to Dwarden
  • Reproduced by another DH user changed from Yes to No
  • Reproducible for you changed from No to Yes
  • Related to content of DLC set to BAF

Updated by kju almost 4 years ago

  • First affected build changed from Please Specify... to 84467

Guess Who

Communications from HQ broken in Warfare. No audio and no chat messages. Last good version was build 84426.

Ref: http://forums.bistudio.com/showpost.php?p=2023664&postcount=26

Updated by OMAC almost 4 years ago

Seek and Destroy BAF scenario will not end even if all objectives have been completed, as the overdub dialog at the end doesn't occur. Have to abort to end scenario. Also no overdubbing dialog by HQ at start of scenario. beta 84628.

Updated by Suma almost 4 years ago

  • Description updated (diff)

Updated by Suma almost 4 years ago

  • Status changed from Assigned to Feedback

The issue from the repro mission is fixed in 84672. However, contrary to description the issue did not start with 84467, but with public beta 84527, with the change

[84478] Improved: loading of binarized bikb files now supported.

Perhaps the repro is actually for a different issue?

Updated by Suma almost 4 years ago

  • Subject changed from Campaign issues to Campaign issues - missing overdub dialog

Updated by Suma almost 4 years ago

  • Status changed from Feedback to Resolved

As I cannot reproduce any missing dialog or titles after the 84672 fix, I suppose it was the same issue, only the build numbers were reported wrong.

Updated by kju almost 4 years ago

  • Target version set to 1.60 BETA

Updated by kju almost 4 years ago

  • Status changed from Resolved to Closed

Demo mission by Varanon works and was able to complete the BAF campaign without problems.

Updated by kju over 3 years ago

  • Target version changed from 1.60 BETA to 1.60.87580

Also available in: Atom PDF