Bug #24532

Crow goes desync/offset in MP

Added by Fireball over 3 years ago. Updated over 3 years ago.

Status:Closed Start date:09/15/2011
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:Multiplayer
Target version:-
Affected ArmA II version:1.60 BETA First affected build:Please Specify...
Reproduced by another DH user:Yes First affected ArmA II version:1.60 BETA
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

Crow goes offset after flying around a bit.

Observed

- Dead player isn't transferred into crow immediately but sees the crow from above for about 30 seconds (not sure if this is an issue, if it had been that way before)
- Crow is going offset in MP by about 2-3 m, noticed by one player aiming at the crow and maybe shooing in the direction

Expected

- Crow should be at the same place on every client

Repro

- One client hosts a two player MP editor mission (may be empty except for two playable units)
- A second client joins
- Player two shoots player on host.
- Host player flies around in crow
- After a short moment the crow is at a different position on the host than on the remote client

I tested this together with zGuba, hence reproed by two DH users.

History

Updated by Suma over 3 years ago

  • Status changed from Assigned to Feedback

I have tested it with 84628 and I am unable to reproduce any significant displacement. The only issue I can see is birds do not have position interpolation implemented, which was likely to cause issues in builds 84464-84562, but not in newer builds (cf. #24413 note 9). As you did not write which particular build numbers were used in your test, I do not know it this explains what you see or not.

Updated by kju over 3 years ago

I cannot reproduce it either with 84628.

However with screenshots or a video I am not
quite sure to understand it right in any case.

Updated by zGuba over 3 years ago

The issue could have been caused by high desync I had on test session. However when I improved the odds of my connection, Fireball's crow was still offset. I believe that Fireball has video of that issue somewhere.

Updated by Fireball over 3 years ago

  • Status changed from Feedback to Closed
  • Assignee deleted (Suma)

I filed the ticket, because I also could repro it "alone" by starting two clients, not only because I reproed it with zGuba, but that was with the previous build (the actual one at this time, 1 day ago - my bad to omit the build no).

But now I cannot repro with current build, so it might have been fixed as a sideeffect. Closing down.

Also available in: Atom PDF